none
Removing failed hard disk RRS feed

  • Question

  • Hi,

    I've been trying to sort this out for days now so welcome any support.

    One of the hard disks has failed completely in my WHS therefore is showing up as missing and I cannot remove gracefully using the remove disk function in WHS Console in the storage tab.

    I've read about re-installations sorting this issue out so I re-installed WHS and after re-installation I still cannot remove the drive the actual error I get is that their are file conflicts when I try to remove via remove method in Storage Tab. Further investigation shows that the demigrator service is not running. So I try to manually start demigrator and it will not start.

    Therefore how can I forcefully remove my hard disk please from the hard disk pool? Have to say Microsoft also very disappointed that considering this is a consumer product hence the words 'Home Server' that it doesn't not seem to be a simple task nor can I find any documentation on the procedure for complete hard disk failure anywhere - very poor in my opinion

    So can someone please help me as my WHS is off at the moment as I can't afford for backups, file duplication, etc not to be working :-(

    Thanks

    Monday, March 7, 2011 11:59 AM

All replies

  • Did you already physically remove the failed disk? If not, try this first.

    If the server still is rejecting to remove the drive from console, you may have to edit the registry on the server.

    Be aware, that a failed disk may causing loss of non duplicated shared folders as well as loss of the backup database, if parts of it have been stored on the drive.

    Best greetings from Germany
    Olaf

    Monday, March 7, 2011 1:26 PM
    Moderator
  • Olaf,

    The drive is completely dead so when you say did I physically remove it. I don't have an option.

    Therefore what would you suggest?

    Thanks

    Monday, March 7, 2011 1:56 PM
  • Physical removing normally should allow to remove the disk via console. Accept all the warnings and go on.

    Only if this fails, try the method described in this thread.

    Best greetings from Germany
    Olaf

    Monday, March 7, 2011 10:57 PM
    Moderator
  • Thanks Olaf,

    I tried to accept all the warning but I still get a file conflicts error which stops me from removing the drive from the pool.

    Can't say that I am happy at all in having to edit the registry to now remove the drive. Do you agree this is a bug? I have logged it as a bug https://connect.microsoft.com/WindowsHomeServer/feedback/details/650135/gracefully-remove-failed-missing-hard-disk-from-whs-v1

    and would welcome your support and others who think that this should be something addressed within WHS or with a separate utility or something  as this is a 'Home Server' and therefore I shouldn't ever have to do something as drastic as edit the registry for something such as this which I am sure has happened to others in the past and will continue to happen for people in the future

    Thanks
    Tuesday, March 8, 2011 3:36 PM
  • Update.

    I have tried to register this as a bug using the Feedback option only to be told that Feedback is only for bugs in Vail. So I've asked how to register a bug in WHS v1 and been told to ask the question here in the forums which I've done. Thanks for your response Olaf however I don't feel comfortable editing my registry nor do I think that the onus should be on me to edit the registry for a consumer/home server product that the hard disk has failed in.

    For me there should be some way of removing a failed hard disk without the need to edit the registry and if registry editing is required this is a bug - pure and simple - bug.

    So does anyone have any advice please on how to get Microsoft to recognise this is a bug and therefore potentially provide a fix please?

    Thanks

    Tuesday, March 15, 2011 12:15 PM