locked
Successful CRM outlook client deployment but with errors RRS feed

  • Question

  • I am deploying the CRM outlook client with rollup 7 via SCCM using the "setupclient.exe" /Q /L C:\WINDOWS\TEMP\crmclientw7.log INSTALLLEVEL=2" command line.

    As far as the logs tell me, the client installs successfully but there are still some errors in the logs that I want to get my head around as I am having problems incorporating the CRM install in a OSD task sequence.

    The first error is in the crm40setup.log where i think it is trying to get some updates. how do I stop this it get it to look at a valid URL?

    18:12:31|   Info| Starting download from http://go.microsoft.com/fwlink/?LinkId=164811&clcid=0x409
    18:12:31|   Info| Create the job key value Client.msp in the registry.

    18:12:31|   Info| Set the job key value Client.msp as  in the registry.

    18:12:32|   Info| Create a new job for file Client.msp.

    18:12:32|   Info| Open the registry key value Client.msp for the download job.

    18:12:32|   Info| Set the job key value Client.msp as {AA45F360-971F-4E34-A310-561FD8E9F55F}.

    18:12:32|   Info| Set the job guid {AA45F360-971F-4E34-A310-561FD8E9F55F} in the registry.

    18:12:32|   Info| Add the file Client.msp to the created job.

    18:12:32|   Info| Set MinimumRetryDelay to: 60 seconds.

    18:12:32|   Info| Set NoProgressTimeout to: 60 seconds.

    18:12:32|   Info| Set Priority to BG_JOB_PRIORITY_FOREGROUND.

    18:12:32|   Info| Create the notify interface.

    18:12:32|   Info| Register notify interface.

    18:12:32|   Info| Set the notify flags to BG_NOTIFY_JOB_TRANSFERRED
    18:12:32|   Info|  | BG_NOTIFY_JOB_ERROR | BG_NOTIFY_JOB_MODIFICATION.

    18:12:32|   Info| Start/resume the download job Client.msp.

    18:13:53|  Error| Error context : 5.

    18:13:53|  Error| Failed to get error description. Error : 0x80070717.

    18:13:53|  Error| Job Client.msp encountered the BG_JOB_STATE_ERROR.

    18:13:53|   Info| The file Client.msp has not been downloaded.

    18:13:53|  Error| Error on download:  0x       0
    18:13:53|   Info| Open the registry key value Client.msp for the download job.

    18:13:53|   Info| Set the job key value Client.msp as .

    18:13:54|   Info| Cancel the download job Client.msp.

    18:13:54|   Info| Clean up the BITS downloader.

    18:13:54|   Info| Uninitializing COM.
    18:13:54|   Info| Uninitialized COM.
    18:13:54|   Info| Starting download from http://go.microsoft.com/fwlink/?LinkId=164811&clcid=0x409
    18:14:15|  Error| Error on download:  0xc0040202
    18:14:15|  Error| The specified update file could not be found or it could not be accessed.
    Thursday, February 25, 2010 11:49 AM

Answers

  • Hi,

    I was looking at my CRM40Setup.log (client) and found similar errors; however, I was able to install the client successfully.

    I have tested the installation via SCCM and it was successful.

    Do you see the following on the log

    Info| Start/resume the download job SQLEXPR.EXE.
    or
    Info| Start/resume the download job vcredist_x86.exe.

    The command I used was:

    SetupClient.exe /Q /L "c:\clientinstalllog.txt" /targetdir "c:\program files\Microsoft Dynamics CRM" INSTALLLEVEL=2

    Is there more information you can provide?
    Errors logged other than the file not downloaded.

    Friday, February 26, 2010 9:34 PM

All replies

  • It looks that it's trying to download update for installator but website it not exist.
    What CRM outlook client version do you have (which build).
    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    Thursday, February 25, 2010 5:50 PM
  • exe shows as 4.0.7333.2138 which i think is the latest one
    Friday, February 26, 2010 9:42 AM
  • Hi,

    I was looking at my CRM40Setup.log (client) and found similar errors; however, I was able to install the client successfully.

    I have tested the installation via SCCM and it was successful.

    Do you see the following on the log

    Info| Start/resume the download job SQLEXPR.EXE.
    or
    Info| Start/resume the download job vcredist_x86.exe.

    The command I used was:

    SetupClient.exe /Q /L "c:\clientinstalllog.txt" /targetdir "c:\program files\Microsoft Dynamics CRM" INSTALLLEVEL=2

    Is there more information you can provide?
    Errors logged other than the file not downloaded.

    Friday, February 26, 2010 9:34 PM
  • I have been trying to install CRM via SCCM ("Install Application" task).  Currently, I have it as part of the a multiple application install option.   I am trying to install the Offline version--INSTALLLEVEL=3.  The documentation recommends installing "Only when user is logged on" which does not work with the OSD "Install Application" task.  After running the program "whether or not user is logged on", I am getting the message that a Reboot is required because IE is in the RunOnce key (see below).

    I am looking for help in deploying CRM 4.0 (laptop client) via OSD.  I would appreciate any help you have to offer.  Thanks! 

     

    12:28:01|   Info| === Setup bootstrap logging started 9/20/2010 12:28:01 PM ===
    12:28:01|   Info| Bootstrap version: 4.0.7333.2747.
    12:28:01|   Info| User: SYSTEM.
    12:28:01|   Info| Invoked with command line: "\\DP\SMSPKGF$\SCM00133\setupclient.exe" /Q /L "c:\CRMInstall.txt" /targetdir "c:\program files\Microsoft Dynamics CRM" INSTALLLEVEL=3
    12:28:01|   Info| Running \\DP\SMSPKGF$\SCM00133\setupclient.exe
    12:28:01|   Info|  is not currently installed.
    12:28:01|   Info| System Memory: 2134814720 Bytes
    12:28:01|Warning| Error RebootError
    12:28:01|  Error| Error: Reboot required
    12:28:01|  Error| Key Found: HKLM\Software\Microsoft\Windows\CurrentVersion\RunOnce contains iessetup
    12:28:01|   Info| Clean up the BITS downloader.

    12:28:01|   Info| Clean up the BITS downloader.

    12:28:01|   Info| Clean up the BITS downloader.

    12:28:01|   Info| === Setup bootstrap logging ended 9/20/2010 12:28:01 PM ===

     

    Monday, September 27, 2010 8:16 PM
  • Are you trying to install IE before CRM? Try a reboot after the IE install and then start the CRM install.

    That should get rid of the HKLM\Software\Microsoft\Windows\CurrentVersion\RunOnce key

    Monday, September 27, 2010 8:54 PM
  • Thanks for the response.  IE automatically runs when you 1st logon to W7.  After the W7 wim has been installed via OSD, the runonce settings are not run until a user logs on for the 1st time.   I tried to remove the IESETUP Value before the CRM install (scripted it as part of the package), but CRM is complaining about anything in the RunOnce Key (see below).  I can install outside of OSD, of course, but I am hoping someone has been successful in installing CRM on a system as part an OSD Task Sequence.  I appreciate your help.

    15:31:10|   Info| === Setup bootstrap logging started 9/28/2010 3:31:10 PM ===

    15:31:10|Warning| Error RebootError
    15:31:10|  Error| Error: Reboot required
    15:31:10|  Error| Key Found: HKLM\Software\Microsoft\Windows\CurrentVersion\RunOnce contains wmssetup
    15:31:10|   Info| Clean up the BITS downloader.

    15:31:10|   Info| Clean up the BITS downloader.

    15:31:10|   Info| Clean up the BITS downloader.

    15:31:10|   Info| === Setup bootstrap logging ended 9/28/2010 3:31:10 PM ===

    Tuesday, September 28, 2010 8:43 PM
  • I think I have the answer on this one..
    Have have done many hours of troubleshooting. To bad that I didn't find this thread earlier.

    The solution is to delete the whole RunOnce key while installing the client. You cant just delete the values inside. The key must me deleted.

    I run my installation in a Task Sequence. Advertisement is set to run at Logon.
    Here is my TS for deploying CRM client with RollupPack 15.
    --------------------------------------
    Run Command Line - Extract to local filesystem
     CRMv4.0-i386-client-ENU.exe /extract:%TEMP% /q

    Run Command Line - RunOnceFixBegin
     regedit.exe /e %temp%\RunOnceExport.reg "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce"
     reg delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce /f

    Run Command Line - Install Client
     %TEMP%\setupclient.exe /q

    Run Command Line - Wait for installation to finish
     cmd /c ping localhost -n 60 > nul

    Install Update - Install Update
     CRMv4.0-KB2449283-i386-Client-ENU.exe /q

    Run Command Line - Wait for installation to finish
     cmd /c ping localhost -n 60 > nul

    Run Command Line - RunOnceFixEnd
     Restore the exported RunOnce
     regedit /s %temp%\RunOnceExport.reg

    --------------------------------------

    My package contains only 2 files. I run every step in TS with no account specified. I dont extract the source files in package source becouse the Client is 28MB unextracted and 130MB extracted. The BITS will also have problem if you have the sourcefiles for the client extracted in the Package.
    CRMv4.0-i386-client-ENU.exe (The Client)
    CRMv4.0-KB2449283-i386-Client-ENU.exe (The Update)

    This is the worst installer in the world........

    Take Care!

    Sunday, March 6, 2011 3:31 PM