locked
Accessing WHS with remote desktop RRS feed

  • Question

  • Before I start I want to say that I know this is not the way the WHS is meant to be managed but I have a unique case where this is required.

    My WHS also serves as my master server for my home automaion software, I have been logging into the administration account to mange this with no problems for months. I want to use a Nokia N800 as a interface viewer for my home automation system but the interface viewer is windows only so i cant directly load it onto the nokia. What people have been doing to get around this is to start a remote desktop session with the interface viewer in kiosk mode. this means that it covers the entire desktop, the desktop is inaccesible so I dont have to worry about breaking anything in WHS.

    This link shows what I want to do: http://www.charmedquark.com/vb_forum/showthread.php?t=6678&highlight=N800

    The only help that I really need from the WHS forums is how to setup a second user other than administrator that can access the WHS via RDP.

    I hope that this isnt inappropriate to ask here and appreciate any help
    -Mike
    Tuesday, September 23, 2008 6:12 PM

Answers

  • Hi Mike,
    as you mentioned, allowing other user accounts for Remotedesktop session is not intended, but it is possible.
    I have done this one time several month ago, let me see, if I can recapitulate the steps:
    (I have only a German version of WHS running, so the translation back may not be exactly.)
    1. Logon to the desktop of your WHS as Administrator.
    2. In Start Menu, right click My Computer and select Manage.
    3. Navigate to Local users and Groups/Users.
    4. Select the user account you want to allow Remotedesktop access and double click on it.
    5. Click on Member tab and verify, if the account is member of Remotedesktop users.
    6. If he is not, add him to that group. He should also have a complex enough password.
    7. Now click Start/Run and type gpedit.msc.
    8. Navigate to Computer Configuration / Windows Settings / Security Settings / Local Policies / User Rights and double click Log on through Terminal Services.
    9. Add the User account to the list.
    10. Click OK, close group policy editor and try.

    Best greetings from Germany
    Olaf
    Tuesday, September 23, 2008 6:57 PM
    Moderator