locked
Import mapping lookup field to deactivated records RRS feed

  • Question

  • 2011 CRM on premise with update 11

    I'm importing contacts with a mapping to account.  The import fails on some records because it thinks there is more than one company with the same identical name and it does not know which one to map too.  There is an active and inactive account with the same name.  When I delete the disabled account and then retry the import it works.  

    I  did not see a way to configure the import to map to only active records.  Thinking it might be related to account views, I checked my account views and they are all looking at a active records.

    Is there a way to control this?


    Scott Clancy

    Tuesday, January 29, 2013 10:50 PM

Answers

  • I don't think there is any way to specify a "where" clause in the import to only look for active records. So if doing something with the inactive records isn't an option I think your best alternative might be to identify the duplicates (export all accounts and statuses to Excel) and in your import file replace the account names of the duplicates with the GUID value.

    Then when mapping your import, set the parent customer to look like this: Account (Primary Key); Account Name



    Jason Lattimer
    My Blog -  Follow me on Twitter -  LinkedIn

    Wednesday, January 30, 2013 2:50 AM
    Moderator
  • It's a mystery why the routine would map to inactive records.  What's the point?

    So I'm going to make sure my import file has a column labeled Account (Primary Key) for the GUID and then one for the Account Name with the name of the account.

    Thanks

       


    Scott Clancy

    Wednesday, January 30, 2013 8:44 PM

All replies

  • I don't think there is any way to specify a "where" clause in the import to only look for active records. So if doing something with the inactive records isn't an option I think your best alternative might be to identify the duplicates (export all accounts and statuses to Excel) and in your import file replace the account names of the duplicates with the GUID value.

    Then when mapping your import, set the parent customer to look like this: Account (Primary Key); Account Name



    Jason Lattimer
    My Blog -  Follow me on Twitter -  LinkedIn

    Wednesday, January 30, 2013 2:50 AM
    Moderator
  • It's a mystery why the routine would map to inactive records.  What's the point?

    So I'm going to make sure my import file has a column labeled Account (Primary Key) for the GUID and then one for the Account Name with the name of the account.

    Thanks

       


    Scott Clancy

    Wednesday, January 30, 2013 8:44 PM