locked
Password Prompt when opening an email activity in CRM 4.0 webclient RRS feed

  • Question

  • I open any Account, select History from the left hand pane, open an email activity and I am then prompted for user name and password.  Hit cancel a few times and it disappears and I can then carry on as normal.

    I was originally setup so the email router dealt with my emails but I have since discovered that it was setup in correctly.  I now use Outlook to deal with my emails but this has made a difference.

    My sercurity roll gives me full access to CRM.  The server had Update Rollup 4 when I first noticed the problem but it now has Update Rollup 5.  However, I still have UR4.  I have had a look on Google but couldnt find any thing that matched my problem.

    Please advise

    MWac
    Monday, August 24, 2009 1:54 PM

Answers

  • I saw this issue in 3.0 but haven't seen it in 4.0.  You can try this and see if it works.  It worked for 3.0.

    Always backup your registry before making changes.  Also, you should update your client to Rollup 5 if you are able.

    1.


    Click
    Start, click Run, type regedit in the Open box, and then click OK.

    2.

    Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_SUBDOWNLOAD_LOCKDOWN

    3.

    Right-click Outlook.exe, and then click Modify.

    4.

    In the Value data box, type 0, and then click OK.

    5.

    Exit Registry Editor.


    Best Regards, Donna
    Monday, August 24, 2009 3:42 PM

All replies

  • I saw this issue in 3.0 but haven't seen it in 4.0.  You can try this and see if it works.  It worked for 3.0.

    Always backup your registry before making changes.  Also, you should update your client to Rollup 5 if you are able.

    1.


    Click
    Start, click Run, type regedit in the Open box, and then click OK.

    2.

    Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_SUBDOWNLOAD_LOCKDOWN

    3.

    Right-click Outlook.exe, and then click Modify.

    4.

    In the Value data box, type 0, and then click OK.

    5.

    Exit Registry Editor.


    Best Regards, Donna
    Monday, August 24, 2009 3:42 PM
  • If this tip does not work, consider installing a tool like Fiddler 2.  Then run it while reproducing the error.  This HTTP tracer should tell you which exact file is triggering the NTLM challenge, you can then narrow your search to fixing the file in question (if it is related to a single request or so).

    http://www.fiddler2.com/fiddler2/

    || Aaron Elder - Dynamics CRM MVP || http://www.ascentium.com/blog/crm
    Tuesday, August 25, 2009 5:20 PM