none
SyncToy not backing up every file in a directory? RRS feed

  • Question

  • Hi folks,

    I'm new to SyncToy - I've just set up a couple of folder pairs "My Documents" and "Desktop" to Echo from my laptop to my NAS over WLAN.

    It runs fine without errors, but there are a fewer files in the echo'd directory on the NAS than there are in the original directory!  It's set up to copy everything with no exceptions.

    What's going on!?

    A side issue: backing up the "Desktop" directory leaves a "synctoy-xxxxxxx.dat" file on my desktop - can I delete it as it looks messy, or is there a way of moving it elsewhere?
    Friday, May 29, 2009 6:19 PM

All replies

  • Done a bit more investigation - files missing seem to be thumbs.db and the like - ie hidden system files.

    But in the synctoy prefs the exclusions boxes for system/hidden are UNchecked - ie, it should be copying these files.

    So why isn't it?

    And how can I get rid of the synctopy-xxxxxxxxxxx.dat files, or at least move them to a temp directory?  Looks horrible with it on my desktop...
    Friday, May 29, 2009 8:02 PM
  • Hi -

    It is not all hidden system files but specifically thumbs.db and desktop.ini ( which have the hidden + system attribute ) on them that we do not sync. We will attempt to sync all other files and provider errors on those that we cannot. We determined that these two files do not make much sense transferred to a different system.

    You cannot move the synctoy.*dat files because these are our system files that we use to sync. You can however add the hidden attribute on this file to not show up on your desktop.

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Friday, May 29, 2009 8:56 PM
    Moderator