locked
VSS error 8194 on Client backup RRS feed

  • Question

  • Setup a new computer and have been unable to run even the first client backup on WHS 2011.  Event Viewer lists the error as follows:

    Log Name:      Application
    Source:        VSS
    Date:          11/20/2011 2:08:48 PM
    Event ID:      8194
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      Backcomputer7
    Description:
    Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface.  hr = 0x80070005, Access is denied.
    . This is often caused by incorrect security settings in either the writer or requestor process.

    Operation:
       Gathering Writer Data

    Context:
       Writer Class Id: {e8132975-6f93-4464-a53e-1050253ae220}
       Writer Name: System Writer
       Writer Instance ID: {8afef8ba-65cb-43ed-8c00-97c13a55d2c5}
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="VSS" />
        <EventID Qualifiers="0">8194</EventID>
        <Level>2</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2011-11-20T19:08:48.000000000Z" />
        <EventRecordID>1279</EventRecordID>
        <Channel>Application</Channel>
        <Computer>Backcomputer7</Computer>
        <Security />
      </System>
      <EventData>
        <Data>0x80070005, Access is denied.
    </Data>
        <Data>

    Operation:
       Gathering Writer Data

    Context:
       Writer Class Id: {e8132975-6f93-4464-a53e-1050253ae220}
       Writer Name: System Writer
       Writer Instance ID: {8afef8ba-65cb-43ed-8c00-97c13a55d2c5}</Data>
        <Binary>2D20436F64653A20575254575254494330303030313236302D2043616C6C3A20575254575254494330303030313231342D205049443A202030303030313132382D205449443A202030303030323630382D20434D443A2020433A5C57696E646F77735C73797374656D33325C737663686F73742E657865202D6B204E6574776F726B53657276696365202020202020202D20557365723A204E616D653A204E5420415554484F524954595C4E4554574F524B20534552564943452C205349443A532D312D352D3230</Binary>
      </EventData>
    </Event>

    ---------------------------------------------------------------------------

    Have run VSSAdmin List Writer but no errors recorded.  Have stopped and started the VSS service.  Have liberalized the antivirus priveledges.  Have 4 more computers on this WHS without difficulties.  Don't know what to do next???


    • Edited by Mentj Sunday, November 20, 2011 8:38 PM
    Sunday, November 20, 2011 7:42 PM

All replies

  • I had much the same problem as you.  Looking around the 'Net, lots of people seem to be having the problem as well.  Mine was a two step fix.  First, I followed the instructions in the following link to correct what was causing the 8194 error on my computer:

    http://answers.microsoft.com/en-us/windows/forum/windows_7-system/vss-error-showing-in-event-viewer/34b62c1b-93e6-4848-a9a0-59e3f4019ebb

    This got rid of the 8194 error, but the client backup's still wouldn't work.  The only indications were in the Home Server console referencing that a snapshot couldn't be taken, and then in both the Home Server's and the Window's 7's "Windows Server" event log there were events having to do with the backup failing/problem with the client VSS writer.

    After doing the steps in the link above, I made sure that I didn't have any disk errors by running the chkdsk /f on the drive.  After that, I tried using the local Windows Backup and Restore and tried to take an image backup of my local computer (I had a second drive I could point it to).  This failed, citing a problem with VSS on my computer.  Searching on the events generated by this action I came across the following article from Microsoft:

    http://support.microsoft.com/kb/968128

    After performing the steps in this article I could now do a local snapshop backup to a second hard drive.  I tried running the Home Server from the console and now it's working.  I'm still going through that initial backup (41% and counting), but I have every reason to believe it will complete normally.  Hope this helps you out.

    Rich

    Wednesday, December 14, 2011 12:23 AM
  • On the client computer from the Start Menu, select Run
    The Run dialog opens.

    In the Open field type dcomcnfg and click OK.
    The Component Services dialog opens.

    Expand Component Services, Computers, and My Computer.
    Right-click My Computer and click Properties on the pop-up menu.

    The My Computer Properties dialog opens.

    Click the COM Security tab.
    Under Access Permission click Edit Default.

    The Access Permissions dialog opens.

    From the Access Permissions dialog, add the "Network Service" account with Local Access allowed.
    Close all open dialogs.
    Restart the computer.

    This has worked on all of my 5 clients having had the VSS Error logged each time a backup was pulled by the WHS2011 server.

               
    • Proposed as answer by Win7ine Friday, March 9, 2012 9:27 PM
    • Edited by Win7ine Friday, March 9, 2012 9:28 PM
    Friday, March 9, 2012 9:26 PM
  • I am having error VSS 8194 access denied and this did not work for me.
    Wednesday, May 16, 2012 1:50 AM
  • Hi,

    I would like to know if can use this solution for Windows 8.1 as have the same problem with VSS error 8194 on Client backup. Could you please send me screenshotswhen open Computer Properties dialog what to,  do step by step to add this Network Service. It will be helpfull for me. Have Polish version of Windows 8.1 anyhow if get the screenshots  it will be easier.

    Thanks in adavance and best regards,

    Ewa

    Thursday, June 23, 2016 9:29 AM