locked
CRM 4.0 E-Mail Router Configuration Manager RRS feed

  • Question

  • Outbound emails from CRM are not being sent at the moment.  I am using a SMTP relay server (not Exchange) which I can telnet to from the CRM server on port 25 and send an email, but if I try and send through CRM mail is never delivered.

    I have tried setting up the Config Profile Authentiction type with both Anonymouse and a Domain Admin account for testing with the same result.  In addition I have run into a problem where the Test Access function in the CRM Email Config Router will no longer complete.  I have left it running over night and the test never finishes.  It doesn't fail, but it doesn't succeed either. I have tried repairing the Email Router program several times.

    My Application/System logs are clean, no errors or warnings. 

    Any help would be greatly appreciated.

    There doesn't appear to be a CRM Forum Category, other than CRM Online (thanks MS) so if this is in the wrong place I apologize.

     

    Jason


    Thursday, August 12, 2010 5:04 PM

Answers

All replies

  • Hi Jason, this forum would be more helpful than the online forum: http://social.microsoft.com/Forums/en-US/crmdeployment/threads
    Phil Edry – Altriva Solutions – http://www.altriva.com/AltrivaBlog.aspx
    • Marked as answer by Jim Glass Jr Friday, August 13, 2010 7:33 PM
    Thursday, August 12, 2010 7:11 PM
  • Do the following :

    -> Check the MSCRM Email router service is running ...

    -> If it is , click on the properties of service,copy the location of "Path to Executable".

    -> Go to the copied location.. You will find a similar file like below

    Microsoft.Crm.Tools.EmailAgent.xml

    -> rename the file to some dummy name like xyz.xml.

    -> Now try to send mails now.

    The pending emails will take some time to deliver(nearly 15-30 mins).

     

    Hope this Helps.

     

    Rg

    Nag

     

     

     

    • Proposed as answer by nagubhai Friday, August 13, 2010 12:29 PM
    Friday, August 13, 2010 12:27 PM
  • Thanks Phil, I didn't dig far enough thanks for pointing me in the right direction.

    Friday, August 13, 2010 6:22 PM
  • Since the 'test access' for local data is not working, take a look at your application log in the event viewer and see what error you have.  Some of the issues I've run into with trying to setup SMTP include the following:

    • The user sending e-mail from CRM is not setup as a user with a valid password in the E-mail router
    • SMTP services on the CRM server are not configured correctly
    • The mail server does not allow relay
    • Mail server requires use a of different port - for example, I think Google uses 587 or something like that
    • E-mail router service is not running
    • async service is not running
    • Outgoing configuration for a user in the Email Router is not set correctly

    The place to start is the Application log file to see if there are errors.  Let us know if you find one that looks like it is related.


    Regards, Donna

    Monday, August 16, 2010 5:27 PM
  • Nag,

    I tried your fix, unfortunately renaming that .xml file kills the service and it can't be restarted. I renamed it and started the service. However, when I started the service I ran a test and it was successful. I tried sending another email, which was never delivered and now when I Test Access the test hangs again.

    Donna,

    There is one error that is related that recently starting popping up over the past few days. Looks like I have some more SQL cleaning that needs to be done.

    Event Type: Error
    Event Source: MSCRMEmail
    Event Category: None
    Event ID: 0 Date: 8/16/2010 Time: 9:14:17 AM
    User: N/A Computer: Server
    Description: #61346 - An error occurred while checking for outgoing e-mail messages to process for SMTP: http://server/company. System.Web.Services.Protocols.SoapException: Server was unable to process request. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Microsoft.Crm.Sdk.Proxy.CrmService.Execute(Request Request) at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.RequestEmailsToProcess(QueryExpression query) at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.RetrieveNextMessageInternal() at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.RetrieveNextMessage() at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run()\r\n 0x80044150 Generic SQL error.

    Platform For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    I am going to do some searching around to see if there is a fix out there.  If anyone has any thoughts I would love to hear them though.

    Thanks.

    Jason

     

    Tuesday, August 17, 2010 6:21 PM
  • started the service. However, when I started the service I ran a test and it was successful. I tried sending another email, which was never delivered and now when I Test Access the test hangs again.

    Donna

    Are you referring to the e-mail router service?  Are you saying that the service is not always running?  if that is the case, then you need to understand why that service is not running.  Maybe the login for the service does not have adequate rights on your network.  Try starting the service with a domain admin account (just for a test) and see if you get a different result.

    Regards, Donna

    Tuesday, August 17, 2010 6:31 PM
  • Thanks guys for the above, realy helpful. Now my question is why doe the "Microsoft.Crm.Tools.EmailAgent.xml" file gets corrupt

     

    Thanks

    Wednesday, September 1, 2010 10:59 AM