locked
XP Sp3 - Remote Access Via RDP BROKEN RRS feed

  • Question

  •  

    I'm having problems enabling this. I found the following post, but the ActiveX control is still not visible to allow me to enable it. Anyone have any other ideas on what I could do?

     

     

     

     

    Yes, there have been a few mentions of this problem. It's the 'upgraded' security model which comes with SP3.

    The reason for this is that the Terminal Services ActiveX control is disabled by default in XPSP3 as a security measure. You need to explicitly enable the Terminal Services ActiveX control in IE in order to use the ActiveX control. To do this you will need to do the following: 

     

    Click on Tools -> Manage Add-Ons -> Enable or Disable Add-Ons in IE to enable the Terminal Services ActiveX control. If you are unable to see/enable the Terminal Services ActiveX control in IE7 on XPSP3 as a workaround can you try deleting the following registry keys: 

     

    HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390f3d8-0439-4c05-91e3-cf5cb290c3d0} HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4eb89ff4-7f78-4a0f-8b8d-2bf02e94e4b2)

    Once you delete these keys, the activeX control should be enabled in IE7.

     

    Thursday, August 14, 2008 1:28 PM

Answers

  • In SP3, If you received it preinstalled on a new PC, you might not see the RDP control listed in IE.

    You can try resetting Internet Explorer:
    • Tools → Internet Options → Advanced tab → Reset... button
    • Close Internet Explorer and re-open it.
    Thursday, August 14, 2008 4:10 PM
    Moderator

All replies

  • In SP3, If you received it preinstalled on a new PC, you might not see the RDP control listed in IE.

    You can try resetting Internet Explorer:
    • Tools → Internet Options → Advanced tab → Reset... button
    • Close Internet Explorer and re-open it.
    Thursday, August 14, 2008 4:10 PM
    Moderator
  • That worked. Thanks for the help.

    Thursday, August 14, 2008 4:33 PM