locked
CRM 2011 - Sharepoint Integration RRS feed

  • Question

  • Hi All,

    I've now been struggling with integrating Sharepoint 2010 in Dynamics CRM 2011 for a few days, i've tried every single thing i could find but nothing helps..

    The problem is that i'm not able to validate the website in the way that it catches that the List Component is installed.. I can validate the site, the Sharepoint URL is OK but it keeps saying that i haven't installed the List Component. (As you can see on the screenshot below)

    The things i already tried:

    • Created a domain user (DOMAIN\ShareCRM) with the following priviliges:
    • Domain user
    • Member of Performance Log Users
    • Member of Local Administrators group on SQL Server Machine
    • Member of Local Administrators group on the CRM Web Server Machine
    • Read and write priviliges on C:\Program Files\Microsoft Dynamics CRM\Trace folder and within the user folder under %Appdata%.
    • Read and write priviliges for the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM and the sub-keys under HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\MSCRMSandboxService
    • Member of CRM_WPG group
    • Administrator of the Sharepoint site collection
    • Member of PrivUserGroup
    • Added the domain user to the sysadmin group on both SQL Servers. (CRM SQL Server and Sharepoint SQL Server, both running on a seperate machine)

    • Changed Dynamics CRM WebAppPool identity in IIS to use the new domain account (DOMAIN\ShareCRM)
    • Ran the AllowHtcExtn.ps1 script before activating the ListComponent in Sharepoint.
    • In IIS -> CRM Site -> Configuration Editor -> system.webServer -> Security -> Authentication -> Windows Authentication i set useAppPoolCredentials to True
    • Started the Microsoft Sharepoint Foundation Sandboxed Code Service.

    However, none of the above things helped me to sort out the issue... I hope anyone will be able to help me out with this issue.

    Thanks in advance.

    Thursday, May 3, 2012 2:09 PM

All replies

  • Hi Yorick,

    Please check if the followin article helps you:

    http://quantusdynamics.blogspot.co.uk/2012/01/dynamics-crm-2011-sharepoint-list.html

    The component is quite straight forward to config if all configuration matches the requirements.

    it may not validate the component if you have changed the CRM IIS port. The component has been activated on the site you trying to configure (Gallery -> Solutions).

    The configuration of the sharepoint component does not use the IIS AppPool account, but the context user account, make sure the user account you logged on to CRM has Read, Write and Design permissions.

    Hope this helps


    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com

    Thursday, May 3, 2012 9:56 PM
    Answerer
  • Hi Nrodri,

    Thanks for your reply.

    However, i followed everything in the article you mentioned but this didn't help..

    Our CRM is running on a different server than our Sharepoint but i noticed that our CRM uses port 443(HTTPS).. I changed it back to 80(HTTP) and tried again.. unfortunately this didn't help..

    Then i checked your 2 other possible solutions.. the component is activated successfully on the site i'm trying to configure and the user account i used to validate the site in CRM has Full Access on the sharepoint site but still no luck..

    Friday, May 4, 2012 7:50 AM
  • Btw the port needs to be changed on the CRM deployment tool and not IIS.

    I have seen other users in the forum with same issues, and normally the solution for them ends up being creating new site collection or web application or re-configure everything.


    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com

    Friday, May 4, 2012 8:16 AM
    Answerer
  • I finally have been able to sort this issue out and everything is working now! :-)

    Thursday, September 6, 2012 3:02 PM