locked
Installing RC1 on VIA walking a narrow road RRS feed

  • General discussion

  • I had to read all the posts, but RC appears to finally be working.  I've made between six and eight attempts to install RC1, with one of them burning up an activation key.

     

    Here is what worked.  Bold text indicates problems I, er, "worked through"... which is to say messed up and corrected on a later attempt.

     

    First, burning a correct DVD was critical.  Like many others here the first two discs I burned were bad, primarily because I used burn software that had no verify function.  In the end I checked the CRC of the ISO file and used NERO to make a DVD-R on a Sony DRU-710A (latest firmware update).  The target machine had a different DVD drive, but that worked out OK.  I have heard DVD-R is a bit more generally compatible across drives (though this could be rumor).

     

    Second, my target machine was:

    • MSI PT880 NEO FSR - this is a VIA chipset based mobo with a PATA/SATA RAID controller with onboard gig Ethernet interface.  The SATA side of the disk controller doesn't appear nor does it run in DMA mode until the mobo chipset drivers are installed, BUT I waited until WHS was finished installing before installing the mobo chipset drivers.
    • Sony DRU-1621 DVD-ROM (also with latest firmware from Sony Storage website) - this drive needed to be on the primary PATA channel or the BIOS would not boot from it.
    • Maxtor 70GB PATA HD on channel 2 - this is where I installed the WHS software.  It seems to have been partitioned 20/50G by the WHS setup (I'm guessing).
    • 2x Maxtor 250G SATA HDs - these would not be visible to WHS until after installation (but it's no problem to add them later).

    The BIOs needed to be set to boot first from DVD, then the HD.  There was an option "boot from other devices" in this particular BIOS which needed to be unchecked.

     

    Third, the install started reasonably enough: pop the DVD in the drive, be sure to "press any key to boot from CD/DVD" and its off.  After the first boot from the DVD, I never again pressed a key to force a boot from the DVD.  Again, critically and per the instructions the DVD needed to remain in the drive until installation was completed.  I failed twice trying to get the SATA drives visible, so I just dropped it for after the install.  I once saw the "no english keyboard option" problem when I had momentarily popped the WHS install disc out of the drive.  On my successful install it stayed firmly in place.

     

    The install log (located somewhere under Docs and Settings\All Users) seems to always indicate that a file called q.ini can't be found, but this didn't stop the final, successful install.  Several people have brought this up and its something I worried about, but it doesn't seem to matter, that is, this particular message may not be indicative of a bad disc burn.

     

    The only workaround needed during the install was due to an error upgrading Windows Desktop Search (WDS) 3.01 with a KBxxx patch file from the redist directory.  The WDS patch itself reported an error to the installer: 0x800703eb.  This causes the install to fail/exit fairly gracefully with lots of dialoging.  After the WHS exit, just restarting the machine (not logging administrator out!), gets the install past this problem.  It seems that logging out of administrator causes the system to just log that user on again, which cranks up the WHS install wizard... and that didn't fix the install.

     

    After that restart WHS finally installed itself and the "Welcome" screen came up.  Relief.  Only then did I run the mobo chipset driver installation.  This made gigE and SATA visible.  I didn't install the RAID or audio drivers since they're not needed.

     

    So, in short, the VIA chipset means a fussier install.  You need to be fastidious and put the install onto the "less evolved hindbrain" of your motherboard to start with, but that's easy if you delay installation of the mobo drivers until after WHS.

     

    Hope this helps someone out there!

    Monday, June 25, 2007 7:11 AM