locked
ADO.NET Synchronization Project Deployment Error RRS feed

  • Question

  •  

    I have a solution created in VS2005 utilizing SQLExpress2005 for a Microsoft Sync ADO.NET project and the following Synchronization DLLs:

     

    Microsoft.Synchronization    :     Version 0.94.0.0

    Microsoft.Synchronization.Data     :   Version 2.0.0.0

    Microsoft.Synchronization.Data.Server   :   Version 2.0.0.0

     

    When I go to the client machine to install the deployment package I get the message:

     

    "Unable to install or run the application.  The application requires that assembly Microsoft.Synchronization Version 0.94.0.0 be installed in the Global Assenbly Cache first."

     

    I have Microsoft.Synchronization.dll v0.94.0.0 installed in the GAC on the target machine.  I've tried setting the 'Specific Version' property to both false then true before publishing but this does not make a difference.  What could be the problem?  This is my first time deploying a Sync project.

     

    Thanks, cj

     

     

     

    Tuesday, September 9, 2008 9:33 PM

Answers

All replies

  • Hi!

     

    Thanks for this feedback. I have a question: are both CPUs on the same architecture, like both 32bit or both 64 bit?

     

    I have also seen that you are not using the RTM bits. You could try to switch to them and see if the problem persists.

     

    Thanks,

    Christian

    Wednesday, September 10, 2008 1:55 AM
  • Both CPUs are 32 bit. 

     

    I am unsure what you mean by switching the RTM bit?  Do you mean to replace the v0.94.0.0 .dll with a newer one?  If so, I don't think I've ever had a clear understanding of why I have to use the earlier version.  I recall that I had difficulty with a newer version and received the message (as per this thread:  http://forums.microsoft.com/sync/ShowPost.aspx?PostID=3558454&SiteID=75)  :

     

    "Error 2 The type 'Microsoft.Synchronization.SyncProvider' is defined in an assembly that is not referenced. You must add a reference to assembly 'Microsoft.Synchronization, Version=0.94.0.0, Culture=neutral, ....."

     

     

    Thanks,

    cj

     

    Wednesday, September 10, 2008 2:37 PM
  • Hi,

     

    by RTM bits I mean the one that have been released here: http://www.microsoft.com/downloads/details.aspx?FamilyId=C88BA2D1-CEF3-4149-B301-9B056E7FB1E6&displaylang=en It seems to me that you are using a BETA version of the framework.

     

    Have you also tried to remove all the references to the Sync Framework assemblies in the project and readd them? I have seen that sometimes Visual Studio might reference the wrong assembly!

     

    Thanks,

    Christian

    Wednesday, September 10, 2008 5:39 PM
  •  

    Thanks you, yes, I had already downloaded the proper files so I removed all sync references, uninstalled, re-installed, and added them back so that now the application does install.    

     

    I'm not sure it made a difference, but this time I made sure to add references only to v1 where before I had references to v1 & v2. 

     

    Thanks,

    cj

    Wednesday, September 10, 2008 7:54 PM