CRM 2013: Custom action import failure RRS feed

  • Question

  • Hi,

    I have created a Process of type Action and for "None (Global)" so that it can be registered for any entity. On this action I have created a few arguments and set values. This Process is related to nothing, has no dependencies whatsoever. I then created a new solution and added the custom action to the solution and exported it. When I import this solution with just one action, in any other CRM 2013 Org, with or without rollup 1, managed or unmanaged, I get Workflow With Id = {GUID} Does Not Exist. This does not make sense to me at all. Are custom actions non-exportable?

    Wednesday, January 8, 2014 10:28 PM

All replies

  • Wednesday, January 8, 2014 11:31 PM
  • Well, I did read that bug report yesterday. It specifically talks about not able to import actions if any entity is attached to them. In my case, I do not have anything attached to the action. It has no dependencies. This renders Actions completely useless, unless you are developing directly on production organization. Which I am sure is not going to happen. Much ado about nothing.
    Wednesday, January 8, 2014 11:50 PM
  • I can confirm that I have the same error with 'Global' Action. I hope that MS will provide some workaround or fix in closest UR.

    Dynamics CRM MVP/ Technical Evangelist at SlickData LLC
    My blog

    Thursday, January 9, 2014 12:00 AM
  • Question
    You cannot vote on your own post

    Hi, actually I also face this problem and I try to find out.

    Using the Rollup 2 for CRM 2013 also still cannot.

    I always having this problem :

    If I go detail then I found this error :

    Workflow With Id = 8e4aafcd-c6a9-43e2-9f4f-50deeb535466 Does Not Exist

    Then I realize that it cannot find the Workflow with Id as a parent ID from related records, in this case the related records are Arguments and Steps of that Action as Process. So it can be when try to import Arguments and Steps, they cannot find this Action since not yet imported (the logic sequence is one of the problem)

    Then, this is urgent for me to export and import solution and can't wait to wait until next rollup, what things that I do are :

    First, I go to my custom action, it is Global Custom Action

    Secondly, I remove all of the arguments and also the steps as well 

    Then save.

    Then I export my solution with that custom action (seems to be blank custom action).

    After I do that, make sure that I can import it successfully.

    Yes, if I import the blank Action with no arguments and steps at the very first time, it will work.

    So, after I manage to import my blank Action, then I go back to my Source Organization solution and I edit back my Action then I input back my arguments and steps (yah, inconvenient way, but no choice).

    Then, I export again my solution then import again to another organization that I already managed to import my blank action.

    Finally, yeah, I can import my action by updating this component 

    Then, I go to the second organization I use to import into and check my action, with arguments and steps same as the source has or not.

    Yes, I can update this, and it is exactly the same as the source has.

    Next time, if there is any update, I can update and import it back again to the purposed organization.

    So, this is not the best way, but at least can save my day, even though I did spend many hours to fix and find out this! And fortunately, my action not too complicated so I can re-do develop again.

    Next time, if I want to create custom action, I have to make it blank first just for importing as create new action, after that I can update.

    Hope it helps!


    • Proposed as answer by Aileen Gusni Saturday, May 10, 2014 8:16 PM
    Tuesday, May 6, 2014 10:26 AM
  • So when you say you were able to import at least a blank custom action, you mean you did it after installing Rollup 2.
    Wednesday, May 7, 2014 5:03 PM
  • Not mandatory, just create a solution with blank custom action, export and import it to your new organization. 
    Thursday, May 8, 2014 11:17 AM
  • I tried, but failed for me.Did you create a new blank "global" custom action or tied to some entity?
    Thursday, May 8, 2014 11:36 PM
  • Global Entity. I tried several times and it worked. Is there any error message? You should create first from source organization then export, import to your second organization.
    Friday, May 9, 2014 5:39 PM
  • Thanks, the suggestion that you provided does work. But it does not solve my problem. I cannot import a blank custom action on production org and then go back to development org and add tons of properties and steps again. And guess what, it is not resolved in rollup 2 as well.


    Monday, May 12, 2014 4:05 PM
  • Hi Ahmad,

    Yes I try using rollup 2, still got this problem.

    Well, actually it worked and solve my problem because I did not have much processes, I just have 3 arguments + 2 steps.

    So this is not a big deal for me to do that. I do that because if I cannot import, I can't use that and also my partner cannot use my solution, so, I have to do that. Thanks.

    Wednesday, May 14, 2014 7:03 AM
  • Hi Ahmad and Aileen,

    I can confirm that the issue “Solution Import Fails when Plugins attached to custom Action Processes (SdkMessage) are included in Solution” has been reported to us and is being handled as a design mistake.  I have reviewed the latest state of the troubleshooting for you: the issue is not yet fixed, however it is currently scheduled to be addressed with one of the next Update Rollups of CRM 2013 SP1.  Please accept our apologies for initial misleading communication in the Connect Suggestion https://connect.microsoft.com/dynamicssuggestions/feedback/details/810477/crm-2013-solution-import-fails-when-plugins-attached-to-custom-action-processes-sdkmessage-are-included-in-solution

    Thank you for using Microsoft Dynamics CRM Communities and Forums.


    Nina Peneva

    Support Engineer

    Microsoft Dynamics CRM

    Wednesday, May 14, 2014 4:35 PM
  • Hi Nina, 

    Thanks for your reply.

    Actually, I tried to create an action that has not been attached to any plugin, but still got error, so meaning for all Action with Arguments and Step cannot be imported.

    Thank you.

    Thursday, May 15, 2014 2:12 PM
  • Hey guys,

    I had the same problem with Microsoft Dynamics CRM 2015 online, which is on SP1 already ( However to solve my issue did the following things:

    - Export the managed solution
    - Unzip the solution into a folder
    - Search for the workflow file related to the custom action that has the problem
       Error: "Workflow With Id = 8e4aafcd-c6a9-43e2-9f4f-50deeb535466 Does Not Exist"
       File: \Workflows\YourWorkflowFile-8e4aafcd-c6a9-43e2-9f4f-50deeb535466.xaml

    - Open the file in an editor and remove the following blocks

    <x:Property Name="Target" Type="InArgument(mxs:EntityReference)">
            <mxsw:ArgumentRequiredAttribute Value="True" />
            <mxsw:ArgumentTargetAttribute Value="True" />
            <mxsw:ArgumentDescriptionAttribute Value="Target Argument" />
            <mxsw:ArgumentDirectionAttribute Value="Input" />
            <mxsw:ArgumentEntityAttribute Value="none" />


        <InArgument x:TypeArguments="mxs:EntityReference" />


    - Zip the whole solution

    Wednesday, May 13, 2015 9:02 AM
  • This is so unacceptable. It is CRM 2015 with Update 1 already and this basic issue is still ignored. I don't understand the meaning of having this feature if it cannot be used.
    Wednesday, May 13, 2015 4:26 PM
  • I just experienced the same thing with CRM 2015 Online with Update 1 with an additional twist.  

    We have a production organization that is CRMOnline 2015 RTM (, with a sandbox that was updated to CRM2015 Update 1 ( 

    The original solution file imported with no issues on the RTM version, however it DID have this error (for which this resolution worked) on the Update 1 version.

    Thanks for the fix Martin!

    Wednesday, June 3, 2015 9:27 PM