locked
read only file causes errors RRS feed

  • Question

  •  

    I am having a problem synching when directories contain read-only files, with 2.0. Has anyone else seen this? I have large directories of files that are locked due to a source control program, and all these files are locked. removing the read-only defeats the purpose of the source control, so thats not an option.

     

    To verify this, i tried on another directory which had 2 locked files out of all of them, and sure enough they did not sync. The error log said "Could not access source file", and i have verified that the exclude read-only setting is not checked. I definitely didnt have this issue with 1.4.

     

    Any thoughts? SnycTopy is great but if this is going to be a 2.0 issue i need to go back to 1.4. Does anyone have the install? MS has removed it from their site.

     

    Thanks

    Mike

    Wednesday, September 17, 2008 10:49 AM

All replies

  •  

    Hi -

     

    SyncToy 2.0 will definitely sync files which have the read-only attribute set on them and preserve the attribute on the destination side. However this is different from having locked files. What do you see when you do an "attrib <filename>" and when you do a "cacls <filename>".

     

    Have you confirmed when using 1.4 that the files were actually being synced?

     

    Thanks

    Deepa

    Wednesday, September 17, 2008 6:18 PM
  • When syncing read-only files my 1.4 version syncs ok the first time. Subsequent syncs fail at the target side because the file is read-only ;-)
    So my work-around is to navigate to my destination folder (with me too its source control that marks these files read-only ;-) with windows explorer and uncheck the read-only flag (in property dlg on folder) recursively for all child items. Then the sync will work... once :-(

    So the fix is quite simple: overwrite read-only files on the destination (or at least make it an option). A behavior that would be implied by 'Echo'...?

    I'm now downloading 2.0 in the hope this would be fixed. Alas....
    Marc Jacobi
    Thursday, September 17, 2009 8:36 AM