locked
Turn off Translator RRS feed

  • Question

  • For many the Translator is certainly a useful tool, but for some it just annoying. One of those nice inventions which is not though completely through. I live in the Netherlands, but is not a native and want to have my web-pages in English. Even though my lanugae in Internet Explorer options is set to English a number of webpages are now automatically translated into Dutch. So every time I have to swithc the translator off to get the content in English. Tried searching for a solution to this on the web, but alas.

    Anyone know how to permanently switch this off as a user?


    Regards, Stig
    Thursday, September 23, 2010 4:22 PM

Answers

  • Hi Stig,

    Microsoft Translator is not invoked automatically. Adopters of our widget (http://www.microsofttranslator.com/widget) can choose to invoke it automatically for their vistors, based on the browser accept-language setting. This is not the default though.

    Can you describe on which sites and which browser you are observing the automatic translation effect?

    Chris Wendt
    Microsoft Translator

    Monday, September 27, 2010 7:28 PM

All replies

  • Hi Stig,

    Microsoft Translator is not invoked automatically. Adopters of our widget (http://www.microsofttranslator.com/widget) can choose to invoke it automatically for their vistors, based on the browser accept-language setting. This is not the default though.

    Can you describe on which sites and which browser you are observing the automatic translation effect?

    Chris Wendt
    Microsoft Translator

    Monday, September 27, 2010 7:28 PM
  • Thanks for the answer, Chris.

    I use IE8 with only English listed in the browser languages settings. Unfortunately I did not write down any of the URLs where I did get the automatic translate.

    From what you state I understand that this is not how it should really work. So I will be sure to make notes when this happens again and then log it here. I believe we then can close this for now.

     


    Regards, Stig
    Tuesday, September 28, 2010 8:28 AM
  • Chris,

    here is an example of a site that does not respect the language settings:

    http://blogs.msdn.com/b/chrisfie/archive/2010/01/29/why-sharepoint-2010-developer-dashboard-is-for-all-it-professionals.aspx

    This page is per default displayed to me in Dutch even though English is my first language in the Internet Explorer 8 Language options.


    Regards, Stig
    Wednesday, October 27, 2010 11:00 AM
  • The translator IS invoked automatically at least in Win 7 with Explorer 8.

    ANNOYING! Why? Because if we have to wait until anything remotely tech-useful is translated from english, we are always going to be 3 versions behind everything.

    Besides, automatic translators still do a poor job in general. Fine for artist gossip but for work can have huge costs.

    Sad to find the VERY narrow view that Microsoft has on international people: Practically forcing users in other countries to adapt to the ugly translations. Trying to condemn us to live on outdated garbage. Believe it or not, people CAN speak more than one language. Content is ALWAYS better on its original language. PLEASE LET THE USER DECIDE!

    here is a link that forces translation:

    http://www.microsoft.com/visualstudio/en-us/products/2010-editions/professional/overview

    sooo... how the devil do I turn off the darn thing?

     
    UPDATE: Options > General > Language > english First solved at least the above link., at least the translator now asks instead of auto.

    Still: How do I disable permanently the thing?

    • Edited by BLL73 Wednesday, September 21, 2011 9:41 AM
    Wednesday, September 21, 2011 9:31 AM
  • Hi Stig, I must say I still cannot repro the behavior you describe, not even with my accept-language set to Dutch (nl-nl). Do you have a toolbar installed, say Google Toolbar or Bing Toolbar? Chris Wendt Microsoft Translator
    Wednesday, September 21, 2011 11:44 AM
  • No. I am no fan of adding extras to IE.

    The page at http://blogs.msdn.com/b/chrisfie/archive/2010/01/29/why-sharepoint-2010-developer-dashboard-is-for-all-it-professionals.aspx still automatically translates for me.

    Did you try setting your location to Netherlands in the Control Panel Region and Languages?


    Regards, Stig
    Wednesday, September 21, 2011 12:06 PM
  • Remove all language preferences from internet explorer: Tools -> Internet Options -> General (tab) -> Languages (button) -> Remove all languages from Language Preference list. 

    Wednesday, November 9, 2011 8:31 AM
  • Remove all language preferences from your internet explorer: Tools -> Internet Options -> General (tab) -> Languages (button) -> Remove all languages from Language Preference list. Funny that Microsoft cannot give simple answers...
    Wednesday, November 9, 2011 8:33 AM
  • Thanks for the tip, but not sure if this resolves all. But it is now even funnier: The page at http://blogs.msdn.com/b/chrisfie/archive/2010/01/29/why-sharepoint-2010-developer-dashboard-is-for-all-it-professionals.aspx then automatically translates to Spanish!!

    The header now reads "¿Por qué SharePoint 2010 Developer Dashboard es para todos los profesionales de TI:" - another example of how useful this is.


    Regards, Stig
    Wednesday, November 9, 2011 9:57 AM
  • I tested this some more (IE9). Tried alternatives with: No language preference, English UK only, English UK plus Dutch and English US only.

    In all of these cases the page was translated to Spanish even though there is no setting on my PC that could indicate that Spanish should be an option. Regional settings is English US with Netherlands as location.


    Regards, Stig
    Wednesday, November 9, 2011 10:07 AM
  • Hi Stig,

    thanks for the additional information. This MSDN site indeed has set the Translator widget to be invoked automatically. Should not be into Spanish though, unless your browser's accept-langauge is Spanish. We'll look into that.

    In any case you can just press the close X button on the translator toolbar to remove translation.

    Chris Wendt
    Microsoft Translator

    Wednesday, November 9, 2011 4:51 PM
  • In any case you can just press the close X button on the translator toolbar to remove translation.


    Chris,

    could MS please provide a way to DISABLE the translation at SITE level, not just page level (by clicking (x) button)? This auto behavior is very annoying for me. I want to see ONLY English language (en-us) to be used despite where ever locals I'm at. It seems it's automatically determined based on IP address, could you confirm that?
    For example, visiting this page: http://www.microsoft.com/visualstudio/en-us, although URL has specify the language (en-us), the translator still automatically kicks in and translate to whatever language that is not "en-us". It's like what's reported by Stig.

    Thanks!

    Friday, November 18, 2011 10:26 AM
  • Hi Chris,

    I know you mean well, but sorry to say that an answer like 'just press the close X button....' is not really what we are looking for. If software is invoked automatically it should work and not force the user to take an extra action to remove the effects of the software.

    So please continue to look into a solution where this is all USER-controlled. That is the only way forward. We realize that this is not done overnight, but let us at least get there in the future.

    Regards, Stig


    Regards, Stig
    Friday, November 18, 2011 10:33 AM
  • Help, help, help.

    I hate translations. They are really worth nothing, especially wenn text is translated from English to German. Everytime, when I encounter a so called "translated" site my stomac crumps. And I spend much time, to find a site, were translation has not kicked in.

    In my opinion, machine translation in the present state is really worth nothing, regardless it they originates from. I would not like to explain in more clarity. If I am expected to use IE in the very near future, the only way is an option, witch allows me to stop this translation nonsense definitely. Otherwise I will have to look for a more friendly browser offering the required feature.

    If you get a headache reading my response (my mothers tongue being german), be assured, my headache reading so called "translations" ist a multiple.

    Kind regards

    wiefisch

     Btw. I do not authorize machine translation of this response.

     

    Friday, November 18, 2011 6:00 PM
  • Thanks a lot all for the passionate sentiment expressions.

    I need to state that it is always the application or webmaster deciding between an automatic or manual invocation of translation. The Microsoft Translator widget can be configured by the webmaster to be invoked automatically, or not: http://www.microsofttranslator.com/widget.

    I am taking as feedback here to work with the individual owners of the Microsoft-owned sites you mention above to turn automatic invocation off, and as a future feature of the widget to remember the fact that it was turned off, for additional page views on this site.

    Chris Wendt
    Microsoft Translator

     

    Friday, November 18, 2011 7:36 PM
  • I am taking as feedback here to work with the individual owners of the Microsoft-owned sites you mention above to turn automatic invocation off, and as a future feature of the widget to remember the fact that it was turned off, for additional page views on this site.


    Yes, Chris. Please do that. I don't like the fact that software being too smart for me, in the sense that it's actually doing the opposite. User should always be in control.

    Thanks.

     

    Saturday, November 19, 2011 7:37 AM
  • I am not aware that the situation has evolved ever since. Any progress you can update us on? Thank you for your help.
    Thursday, January 3, 2013 4:28 AM
  • I took a look at the blog site, and it does not appear to be auto translating for me right now. Is it fixed for you too?

    Please note that auto translate is a choice of the webmaster, not the software. The default behavior of the software is to have user-invocation of the translation.
    Thursday, January 3, 2013 10:19 AM
  • Hi!

    2 years later, and the problem goes on. Now Ive got it. I browse China Daily, turn the translator button to 'off', and every time I open a new page, Bing translator has switched itself back on. What makes matters worse is that its in the bottom right corner peeking out from behind an ad that resizes itself every time I get near. So every time my cursor gets near an English word, a large window pops open, slows my computer, and blocks what I'm reading. Aaaahhh!!

    (no link included until you can verify my account I am told)

    I'm aware that maybe its the website that enables this, but really, why can't I turn it oiff??? Its already maddening that Bing Search cannot seem to remember I'm an English speaker living in China, as it continuously wants to revert to Chinese! Google is 99% blocked here so I really wish Bing could pick up the slack. However it's 'intuitive' stylings are completely wrong, counterproductive, and frustrating as heck.

    I guess that this doesnt concern anyone at Microsoft if the problem still exists 2 years later, but thanks for listening.

    Tuesday, January 8, 2013 3:58 AM
  • Hi BManin,

    I visited the China daily site and I did not find any translation function offered by the site itself. China daily doe snot invoke the Microsoft Translator widget. Can you list the browser and tools you are using to visit the site? My suspicion is you are using a client application or browser helper that automatically translates for you. I am not aware that Microsoft is shipping such a tool, certainly not the Bing Translator team. You should be able to solve the problem by uninstalling that tool.

    For translating within Internet Explorer I recommend using the Bing Bar (http://www.bingtoolbar.com/en-US), and activate the Translator button. Translation is not invoked automatically, the Bing Bar only offers to translate when it detects a language mismatch between itself and the web site you are visiting.

    Let us know if this helps,
    Chris Wendt
    Microsoft Translator

    Tuesday, January 8, 2013 6:53 AM
  • Translation also takes in place in other browsers. I use Firefox and manu MS knowledge base articles are automatiocally translated to Ducth while I prefer the original English texts. That saves me from having to second guess which Dutch terms the translater (human or machine) uses.
    Friday, January 11, 2013 8:27 AM
  • I am from Brazil, but same problem.

    I need to fix an annoying problem on my excel macros, but just bumped into another annoying problem.

    When I find codes like "use Workbooks.Open command" the translator brings me "... Workbooks. Abrir o comando..." ???

    I need help, not more confusion to my already stressing problem.

    Feel like talking to a wall, but anyway.

    Wednesday, February 6, 2013 9:54 AM
  • Hi Jan,

    to turn of translation on the Microsoft knowledge base, please choose an English-speaking locale. In the upper right corner of the site you see a locale specification, in your case probably "Nederlands". Click on it, and choose United States (English) or United Kingdom, or similar.

    Chris Wendt
    Microsoft Translator

    Wednesday, February 6, 2013 2:33 PM
  • Hi Marcelo,

    can you list which application or web site you were using?

    Chris Wendt
    Microsoft Translator

    Wednesday, February 6, 2013 2:35 PM
  • Hi Chris,

    I have read the message in this forum that tbot will be turned off on the 26th of this month.

    I have a friend who only speaks German and I only speak English. We speak using mtbot on messenger everyday and are desperate to find an alternative so that we can continue communicating. I have already tried using clownfish in the skype interface and found it to be poor comparison to mtbot. There were many issues with compatibility.

    I think it is a really bad way for microsoft to treat their clients. We are their clients. You place ads on messenger and presumably you get paid for put those ads there. So why break something that works perfectly well for skype which does not have the same reliability and certainly doesn't cater for people that speak foreign languages to communicate. There has to be more than my friend and I that are severely inconvenienced by messenger being closed.

    Please I would appreciate an answer to this question. I have sent emails to microsoft a few times with registration numbers and there has been no response. Nothing. Not even a "We will get back to you with a solution. Really poor customer service don't you think? That aside all I want is to continue to communicate with my german friend. Please Help Us.

    Regards,

    Nashi

    Monday, February 18, 2013 11:36 AM
  • Hi Nashi,

    thanks for sharing your view here. As much as I myself dislike to see TBot retiring, I fully understand and support Microsoft's decision to ask Messenger customers to move from Messenger to Skype. Skype offers a superset of the Messenger functionality on a wide variety of platforms, and is more popular all around. TBot was not going to change that.

    Microsoft Lync is a chat client, offering similar functionality to TBot. See www.conversationtranslator.com to install Translator on a Lync client. Offers a much nicer user interface even than TBot, with the same translation service. If you both have access to Lync, that will be an option.

    For translation in Skype please keep watching this forum. We'll announce here when we have a solution or a recommendation.

    With regards to your unanswered messages: I am sorry this happened to you, and I didn't see them.

    Chris Wendt
    Microsoft Translator

    Wednesday, February 20, 2013 2:58 AM
  • I am from Brazil, but same problem.

    I need to fix an annoying problem on my excel macros, but just bumped into another annoying problem.

    When I find codes like "use Workbooks.Open command" the translator brings me "... Workbooks. Abrir o comando..." ???

    I need help, not more confusion to my already stressing problem.

    Feel like talking to a wall, but anyway.

    O mesmo aqui em Portugal Marcelo!!!

    It is the most annoying think ever!!! Bad translations, even worst control of the technical terms, a mess!!

    On one hand we must get our certification in English, and in the other we get stuck with unwanted terrible translations!!

    Need to see something at http://support.microsoft.com/kb/2795190 and (again) all is translated!!

    Had to enter with my Hotmail credentials to get it in English!!

    Very fast and helpful when you are in a client trying to get a problem solved!!!

    These translation are TERRIBLE!!! Do everybody a great favor and just KILL the functionality, please.

    JF

    Wednesday, October 23, 2013 6:52 PM
  • Also i see that with Google Chrome Browser and while browsing th msdn website..
    Thursday, January 9, 2014 1:50 PM
  • Quite a few pages seem to apply the preferred language setting of your browser, e.g. http://support.microsoft.com/

    In Chrome you can go to the languages section of the settings and reorder your preferred languages so that, say, English comes first. I tried it and it solved the problems of a particular Microsoft page being translated into Spanish on my computer. 
    Monday, November 17, 2014 10:07 AM