none
Azure HPC Pack 2016 Cluster - HPC Power Shell - Retry Count of RetryManager is exhausted RRS feed

  • Question

  • Hi 

    When trying to execute the command Get-HpcClusterProperty or Set-HpcClusterProperty command on the HPC powershell,  encountering below error 

    Get-HpcClusterProperty Get-HpcClusterProperty : Retry Count of RetryManager is exhausted. At line:1 char:1 + Get-HpcClusterProperty + ~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (Microsoft.Compu...ClusterProperty:GetClusterProperty) [Get-HpcClusterProperty], RetryCountExhaustException + FullyQualifiedErrorId : Microsoft.ComputeCluster.CCPPSH.GetClusterProperty

    Anyone encountered the above error ?

    I am trying to set the enable grow shrink on Azure HPC Pack 2016 Cluster. Beside using HPC Powershell , is there any way we can set this ?

    Thanks in advance. 

    Ramesh

    Tuesday, April 28, 2020 11:41 AM

Answers

  • Are you able to use HPC Cluster Manager to connect to the cluster? If not, then there may be something wrong in your HPC Management service, you can check whether it is still running in Services.msc.

    Another possible reason is that you disabled TLS 1.0 on the head node, and in the PowerShell, you are still trying to use TLS 1.0. In that case, you can run the following PowerShell command first before running any HPC PowerShell commands.

    [System.Net.ServicePointManager]::SecurityProtocol = [System.Net.SecurityProtocolType]::Tls12

    • Marked as answer by MVV Ramesh Wednesday, April 29, 2020 5:31 AM
    Wednesday, April 29, 2020 3:15 AM

All replies

  • Are you able to use HPC Cluster Manager to connect to the cluster? If not, then there may be something wrong in your HPC Management service, you can check whether it is still running in Services.msc.

    Another possible reason is that you disabled TLS 1.0 on the head node, and in the PowerShell, you are still trying to use TLS 1.0. In that case, you can run the following PowerShell command first before running any HPC PowerShell commands.

    [System.Net.ServicePointManager]::SecurityProtocol = [System.Net.SecurityProtocolType]::Tls12

    • Marked as answer by MVV Ramesh Wednesday, April 29, 2020 5:31 AM
    Wednesday, April 29, 2020 3:15 AM
  • Thank you Sunbin.  It worked like a charm and you have saved my day.  I marked your response as answer. 

    In response to your questions, Yes. I am able to connect to Cluster Manager and able to submit / process jobs with no issues.  I notice TLS1.0 disabled when trying to connect to WebAPI (that was hosted on the headnode ) from a client and realized that possibly the problem when trying to run the HPC Powershell.  Indeed your answer is bang on. 

    I have no idea how and why TLS 1.0 disabled on the Headnode but it was by default disabled when new Azure VM (headnode) configured for HPC Cluster.

    Thank you once again.

    Ramesh

    Wednesday, April 29, 2020 5:37 AM