locked
Office Communicator 2007, QoS and DSCP RRS feed

  • Question

  •  

    Hello.

     

    In documentation about OCS, is written:

    "Microsoft UC natively supports DiffServ

     

    Microsoft UC natively supports DiffServ through DSCP marking by the end-points, which can easily be turned on or off and modified through Group Policies.

     

    When enabled, Microsoft Office Communicator 2007 instructs the transport layer of the operating system to set by default the Differentiated Services Code Point (DSCP) for voice media to the Expedited Forwarding class marking, and to set the DSCP for video media to Class 3 of Assured Forwarding. That means that for networks honoring the DSCP marking, voice is prioritized higher than video by default. These default settings ensure that on any network honoring end-point marked DiffServ, both the voice and the video media would take advantage of the network capability for DiffServ prioritization as soon as the administrator would have enabled the packet marking – provided the ingress network switch is not set to overwrite end-point set marking. At this time, Microsoft UC does not natively provide trusted proxy interfaces for DSCP marking by network elements of the Microsoft UC traffic. ..."

     

    I carry out following actions on the client:
    OS Windows XP SP2
    1. setup QoS Packet Scheduler;
    2. in network adapter settings - enabled QoS Packet Tagging;
    3. Group Policies (Computer - Administrative Templates - Network - QoS Packet Scheduler ) - default settings.
     
    Then we start Communicator 2007, we establish audio/video session and it is analyzed proceeding packages:
     

    I see:   DifferentiatedServicesField: DSCP: 0, ECN: 0

     

    What I need to make, that the Microsoft Office Communicator 2007 could do DSCP marking?
     
     

    For Vista to documentation it is written: " DiffServ QoS DSCP marking of packet by the end-point can be turned on by modifying or creating the following registry key to the REG_DWORD value of 1:

    HKEY_LOCAL_MACHINE \SOFTWARE \Microsoft \RTC \Transport \QoSEnabled "

     
     
     
     
    Tuesday, October 30, 2007 8:53 AM

All replies