locked
E-mail router Configuration Manager was unable to retrieve the user and queue in Dynamics CRM 4.0 NLB RRS feed

  • Question

  • I have installed the NLB on two Windows 2008 R2 SP1 nodes – this is functioning perfectly.

     

    I have installed Dynamics CRM 4.0 on each node – according to the “Microsoft_Dynamics_CRM_IG_Installing.doc” and updated SQL tables to point to the NLB address – this works perfectly.

     

    The configuration of the E-mail Router for CRM is where I am experiencing a major problem…

    During the Dynamics CRM 4.0 installation, I entered the name of each NLB node into the field “E-mail router server name:”

     

    Now when I install the email router and attempt to configure it, I receive the following errors…

     

    The E-mail router Configuration Manager was unable to retrieve the user and queue information from the Microsoft Dynamics CRM server.

    This may indicate that the Microsoft Dynamics CRM Server is busy.

    Verify that the URL 'http://crmnlbnode01:5555/orgname/' is correct.

    Additionally, this problem can occur if specified access credentials are insufficient.

    To try again, click Load Data. (The request failed with and HTTP status 401:Unauthorized. )

     

    I have attempted using the nodes names and the NLB Cluster name in the URL – but I receive the same error.

     

    I am using the same domain account user account that I used for the CRM installation. The Async service and the CRM Email Router on both NLB nodes are running as the same domain user account, and the domain account and each NLB node machine name account is in the PrivUserGroup.

     

    I am using just the Outgoing Profile...

     

    Configuration Profiles tab (Outgoing profile) (Advanced tab has default settings)

    E-mail server Type: SMTP

    Authentication Type: Windows Authentication

    Location Server: exchangeHUBservername

    Access Credentials: Other Specified
        UserName: Domain\crmservice
        Password: password

    Deployments tab

    MIcrosoft Dynamics CRM server: http://crmnlbnode01:5555/orgname [have tried both NLB node names and NLB clustername]

     

    Please help.

     

    Thursday, March 10, 2011 12:38 PM

All replies

  • I solved the problem.

     

    disable LoopBack...

    1.    Click Start, click Run, type regedit, and then click OK
    2.    In Registry Editor, locate and then click the following registry key: HEKY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3.    Right-click Lsa, point to New, and then click DWORD (32) Value
    4.    Type DisableLoopbackCheck , and then click Modify
    5.    In the Value data box, type 1 , and then click OK
    6.    Restart the 'Microsoft Email Router service' and test access

    ...this has solved my NLB issue.

     

    My concerns are; what are the implications of Disabling LoopBack?

    Anyone?

     

     

     

    • Proposed as answer by pmdci Thursday, May 17, 2012 10:09 AM
    Thursday, March 10, 2011 3:25 PM