troubleshooting connector issues and....IIS not running on WHS RRS feed

  • Question

  • i was just going through the troubleshooting for connector install failure and i checked my IIS services manager and there are no sites listed and when i try to connect to my WHS through the manager it says "server failee to initialize"

    my WHS was working fine until a few months ago now I can only access through RDP, I never even looked at the IIS manager before....

    Any ideas how to get it going again? I can't even connect to my own WHS through it yet
    Friday, March 12, 2010 5:40 PM


All replies

  • Server recovery is the only supported option. If you have an OEM server (HP, Acer, etc.) you should have instructions in the documentation you received with your server. If you have a self-built server, see this FAQ.
    I'm not on the WHS team, I just post a lot. :)
    Friday, March 12, 2010 5:47 PM
  • this is the second time I have had to recover the server for connector not working, I suspect both times the same cause....

    I have no trouble recovering the server, I just would hate to do it again 3 months later

    Friday, March 12, 2010 6:02 PM
  • So have you installed anything on your server? Is it an OEM server (Acer, HP, etc.)? Self-built?
    I'm not on the WHS team, I just post a lot. :)
    Friday, March 12, 2010 7:10 PM
  • OEM acer easystore....

    connector went down about 6 weeks after initial purchase...after troubleshooting and much help from these forums, there was no other alternative but to do a reinstall...

    everything worked for about 3 months then the connector went down again, frustrated I let it go and just accessed through RDP....

    now I need to get at some of my backups, which can only be accessed from the connector on a local machine, so i decided to troubleshoot with a network guru freind of mine.... when we looked into it the IIS server was not working...

    so judging by my past experience, I would think the IIS server failed the first time i had to reinstall....

    this is a OEM un-touched install that I have had working with 4 other computers on a network 3 times now and the connector has failed within months of a reinstall each time. 
    Friday, March 12, 2010 8:58 PM
  • Without some clear errors (i.e. from the event log) it is hard to say, what is causing your problem.
    I have also experienced the one or other home server related service go down, but IIS was none of them.

    Did you run Windows updates on the home server from the console or from the desktop? The later can sometimes bring updates for Windows Server 2003, which are not good for Windows Home Server.

    Best greetings from Germany
    Friday, March 12, 2010 10:41 PM
  • the errors are
    IIS config event 4275
    when manualy trying to start the service I get some thing like

    IIS Admin service specific error code -2145318902

    i googled it and found this

    which suggests a metabase or machine keys....
    I also found this

    which I have tried but to no avail

    as far as i can remember updates would have been from the console


    Saturday, March 13, 2010 12:35 AM
  • SUCCESS....

    I followed this link

    got the service running again....

    Saturday, March 13, 2010 12:56 AM