Windows 7 Anytime Upgrade does not work - "Windows Anytime Upgrade was not successful." RRS feed

  • Question

  • Hi all,


    I have a problem. I just bought a brand new laptop from Alienware, it's an M17x supplied with Windows 7 Home Premium 64 bit - I assume it's a bulk key or something since it's essentially from Dell.

    As I say, I ordered it with Home Premium and then decided to upgrade to Ultimate, so I ordered this item from Amazon:


    Which is the Windows 7 Ultimate Anytime Upgrade (I assume it works for 32 and 64 bit since no mention is made anywhere in the description). The item is a genuine, sealed item direct from Amazon and the preinstalled OS is from Dell so I asusme that it is all legal.

    However, upon trying to run the Windows Anytime Upgrade tool, I get the following error:

    "Windows Anytime Upgrade was not successful. ... The upgrade was not successful. Please try the upgrade again". The first time I ran the tool it asked for the serial key, and each time after that it just "knew" the key and kept trying to upgrade, but it was not able to. I have followed several steps including rebooting to safe mode, reactivating Windows Home Premium, and changing the serial key manually using slui.exe and slmgr.vbs commands - nothing worked.

    I also tried activating through My Computer properties > Change Product Key, and I was presented with this error:

    Invalid Product Key
    The product key you have entered will not work with this version of Windows 7.
    You must either run Windows 7 setup or enter a Windows 7 Home Premium product key

    It seems a bit silly that I would have to format and reinstall just to upgrade, and more to the point I don't think I *would* be able to do that as this is just an Anytime Upgrade key.

    I have attached the outputs from the Microsoft Genuine Advantage Diagnostic Tool (1.9.0027.0) and also the upgrade logs from %userprofile%\AppData\Local\Microsoft\Windows\Windows Anytime Upgrade\

    Any advice is appreciated greatly - I just hope I haven't wasted £100!




    Diagnostic Report (1.9.0027.0):
    Windows Validation Data-->

    Validation Code: 0
    Cached Online Validation Code: 0x0
    Windows Product Key: *****-*****-2CV9D-2B2RJ-3R4H9
    Windows Product Key Hash: kx5ahSuWIq87AlB/Xp68K1bEOkM=
    Windows Product ID: 00359-OEM-9817406-79750
    Windows Product ID Type: 8
    Windows License Type: COA SLP
    Windows OS version: 6.1.7601.2.00010300.1.0.003
    ID: {ABD1EBF7-DA64-4B50-AE2A-EF41CCE141A2}(3)
    Is Admin: Yes
    TestCab: 0x0
    LegitcheckControl ActiveX: N/A, hr = 0x80070002
    Signed By: N/A, hr = 0x80070002
    Product Name: Windows 7 Home Premium
    Architecture: 0x00000009
    Build lab: 7601.win7sp1_gdr.110408-1631
    TTS Error:
    Validation Diagnostic:
    Resolution Status: N/A

    Vista WgaER Data-->
    ThreatID(s): N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002

    Windows XP Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    File Exists: No
    Version: N/A, hr = 0x80070002
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002
    OGAExec.exe Signed By: N/A, hr = 0x80070002
    OGAAddin.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 100 Genuine
    Microsoft Office Enterprise 2007 - 100 Genuine
    OGA Version: N/A, 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
    Default Browser: C:\Program Files (x86)\Mozilla Firefox\firefox.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{ABD1EBF7-DA64-4B50-AE2A-EF41CCE141A2}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-3R4H9</PKey><PID>00359-OEM-9817406-79750</PID><PIDType>8</PIDType><SID>S-1-5-21-496292981-2545973583-3325081220</SID><SYSTEM><Manufacturer>Alienware</Manufacturer><Model>M17xR3</Model></SYSTEM><BIOS><Manufacturer>Alienware</Manufacturer><Version>A04</Version><SMBIOSVersion major="2" minor="7"/><Date>20110328000000.000000+000</Date></BIOS><HWID>A1173007018400FE</HWID><UserLCID>0809</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>GMT Standard Time(GMT+00:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>ALWARE</OEMID><OEMTableID>ALIENWRE</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>100</Result><Products><Product GUID="{90120000-0030-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office Enterprise 2007</Name><Ver>12</Ver><Val>7480B9502DF0D86</Val><Hash>oYWOW5ayFE3pZ+jvTpuXYsY64JE=</Hash><Pid>89388-707-8722531-65336</Pid><PidType>14</PidType></Product></Products><Applications><App Id="15" Version="12" Result="100"/><App Id="16" Version="12" Result="100"/><App Id="18" Version="12" Result="100"/><App Id="19" Version="12" Result="100"/><App Id="1A" Version="12" Result="100"/><App Id="1B" Version="12" Result="100"/><App Id="44" Version="12" Result="100"/><App Id="A1" Version="12" Result="100"/><App Id="BA" Version="12" Result="100"/></Applications></Office></Software></GenuineResults> 

    Spsys.log Content: 0x80070002

    Licensing Data-->
    Software licensing service version: 6.1.7601.17514

    Name: Windows(R) 7, HomePremium edition
    Description: Windows Operating System - Windows(R) 7, OEM_COA_SLP channel
    Activation ID: 5e017a8a-f3f9-4167-b1bd-ba3e236a4d8f
    Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
    Extended PID: 00359-00196-174-079750-02-2057-7601.0000-1832011
    Installation ID: 000456175032054365161974495236378613959354237381684720
    Processor Certificate URL: http://go.microsoft.com/fwlink/?LinkID=88338
    Machine Certificate URL: http://go.microsoft.com/fwlink/?LinkID=88339
    Use License URL: http://go.microsoft.com/fwlink/?LinkID=88341
    Product Key Certificate URL: http://go.microsoft.com/fwlink/?LinkID=88340
    Partial Product Key: 3R4H9
    License Status: Licensed
    Remaining Windows rearm count: 2
    Trusted time: 02/07/2011 16:10:40

    Windows Activation Technologies-->
    HrOffline: 0x00000000
    HrOnline: 0x00000000
    HealthStatus: 0x0000000000000000
    Event Time Stamp: 7:2:2011 06:04
    ActiveX: Registered, Version: 7.1.7600.16395
    Admin Service: Registered, Version: 7.1.7600.16395
    HealthStatus Bitmask Output:

    HWID Data-->

    OEM Activation 1.0 Data-->

    OEM Activation 2.0 Data-->
    BIOS valid for OA 2.0: yes
    Windows marker version: 0x20001
    OEMID and OEMTableID Consistent: yes
    BIOS Information:
      ACPI Table Name    OEMID Value    OEMTableID Value
      APIC            ALWARE        ALIENWRE
      FACP            ALWARE        ALIENWRE
      HPET            ALWARE        ALIENWRE
      BOOT            ALWARE        ALIENWRE
      MCFG            ALWARE        ALIENWRE
      SLIC            ALWARE        ALIENWRE
      OSFR            ALWARE        ALIENWRE
      ASF!            ALWARE        ALIENWRE
      SSDT            INSYDE        INSYDE 
      ASPT            ALWARE        ALIENWRE
      SSDT            INSYDE        INSYDE 
      SSDT            INSYDE        INSYDE 
      DMAR            ALWARE        ALIENWRE
      SSDT            INSYDE        INSYDE 
      WDTT            ALWARE        ALIENWRE



    Windows Anytime Upgrade Log:

    2011-07-02 16:30:11, Info                  WAU    WindowsAnytimeUpgradeUI.exe started
    2011-07-02 16:30:11, Info                  WAU    An internet connection is available.
    2011-07-02 16:30:11, Info                  WAU    Found existing product key in registry.  WAU is advancing straight to the verification page.
    2011-07-02 16:30:11, Info                  WAU    Verify page created successfully.
    2011-07-02 16:30:18, Info                  WAU    EULA page created successfully.
    2011-07-02 16:30:22, Info                  WAU    Confirm page created successfully.
    2011-07-02 16:30:23, Info                  WAU    Progress page created successfully.
    2011-07-02 16:30:23, Info                  WAU    WindowsAnytimeUpgrade.exe is starting.
    2011-07-02 16:31:00, Error                 WAU    DoTransmogrify failed due to error 0x800f0905.
    2011-07-02 16:31:00, Error                 WAU    UpgradeSKU failed. Exiting.
    2011-07-02 16:31:00, Error                 WAU    Windows Anytime Upgrade was not successful
    2011-07-02 16:31:00, Error                 WAU    The upgrade was not successful. Please try the upgrade again.
    2011-07-02 16:31:00, Info                  WAU    WAUError page created successfully.
    2011-07-02 16:31:07, Info                  WAU    windowsAnytimeUpgradeUI.exe is exiting.


    Upgrade_dism.log (Too long to post so I have uploaded it to my server):
    Saturday, July 2, 2011 3:31 PM


All replies

  • Windows installation and upgrade receives free Microsoft support.  Begin here or use the link for your region by searching on "microsoft support".


    Colin Barnhorst Windows 7 Ultimate x64 on DIY with 6GB ram.
    Saturday, July 2, 2011 3:51 PM
  • I went there but it asks for a PID. I can't enter the one for Ultimate (obviously, since if I had the PID it would be installed and working) and if I select "No PID" or enter my home premium number it tells me that there will be a charge for the service - of £46, which seems a bit much considering I just paid over £100 for a piece of software that doesn't work!
    So, again, just wondering if anyone out there can help me with this problem?

    Windows installation and upgrade receives free Microsoft support.  Begin here or use the link for your region by searching on "microsoft support".


    Colin Barnhorst Windows 7 Ultimate x64 on DIY with 6GB ram.

    Saturday, July 2, 2011 11:14 PM
  • Run Regedit and search for the original product key.  OR in HKEY_USERS\S-1-5-21-##########-########-#....etc, locate Software\Microsoft\Windows\CurrentVersion\WindowsAnytimeUpgrade

    Delete the

    ProductKey  REG_SZ


    Close Registry editor


    Rerun the Windows Anytime Upgrade from Computer Properties screen, and the system will ask for a new key.  Obtain the correct key and you should be good to go.



    Wednesday, August 10, 2011 8:30 PM
  • To DuckMasterII

    You nailed it man! I was able to resolve my customer's issue.


    Windows Answer Desk Technician

    Friday, May 11, 2012 11:21 PM