locked
Developer Toolkit: The server was unable to process the request due to an internal error. RRS feed

  • Question

  • I think this has started happening after going to rollup 11. Whenever I open a CRM Solution, or try to connect to the CRM server using the developer toolkit I get this error:

    Full Error:
    The server was unable to process the request due to an internal error.  For more information about the error, either turn on IncludeExceptionDetailInFaults (either from ServiceBehaviorAttribute or from the <serviceDebug> configuration behavior) on the server in order to send the exception information back to the client, or turn on tracing as per the Microsoft .NET Framework 3.0 SDK documentation and inspect the server trace logs.

    Anyone else seen this?


    • Edited by Phil98765 Wednesday, October 24, 2012 12:48 AM edit
    Wednesday, October 24, 2012 12:48 AM

Answers

  • Problem solved :)

    So if the last database (you happened to be using the developer toolkit with) is now offline, you will get this error. Even if you are making a new project you will get this error.

    If you bring this database back online, you can then get past the "Authentication Details" group and into the "Organization" and "Solution Name" controls.

    Then you can choose another database and solution and hit OK.

    If you no longer have this database and can't remember what it's called to recreate it, you'll have to find where this value is stored (I couldn't find it).

    Reinstalling the developer toolkit didn't work for me.

    So it was nothing to do with Rollup 11 - it was just me taking some old databases offline


    • Edited by Phil98765 Wednesday, October 24, 2012 3:49 AM more info
    • Proposed as answer by Pavlos Panagiotidis Wednesday, October 24, 2012 8:39 AM
    • Marked as answer by Phil98765 Wednesday, October 24, 2012 7:36 PM
    Wednesday, October 24, 2012 3:48 AM

All replies

  • restarting the server seems to make it work for a short period of time - as does IISReset - but then the problem returns
    Wednesday, October 24, 2012 2:45 AM
  • Problem solved :)

    So if the last database (you happened to be using the developer toolkit with) is now offline, you will get this error. Even if you are making a new project you will get this error.

    If you bring this database back online, you can then get past the "Authentication Details" group and into the "Organization" and "Solution Name" controls.

    Then you can choose another database and solution and hit OK.

    If you no longer have this database and can't remember what it's called to recreate it, you'll have to find where this value is stored (I couldn't find it).

    Reinstalling the developer toolkit didn't work for me.

    So it was nothing to do with Rollup 11 - it was just me taking some old databases offline


    • Edited by Phil98765 Wednesday, October 24, 2012 3:49 AM more info
    • Proposed as answer by Pavlos Panagiotidis Wednesday, October 24, 2012 8:39 AM
    • Marked as answer by Phil98765 Wednesday, October 24, 2012 7:36 PM
    Wednesday, October 24, 2012 3:48 AM
  • Has anyone got any more hints about resolving this problem?
    I feel like I may be experiencing the same problem as I have had other databases attached, but I don't know their names or how to fix.

    I've got CRM, Reporting Extensions & SQL installed on a server

    Then on a different computer I've got Visual Studio + the BIDS extensions installed on.

    Just getting errors when trying to connect the BIDS DYnamics CRM Fetch connector data source to CRM

    Thanks

    James

    Tuesday, April 16, 2013 6:22 AM
  • Did u manage to fix this problem?
    Thursday, August 7, 2014 10:22 AM