locked
Import org using the deployment admin failed to recongnize users in the db RRS feed

  • Question

  • Hello, I have a db that want to upgrade to crm 2011 . I am using the RTM version.

    When I was prompted to map the users it doesnt matter what option I choose, it does not detect there is any users in the db.

    Then the next screen is

    "You must map your Active Directory user account to at least one enaled Microsoft Dynamics CRM user who has the System Administrator security role before the organization can be imported."

    Is this a bug?

    What can I do to troubleshoot?

    Thanks

    Monday, March 21, 2011 6:13 PM

All replies

  • Hi Patrick,

    Can you map users manually ? Is this the same domain or you want to move CRM to new domain ?

    KG


    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    Monday, March 21, 2011 10:08 PM
  • To answer your questions, none of the mapping options worked and I was moving CRM to a different domain.

    Fortunately, I was able to find the problem using SQL Profiler.  The problem was in the organization table where the integrationuserid GUID did not match the one in the systemuser table.  Not sure how it go into that state – we’ve had CRM since ver1.2.

    Thursday, March 24, 2011 5:24 PM
  • Hi Patrick,

    Did you try this??

     

    I got the same error when i was importing the org, Choose the manual mapping

    db administrator -> default administrator

    db user -> users

    This should works.

     

    Previously i have mapped "db administrator -> user", this wont work. I got the same error which you got. Later it got resolved by using the above process.


    Khaja Mohiddin
    Friday, March 25, 2011 12:19 AM