none
How to change the name of a pasted image before publishing?

    Question

  • It is a great feature to be able to just past an image into a blog post with WLW, however it because dangerous because it gives a generic numbered name to each image in the post.  Over time I will end up with alot of image1 and image2 files in my WordPress media manager.

    Is there a way to change the name before publishing the first time?  Is there a plug-in that can provide this functionality for a pasted image?
    Creepy
    Sunday, September 06, 2009 9:41 PM

Answers

All replies

  • Check out my clipboard plugin which does exactly what you want. Details here: http://scottisafooldev.spaces.live.com/blog/cns!FE151030F50B5B37!1819.entry
    SL - Windows Live Platform MVP
    If my post has answered your question, please mark it as an answer.
    • Proposed as answer by Scott Lovegrove Sunday, September 06, 2009 10:16 PM
    • Marked as answer by Rodney Foley Sunday, September 06, 2009 11:47 PM
    Sunday, September 06, 2009 10:16 PM
  • Hi Scott,

    Thanks, I marked this as answered as it looks like this will work great.  However, I doesn't work on my box.  After installing it I open WLW and it is not listed in the plugins list.  I did a repair and same results.  I looked in the plugins directory but no DLL for your plugin is there.

    I am using Windows 7 64 bit, using WLW build 14.0.8089.726.  

    I really like to use it, not sure what is going wrong here, I would appreciate any help in getting it working.

    Kind Regards,

    Creepy Gnome

    Creepy
    Monday, September 07, 2009 6:29 AM
  • Ah, I might need to double check the installer on that one then. In the mean time, go to c:\program files (x86)\scottisafool. In there you will find the folder for that plugin, just go in there, take the dll out and drop it in the plugins folder in the Live\Writer folder.
    SL - Windows Live Platform MVP
    If my post has answered your question, please mark it as an answer.
    Monday, September 07, 2009 7:10 AM
  • Thanks that worked.  For the record, I also noticed I have your Wikipedia plugin, and its DLL isn't in the plugin folder for WLW but it is in the scottisafool folder, and it works fine.  Are you just registering them with WLW via the registry and pointing them to your folder?  

    If so the wikipedia installer works fine for you compare to, and maybe related to the registry redirector.

    Creepy
    Monday, September 07, 2009 7:18 AM
  • Yeah, I use a registry entry to tell Writer where it is. I think I know what's wrong with the clipboard installer though, should be a quick fix. Glad the clipboard plugin is working for you now.
    SL - Windows Live Platform MVP
    If my post has answered your question, please mark it as an answer.
    Monday, September 07, 2009 7:20 AM