locked
Unable to mount backup RRS feed

  • Question

  • My DIY Windows Home Server backup and restore just fine (tested on 2 different machines) but for some reasons, I can never open the backups via the connector console.  Whenever I try to open the backup, I'll get the error:  Cannot mount the backup.

    I'm using Windows XP across the board, all 32-bit.

    Does any know what causes this and how to fix it?  Thanks.
    Thursday, October 22, 2009 11:55 PM

All replies

  • Apossible solution is the answer from Marc Moon in this thread. If that doesn't help you can also try the Repair option in the WHS console Settings Menu, Backup tab. Please note you may loose all current backups if you use the Repair option.

    If Repair also doesn't fix it or if you don't want to try this please provide some more detail;

    When exactly do you get the error?
    What's the exact error message(s)
    Any errors in the eventlogs on the client or server (Start, Run, type eventvwr.msc, Hit Enter) around the time you try to mount the backup?
    Does his happen on all clients?
    Are your server and client updated?

    Friday, October 23, 2009 6:50 AM
    Moderator
  • OK Since I have been unable to find a solution to this problem anywhere, here are the steps I took to resolve this and hopefully anyone else looking for a solution may find it here.

    First this solution is only for a WHS Installation that has just been completed and following these steps for someone wanting a solution for a restore that is critical these steps will
    not work.

    Windows Home Server Console: 6.0.1800.0
    Windows Home Server Backup & Restore: 6.0.1800.0
    Windows Home Server Drive Extender: 6.0.1800.0
    Windows Home Server Remote Access: 6.0.1800.0
    Windows Home Server Storage Manager: 6.0.1800.0

    This is with PP1 Only

    1. Un install all Connector Software on all Clients.
    2. Delete the c:\Program Files\Windows Home Server folder on the Clients , and Restart the Client PC.
    3. Perform a Complete New Installation of WINDOWS HOME SERVER. As you can see now, this will erase all drives on the Server. Setup your users as before.
    4. After reinstallation use IE and got http://[server name]:55000 and load the Connector Software. DO NOT USE THE CD TO INSTALL THE CONNECTOR SOFTWARE. I believe this is what caused my problem.

     I selected not to update the collector software if the Server gets updated. I also turned off (for now) Auto Updates. I want to do this a step at a time to see if an update causes the problem later.

    5. Connect to the Server using Connector Software and configure and run a backup on the Client.
    6. After the Backup completes try a restore and see if it has resolved the Cannot Mount Backup error. During the Restore I did get a warning that one of the files it was trying to replace was newer, I selected to not replace it. This was related to the Backup Reader.sys file.

    This worked for me, and even though performing a New Installation was a little bit of a pain it did solve my Cannot Mount Backup error.

    I am testing another Client and after that will look at running Windows update for the WHS.

    The only thing I can conclude is that the Windows Update is not updating the Connect Software correctly as I kept getting the Server Connect software does not match the server error when I ran the WHSToolkit. Even though I un installed and deleted the Server Connect software and folders several times, I believe the Server Connect Software was still not matching the server.

    Tuesday, November 10, 2009 7:19 PM
  • ...
    as I kept getting the Server Connect software does not match the server error when I ran the WHSToolkit.
    ...

    This is normal for Power Pack 2. For whatever reason, Microsoft decided not to update version numbers for the Power Pack 2 connector, and as a result you see that error in the Toolkit.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, November 10, 2009 8:11 PM
    Moderator