locked
Outlook sends winmail.dat attachment when Track in CRM is clicked RRS feed

  • Question

  •  

    CRM 4.0, Outlook 2003 SP3 or 2007, WinXP,

    same behavior via Internet explorer

     

    If a client clicks on Track in CRM button and sends email with attachment, for example .xls file Outlook sends it as an winmail.dat attachment (or some times as an .dst file) which is unreadable for many people. If the function Track in CRM is not active the attachment is send OK.

     

    I have played a bit with format of sent e-mails, e.g. plain text, html but it behaves still in the same way.

     

    Could you please help me?

     

    Thanx

     

    Jan

    Tuesday, July 8, 2008 7:38 AM

Answers

  • There is no solution, I have set up a case at Microsoft Support and they said it is caused by Outlook, and will be solved in a new version...

     

    Wednesday, October 29, 2008 8:47 AM

All replies

  • Winmail.dat is the file with the format instructions that Outlook includes when the message is sent in RTF format.  See http://support.microsoft.com/kb/278061

    1.  What email client is the recipient using
    2.  Follow the instructions in the above KB article to clear the setting in the SMTP tab so the setting in the address book does not always send in RTF format.

    Typically changing the format of the message to plain text or html fixes it, but I have seen with some obscure e-mail clients that it will still see winmail.dat unless the contact is set to always send in plain text.
    Wednesday, July 9, 2008 2:30 AM
    Moderator
  • Dear Joel, thank for your reply...

     

    I made quite a big research and here is what I found:

     

    1) winmail.dat file is sent only in case "Track in CRM" is marked.

    2) it is SMTP server depended, the client can use two SMTP servers, one works fine, second makes winmail.dat file

    3) same behavior even if you send the mail from CRM via Internet explorer

     

    So the result is, it is caused by CRM. It must change the outgoing e-mail in some way (probably changes the mail format to TNEF). I would like to tell CRM not to do this Smile

     

    You can change manualy send as rich text format at each contact, but imagine the client has 500 active contacts... And some of the clients need to get formated email, if you change outlook to send emails in HTML format this setting is ignored when Track in CRM is active...

     

     

    Do you have any advise?

     

    Thursday, July 10, 2008 9:25 AM
  • I would advise you to call support and set up a case.  Since it is only happening with one of your SMTP servers, it may be something in the way that CRM is affecting the email, but also in how that SMTP server is processing it. Could be a problem with how the SMTP server is processing the tracking token.

     

    Really the only change that CRM makes is the tracking token (if you are using it).

     

    MSFT support will help you get to the bottom of this.

     

    Also, it would be good to know what e-mail client the recipients are using that are having problems with the winmail.dat files.  If they use Outlook, it should not cause a problem. 

     

    Thursday, July 10, 2008 10:59 AM
    Moderator
  • Yes I use the tracking token.

     

    If the recipient uses Outlook than its OK (But outlook express has problem).

    If the resipient uses some freemail like gmail.com it is sometimes OK sometimes not, depending on the freemail provider (here in the Czech Republic the most common freemail service is seznam.cz which of course has problems Smile

     

     

     

    Thursday, July 10, 2008 11:27 AM
  • Outlook Express  has a lot of problems. Support for it is being discontinued by Microsoft.  Anyone who uses it should upgrade to the free windows live mail

    http://get.live.com/wlmail/overview?wa=wsignin1.0

     

    I know you cannot force your customers to do this however.  I would recommend that you set up a case with Microsoft Support and troubleshoot why this is happening with your SMTP server.

    Thursday, July 10, 2008 11:40 AM
    Moderator
  • OK thank you and have a nice day

     

    Thursday, July 10, 2008 11:45 AM
  • Hello Jan!
    Do you find solution for this f...g winmail.dat?
    Tuesday, October 28, 2008 6:20 PM
  • There is no solution, I have set up a case at Microsoft Support and they said it is caused by Outlook, and will be solved in a new version...

     

    Wednesday, October 29, 2008 8:47 AM
  • Hi there,

    we have the same problem, so MS, please do something!

    Cheers Felix
    Wednesday, December 10, 2008 8:30 AM
  • Hi

    we have this problem now, did MS come up with an answer?

    i cant find a solution anywhere as yet.


    many thanks

    bob.
    Wednesday, October 14, 2009 10:19 AM
  • We have the same problem with CRM. Not only the attachment is sent as winmail.dat, also if a client replies to me and the email is tracked in CRM, in outlook I do NOT see the reply at all. I just see the original email. This happens always with the same clients, regardless if the attachment was sent or not. Another thing I have noticed is, that most (if not all) of our customers that I have problems with use Lotus Notes.

    Any ideas?
    Monday, January 11, 2010 9:01 AM
  • As far as I know there is no official solution from MS, I have bought a new mail server for SMTP (choose cheapest one) and all e-mails are converted into plain text. In this settings emails arrive with attachment but with no formating. Most problems are with some linux based SMTP servers and Lotus notes on the recipient site.
    Monday, January 11, 2010 2:39 PM
  • I have the following solution; tested with Outlook 2007 should work with 2003, untested for messages composed in the CRM web (IE) interface or sent via the CRM mail connector.

    Using the Redemption library for access to advanced MAPI properties (not available through the Outlook object model), write an Outlook VBA macro on ItemSend event handler which explicitly sets the UseTNEF tag (0x8582) (transport neutral encapsulation aka. winmail.dat) to false.

    http://www.dimastr.com/redemption/

    Private Sub Application_ItemSend(ByVal Item As Object, Cancel As Boolean)
        Dim Utils As Redemption.MAPIUtils
        Set Utils = CreateObject("Redemption.MAPIUtils")
        Dim rMailItem As Redemption.SafeMailItem
        Set rMailItem = CreateObject("Redemption.SafeMailItem")
          If TypeName(Item) = "MailItem" Then
            rMailItem.Item = Item
            xUseTNEF = Utils.GetIDsFromNames(Item.MAPIOBJECT, "{00062008-0000-0000-C000-000000000046}", &H8582, False)
            rValue = Utils.HrSetOneProp(Item.MAPIOBJECT, xUseTNEF OR &H000B, False, True)
        End If
    End Sub

    There are other flags and settings relating to HTML and format selection at both the message and recipient levels but this is the one which resolved the attachment issue for me.
    Regards

    Peter
    • Proposed as answer by Dscpt Thursday, January 14, 2010 6:52 PM
    Thursday, January 14, 2010 6:51 PM
  • Hi, I have tested your solution, but it doesn work for me, Outlook still sends emails as TNEF, do you have any idea why?

    Regards Jan

    Thursday, May 27, 2010 9:30 AM
  • Hi

    I hate to be one of the posters that say "I have the problem too" but "I have the problem too"

    Here is some facts if it helps/diagnose/assist/come up with ideas:

    Sender is using Outlook 2007 or Outlook 2010

    Sending an email with an attachment is received in Outlook 2007/2010 OK (not tracked in CRM).

    Sending an email with an attachment that is "Tracked in CRM" is received in Outlook 2007/2010 comes as a "winmail.dat" attachment.

    The only way to get it to work is to right click on email address before sending and set to "send as plain text only"   (Both HTML and RTF CRM tracked emails result in winmail.dat attachments)

    Sending as plain text is not an option.

    This is not a "sending to a non-Outlook client" issue (as various KBs refer to)

    Tracking with and without a tracking token doesn't seem to affect the issue.

    The fact that it is "Tracked in CRM" does affect the email and how it is sent.

    Turning on the CRM icon on or off does not help.

    No surprise, but doing a search on KBs in partnersource turns up nothing (are these even being updated anymore?)

    I am about to raise a support incident with MS, but from other posts it appears that others have done this and have *not* had a resolution? 

    Thanks in advance.

    Nick

    Tuesday, July 6, 2010 12:42 AM
  • Hi Nick, I have only one solution and this is what Dscpt wrote, but it costs few dollars, so it is very hard to convince the client to buy something to send html formated email in the year 2010...

    Try to open an incident with MS, maybe you will have more luck then I had.

     

    Jan

    Thursday, July 15, 2010 10:08 AM
  • This fixed if for me for Outlook 2007, still having an issue with Outlook 2010 and 2003.

    (I don't think you need the actual hotfix if running the latest SP, just the registry setting)

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;958012

    If I ever get Office 2010/2003 working, I will post here.

    Cheers
    Nick

     

    Thursday, July 15, 2010 11:53 AM
  • Hi, thanx for the link, unfortunatelly the client uses mostly Office2003 and want to migrate to 2010 :(

     

    Regards Jan

     

     

    Friday, July 16, 2010 1:23 PM
  • Hi Jan

    This seemed to fix it for me for Office 2010, sorry as I don't have a solution for 2003...

    Standard warnings apply for registry modifications.

    After you have made a backup of the registry, try the registry key as follows:

    1. Exit Outlook 2010.

    2. Start Registry Editor.

    3. Locate and then select the following registry subkeys:

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences

    3. On the Edit menu, point to New, and then click DWORD Value.

    5. Type DisableTNEF, and then press ENTER.

    6. Right-click DisableTNEF, and then click Modify.

    7. In the Value data box, type 1, and then click OK.

    8. Exit Registry Editor.

    9. Restart the computer.

     

    I did this and was able to send a tracked CRM email successfully.

    Cheers

    Nick

     

    • Proposed as answer by ReadyXRM Friday, June 3, 2011 2:43 PM
    Sunday, July 18, 2010 12:05 AM
  • Nick

    Found your solution and it has worked perfectly for us.  We have recently started using Microsoft CRM.  We are using Outlook 2010 and when sending a tracked email to a customer who was not using Microsoft Outlook (eg. one of our bigger customers has Lotus Notes) our emails were converted to plain text and had a winmail.dat attachment.  Customers were starting to ask what the attachment was and we have spent a long time finding the answer despite logging a problem with Microsoft support.

    We have found that tracking emails means a Microsoft propriety format called TNEF is used.  This is fine if the receipient has Outlook but does n't work if they dont.  We have followed your simple steps above to chage the registry and everything now works.  We have done various checks with tracking emails and it does n't seem to have broken any of the functions.  We have also tested things like calendar appointments to make sure they still work with TNEF disabled.

    Many thanks for your solution.  For others reading this I would suggest following the nine steps above to see if it will fix your problem

    Ian

     

    Thursday, May 12, 2011 12:21 PM