locked
Media player during remote desktop RRS feed

  • Question

  • When I use remote desktop ( or MSTSC ) to connect to my server there is no audio devices present. Audio works fine if I direct log onto my server. This used to work great on ver 1 but with 2011 it has no audio devices installed. Any Ideas where it could be turned off?
    Emmett
    Friday, August 19, 2011 11:52 PM

Answers

  • In theory, yes, that should work. However, it's entirely possible that Microsoft has disabled this, since use as a remote-controlled media player isn't a design requirement, and technically the use of Remote Desktop isn't supported (never mind that for anything out of the ordinary you'll have to use it at some point).

    Since I don't have any sound configured on my server, I can't test and give you better instructions, I'm afraid.


    I'm not on the WHS team, I just post a lot. :)
    • Marked as answer by Emmett Chapman Saturday, August 20, 2011 10:56 PM
    Saturday, August 20, 2011 9:41 PM

All replies

  • Audio is switched off by default as it is a Server. If it "works fine" when you log in directly to your Server you must have changed it from the default settings.
    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Saturday, August 20, 2011 12:00 AM
  • Agreed. Some how it has changed but how can I get a audio device to work while using remote desktop? I tried installing the driver again but still it only works when I log on directly.
    Emmett
    Saturday, August 20, 2011 12:08 AM
  • Not sure why you would want to, but have you tried looking under Remote Desktop settings, Local Resources, Remote Audio, Settings?
    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Saturday, August 20, 2011 12:19 AM
  • Yes I did set that up to play on remote just the same as I did with WHS Ver 1 which worked great. What I want to do is when I remote log in to be able to play some music through the server to listen to. I used it this way to listen to while out side at my fire pit through my Sony outside speakers and a old amplifier. I have a laptop I take out with me to control what I was listening to.

     


    Emmett
    Saturday, August 20, 2011 12:31 AM
  • Why not use the built in media streaming capabilities of WHS 2011 - one of the main  reasons for upgrading from WHS1?
    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Saturday, August 20, 2011 12:43 AM
  • Ok but how do I get audio to my old NAD stereo amp. It has no media streaming. I just need to cable from my sound card to the jacks on the amp
    Emmett
    Saturday, August 20, 2011 1:00 AM
  • Stream from your server via your wireless network to your laptop and then use analog out, with a cable from your laptop to your amp?
    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Saturday, August 20, 2011 1:21 AM
  • That would be fine but the Amp is in the house that will drive the speakers. Actually it is right next to the server as that is its only purpose. The Idea is to allow me to control the music I want to listen to out side at the fire pit to suit my mood. I would have to have a looong wire to get out to my fire pit.

    Somewhere WHS is turning off my audio drivers when I remote in. I just need to find out where that is as it works fine when I direct log in at the server. Unfortuantly that is in the house. It actually worked good in WHS ver 1 and I really do not want to go back to it at this point in time as I kind of like 2011.

     


    Emmett
    Saturday, August 20, 2011 1:35 AM
  • To get audio to play on your server via remote desktop, a couple of things are required.

    • You need have the correct audio drivers installed and configured. You can easily test this by logging in to your server locally and playing something in e.g. Windows Media Player. 
    • You need to configure your Remote Desktop client to leave audio on the server.
    • You need to connect to session 0, the console session, on the server. You can do this by using the /admin parameter for the Remote Desktop client.

    Note that this is completely unsupported, and to keep audio playing when you aren't using the server desktop you will wind up needing to leave the administrator logged in to the server. This is, rather obviously, a security risk.


    I'm not on the WHS team, I just post a lot. :)
    • Proposed as answer by Ken Warren Saturday, August 20, 2011 2:07 AM
    Saturday, August 20, 2011 2:07 AM
  • Ken

    If I understand you right then when I issue the command:

    mstsc.exe /v:WHS2011-Server /admin

    I should be able to connect to the sound card. How ever this is not working. I have the option set for sound to play on remote and the drivers do load when I log in locally. Am I issuing the command wrong?

     


    Emmett
    Saturday, August 20, 2011 3:18 AM
  • In theory, yes, that should work. However, it's entirely possible that Microsoft has disabled this, since use as a remote-controlled media player isn't a design requirement, and technically the use of Remote Desktop isn't supported (never mind that for anything out of the ordinary you'll have to use it at some point).

    Since I don't have any sound configured on my server, I can't test and give you better instructions, I'm afraid.


    I'm not on the WHS team, I just post a lot. :)
    • Marked as answer by Emmett Chapman Saturday, August 20, 2011 10:56 PM
    Saturday, August 20, 2011 9:41 PM
  • Thanks Ken and Phil

    I will have to keep looking though. I sure hate to go back to WHS 1 but I may have to if I can not find a way to use this as a media player or for my MagicJack (separate Problem). In the mean time I will keep playing  and testing.

     


    Emmett
    Saturday, August 20, 2011 11:00 PM