none
How to find registry keys for Windows Japanese Keyboard Settings? RRS feed

  • Question

  • I want to add Japanese keyboard for that i need to do specific settings for the keyboard. I want to find the registry keys for some of the settings like after installing the Japanese language there is option for 
    1. "Display Input mode at center of screen"
    2. "Convert words and characters using JIS X 0208 characters "      
    I tried every link and every setting but am not able to get the registry keys for these settings , can anyone please suggest me how can i found the keys regarding these or any method to find for any setting would be helpful.
    Thursday, July 18, 2019 1:27 AM

Answers

All replies

  • Hi,

    Thank you for posting here.

    >>How to find registry keys for Windows Japanese Keyboard Settings?

    I suggest you should configure the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters registry subkey .

    To configure these registry entries yourself, follow these steps:
    1,Start the Registry Editor:type regedit in the Start Search box, and then click regedit in the Programs list. If you are prompted for an administrator password or for confirmation, type the password, or click Continue.
    2,Locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

    For more details I suggest you could refer to the link: https://support.microsoft.com/en-us/help/927824/windows-may-not-use-the-correct-keyboard-layout-when-you-connect-a-usb

    Best Regards,

    Jeanine Zhang

    Thursday, July 18, 2019 5:39 AM
  • I already went through that link the settings they have told are for some other feature that i have already configured,, the settings for which i need the keys are not present on internet i tried a lot that's why i posted here if someone can help how to find them or there is any way to find keys for any feature .
    Thursday, July 18, 2019 7:21 AM
  • Hi,

    Have you set the default IME to Japanese? I suggest you could try to right click the Japanese ime tray icon (right click the A or あ icon) and enter the property. You will see a check box saying "Display input mode at center of screen" .And then check it .

    Best Regards,

    Jeanine Zhang

    Friday, July 19, 2019 9:44 AM
  • Sorry to say but i don't think so you have read my question properly i have clearly mentioned i am looking for the registry keys for those options i know how to do it manually!
    Monday, July 22, 2019 12:40 AM
  • Hi,

    I am sorry for not understanding what you mean .

    >>"Display Input mode at center of screen"

    1,Start the Registry Editor:type regedit in the Start Search box, and then click regedit in the Programs list. If you are prompted for an administrator password or for confirmation, type the password, or click Continue.
    2,Navigate to:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\StigRegKey\Typing\TaskbarAvoidanceEnabled 
    If not, create them sequentially according to the above path.
    3,Under TaskbarAvoidanceEnabled (TaskbarAvoidanceEnabled is selected on the left, right-click in the blank space on the right) to create a new DWORD (32-bit) value, the name is Enable, double-click the DWORD (32-bit) value, and modify its value data to 1
    4,After modifying, save and exit the registry editor, then return to the desktop, restart the computer directly.

    >> "Convert words and characters using JIS X 0208 characters "

    1,Start the Registry Editor:type regedit in the Start Search box, and then click regedit in the Programs list. If you are prompted for an administrator password or for confirmation, type the password, or click Continue.
    2,Navigate to:HKEY_CURRENT_USER\Console\%SystemRoot%_system32_cmd.exe
    3,Modify the value of CodePage to 932
    4,After modifying, save and exit the registry editor, then return to the desktop, restart the computer directly.

    Best Regards,

    Jeanine Zhang

    Monday, July 22, 2019 8:38 AM
  • Hi,

    Have you got any updates? If your case has been solved, please help to mark answers. If not, just feel free to contact us.

    Your understanding and cooperation will be grateful.

    Best Regards,

    Jeanine Zhang

    Thursday, July 25, 2019 6:46 AM
  • Thanks for in detail reply i have many queries listed below-

    1. StigRegKey this key and it's child folders are not present in my system so do i need to install something ?

    2.  %SystemRoot%_system32_cmd.exe is not present in my Console so do i need to install something? and since am  using 64 bit machine so do i have to same 32 bit exe ?

    3.  Is there any way how you found out these keys, i would like to really know so that in future i can work on them myself any help regarding this would be really helpful.

    Monday, July 29, 2019 1:23 AM
  • Hi,

    >>1. StigRegKey this key and it's child folders are not present in my system so do i need to install something ?

    If the StigRegKey, Typing or TaskbarAvoidanceEnabled don't exist right-click on the parent key and select New > Key from the context menu. Name the keys accordingly.

    >>%SystemRoot%_system32_cmd.exe is not present in my Console so do i need to install something? and since am  using 64 bit machine so do i have to same 32 bit exe ?

    The machine I am using is also 64-bit.%SystemRoot%_system32_cmd.exe exists in my console.

    I suggest you could try to navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage\OEMCP. And then modify the value of CodePage to 20932

    Best Regards,

    Jeanine Zhang

    Monday, July 29, 2019 8:39 AM
  • Hey sorry for the late replies :)

    1. I added the Japanese Language with following steps -

    Language-> Add a language -> Added Japanese-> Select it , the click Options->At the bottom "Microsoft IME" click on it -> Click on "Options"-> Display input mode at screen. -> Switched it to off, it's on by default .

    I added the keys at the exact path you have mentioned as those were not present in my system and then restarted the system. It remained OFF it didn't set to ON. Do i need to do a anything else?

    2. At the same location i am having 2 entries one is -

    -> _SysWOW64_WindowsPowerShell_v1.0_powershell.exe

    -> _System32_WindowsPowerShell_v1.0_powershell.exe

    Neither of those entries are having Codepage entry, what should i do?

    And i tried this also 

    I suggest you could try to navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage\OEMCP. And then modify the value of CodePage to 20932

    Nothing worked out

    • Edited by HimanshuKa Tuesday, July 30, 2019 10:16 AM
    Tuesday, July 30, 2019 10:07 AM
  • Hi,

    According to your case which is not related to c++, I will move it to Where is the Forum For…? forum to redirect it to the correct forum for better support.

    The Visual C++ forum Discuss and ask questions about the Visual C++ IDE, libraries, samples, tools, setup, and Windows programming.

    Best Regards,

    Jeanine Zhang

    Wednesday, July 31, 2019 6:56 AM
  • I'd try asking for help over here.

    https://social.technet.microsoft.com/Forums/en-US/home?forum=win10itprogeneral

    https://social.technet.microsoft.com/Forums/en-US/home?forum=w8itprogeneral

    https://social.technet.microsoft.com/Forums/en-US/home?forum=w7itprogeneral

    https://social.msdn.microsoft.com/Forums/windowsdesktop/en-US/home?forum=windowsgeneraldevelopmentissues

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Wednesday, July 31, 2019 12:45 PM
    Moderator