locked
Recent problems with WHS 2k3 network RRS feed

  • Question

  • Need some suggestions before I reinstall my server completely.

    I've had my server running fine for a long time now. No troubles at all actually.

    A few months ago I got myself a new Samsung Smart-TV, and discovered that I had to use other software on the server to be able to play all files. Installed Serviio and the whs-addon, and everything was working really great.

    A few weeks ago, things started to play tricks on me, without any changes on the server. I kept loosing the connection to the server from my TV, and I guessed it was due to Serviio. Tried using the built in media sharing and play media using my xbox, problems there as well. Tried reinstalling serviio, no luck. Removed serviio completely and installed PS3 media server. Works every now and then, but then all of a sudden the connection is dropped and I have to restart a few times for the devices to find eachother.

    I tried using another computer (XP Pro SP3) and it works most of the time, but every now and then I get random disconnections.

    I have no problems what so ever with backups, no warnings from consol, no obvious errors in event logs.

    Recently, I have also noticed that something is affecting my homeserver.com (can't connect at all from outside the house)

    I've tried new drivers for my Realtek NIC, actually 2 sets of new drivers as a new was released while trying to locate what is wrong.

    I have a managed gbit switch showing no dropped packages at all. I have checked all cables in the house, replaced all old cables with new cat6.

    I've been writing to guys at Serviio, according to them it seems to be network related and not their software. I think I can confirm this as so many other things are playing tricks on me.

    I've also noticed that if I have utorrent on a client saving something on the shares and close the program, when I reopen the program it will take ages to verify the files which usually only takes me a few seconds.

    As everything seems ok according to all logs, and that there was no changes at all when the problems started, I am running out of ideas where to start. Any suggestions I could try before I reinstall the server?

    Friday, March 30, 2012 1:18 PM

All replies

  • Check your server's event logs, and look the errors reported up online (note: most "errors" are likely to be innocuous, please don't dump a huge list of less than meaningful errors on us to interpret :) ). If you find errors, I would not be surprised if they're disk related; in that case run chkdsk on all the drives in your server. There's a FAQ (in the FAQ section) about this.

    Other than that, step by step analysis of the issue is your best bet. Hope you like solving problems. :)


    I'm not on the WHS team, I just post a lot. :)

    Friday, March 30, 2012 1:26 PM
    Moderator
  • I haven't seen anything strange at all in the logs.

    However, I think I still have that batch for chkdsk on all drives, will start that when I get home as I haven't done so in many months.

    If I like solving problems? Well, you might recall that I spent a lot of time on this forum a while ago before I got everything running. I think I will find ways to keep myself busy solving problems all weekend :P

    Friday, March 30, 2012 1:31 PM
  • Update, started the batch, and as usual it took a few days scanning the free space. Aborted as I had to get access to some files on the server, and rebooted. Only thing I noticed fixed was some files not indexed. Let's see if things are running now.

    Regarding the free space problem, is it possible to exclude that from the scan? I do know that many issues could be related to errors in free space, but from what I've experienced before it's more likely to be found somewhere else among the existing files.

    Monday, April 2, 2012 6:02 AM