none
VS 2015 Community, debugging an Azure App, returns that a parameter is not being provided to a stored proc but it is provided. RRS feed

  • Question

  • Here is a link to the SO post: https://stackoverflow.com/questions/47104043/visual-studio-returns-error-from-azure-that-a-parameter-isnt-provided-but-is 

    Basically, debugging in Azure, there is a line of code where ExecuteNonQuery() is being called, with the command type of Stored Procedure being specified, all parameters are provided but the code throws an error that a parameter isn't being provided.

    I've verified the param names are right, case of names are right, order of INSERT INTO () AND VALUES () are correct and so on.

    Tried hard coded values, tried everything.  Verified at the database level that the query works.

    See the SO post for details or if this needs to be duplicated here, that can be done.  I'm hoping to not have the full post which is very lengthy posted all over hell's half acre.

    Looking for some help here.

    Thanks,

    Mike Durthaler


    Michael Durthaler

    • Moved by 宝宝徐 Monday, November 13, 2017 9:34 AM
    Saturday, November 4, 2017 7:31 PM

All replies

  • Hi Mike,

    Thanks for your posting.

    This forum is for VS IDE issue, may I ask what kind of application are you developing.

    Have you tried to debug the app locally? Or the issue only happens when you are debugging it on cloud?

       

    Best regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by Fletch Zhou Monday, November 6, 2017 9:04 AM
    Monday, November 6, 2017 9:03 AM