locked
Money won't start RRS feed

  • Question

  • Yesterday and this morning when I try to open Money Plus I get a small window headed "Shutting down", followed by "Money has experience a problem and cannot continue. If you are running low on memory try closing some programs and running money again." I have heaps of space in the RAM so that isn't the cause. Is there anything I can do other than installing again? (Assuming downloading afresh will overcome the problem.)
    Wednesday, November 6, 2019 9:51 PM

All replies

  • First, make sure that you have a copies of your Money.mny file and recent backups on another medium such as a flash drive.  If your Money.mny file has become corrupted or there is a problem with your computer you may need those backups.

    Next, try opening your Sample.mny file to see if your Money installation is OK.

    Then, see Cal's advice here:

    https://social.microsoft.com/Forums/en-US/a0884e1c-cff3-4724-a4c2-331ac3242b8b/ms-money-plus-wont-open-error-message-please-help?forum=money

    Post back to let us know how you make out and be sure to include what version of Money you are running and the version of Windows that you have installed.


    Bill Becker

    Wednesday, November 6, 2019 10:06 PM
  • Thanks Bill. My version of money is Money Plus Sunset edition Deluxe.  My OS is Windows 10 Home 64 bit.

    I tried to get the sample file to load and got the same message, so put my three .mny files, the recent back-ups, (from 4 days ago and I've had it running since then), and sample.mny onto a flash drive.

    I guess the next step is to reinstal the sunset version?

    Thursday, November 7, 2019 8:35 AM
  • Oh dear! I have just installed Money Plus Sunset Deluxe and when I tried to run it I got the same error message as before. It is definitely the one I just downloaded; I checked the file date and time. When I can get my wife off her computer I will try downloading it there. Mean time anyone has any suggestions I'd love to hear them.
    Thursday, November 7, 2019 10:25 AM
  • After installing Money Plus Deluxe Sunset, put the patched versionmnyob99.dll into place in  MNYCoreFiles as described in what is currently the first post in this forum.

    Then copy Sample.mny from your install folder (typically
    C:\Program Files\Microsoft Money Plus\ or
    C:\Program Files (x86)\Microsoft Money Plus\
    with 64-bit Windows) to your Documents folder.  Open Money by right-clicking that copy of sample.mny and choose Open.

    While in Sample.mny, go to Tools->Settings->ProgramSettings and set
    (GeneralDisplay:)StartMoneyWithThisPageOpen:AccountList
    Open the problem file a time two.  Does that file open now?  If so, go to Tools->Settings->HomePageDisplaySettings and Remove the Investment Performance module.  There has been a problem where a lot of investments triggers a crash upon opening where Money opens to the "Home Page".

    Thursday, November 7, 2019 3:31 PM
    Moderator
  • Thanks, will do that. Incisdentally, I installed the sunset version on my wife's computer and it works perfectly. Can't figure that, at we both have almost identical HP All-In_One comps with the same build number and the same security system.

    Thursday, November 7, 2019 11:59 PM
  • Since your Money.mny file opens on your wife's computer, it seems that the file is OK.

    One thing to try is to open a command prompt as an administrator on your computer and run "sfc /scannow".  This will do a quick check for corrupted system files.


    Bill Becker

    Friday, November 8, 2019 2:14 AM
  • I tried that, but it won't let me right click on the result to open as admin. I tried scf.exe and that did allow right click, but it opened a small box for a nanosecond and then went away. Anyway I think doing that may be irrelevant now as, having difficulty with the Moderator answer above, I uninstalled the money file completely, registry files included, and tried downloading and installing the app again. This time it seems to have worked, but with one strange obstruction. It is asking for my password, which as a new install doesn't exist. I tried my password from the previous version before the problem, but it won't accept it. There is no apparent 'I can't remember my password' option so what do I do now? Just as well I got it to download successfully, (and ask me to set up a password), on my wife's computer, but I really need it on mine.  
    • Edited by bilnrobn Friday, November 8, 2019 3:19 AM
    Friday, November 8, 2019 3:17 AM
  • In Windows 10, if you do a search for "Command Prompt" you should see that app come up and then when you right-click on it you should see the choice to "Run as Administrator".  Does that happen?  If so, then typing sfc /scannow into the Command Prompt window should run.

    As for the password issue, Money passwords are associated with Money files, - not with the Money installation.  Do you have a password on your current Money file?  Do you need that password to open the file on your wife's computer?  Is it associated with a Microsoft account?

    Just to be sure, did you download and install Money from the second "sticky" thread in this forum:

    https://social.microsoft.com/Forums/en-US/479281b2-90f9-42ca-85f7-644fc6e1e5c3/download-microsoft-money-installation-files-solve-activation-and-some-other-errors?forum=money

    and did you do the required mnyob99.dll replacement as described in the first "sticky" thread in this forum:

    https://social.microsoft.com/Forums/en-US/d28d6921-1f01-430f-b33e-f5a3ec47077b/important-patch-for-money-plus-maybe-20062007-mnyob99dll?forum=money


    Bill Becker

    Friday, November 8, 2019 4:25 AM
  • Having shut down and later rebooted I find that money is now working perfectly. It has allowed me to set a password for both of the money files I currently have and the files seem complete and respond appropriately to all commands I enter. So I can say the problem is solved due to some of the advice given, albeit that I'm not sure which advice did the trick.

    Answering your above questions in sequence, I didn't do the scannow thing as whilst attempting to change to Administrator I found I could get into the Money sign in page.

    The password had never been on my computer with other saves passwords and as Money had been purged from the computer and had been reinstalled and uninstalled several times before it finally got me to the login screen, I can't see why it assumed I had a password rather than asking me to set one up. Suddenly that changed, perhaps because I shut down and later rebooted.

    No, I installed it by googling "Download Money sunset edition" and choosing a Microsoft link to do that.

    No, I didn't update the dll replacement as I finally got it to work after leaving that for the moment, as I was having problems getting the dll installed, and tried other options.

    The main thing is, the problem is solved and your suggestions and tenacity, along Cal's suggestion,seem to have been instrumental in getting me there. I just can't put my finger on exactly how!

    All a bit of a mystery, but heartfelt thanks tor both you and Cal. It is much appreciated.                                                       

    Friday, November 8, 2019 8:18 AM
  • Thanks Bill. I'll do that.
    Sunday, November 10, 2019 6:40 AM
  • Thanks Bill.  I added your tip to the article today.
    Sunday, November 10, 2019 5:32 PM