locked
Project server Save and Open issue RRS feed

  • Question

  • The requirement is i need to save a copy of the mpp file to sharepoint. Now When you open a project in Project Pro from Project server, you cannot directly use the Save As feature and user the sharepoint path say "http://server/project/project docuements" to save it, it throws a resource pool error... so the correct way of doing thins is

    1. Save ur exsisting project and close (once you save it it starts synch with the server)

    1.1 Open back the same project , and now it opens as read only because of the previous step 1.

    2. do a save as and save it locally (this will become your current project)

    3.do a save to sharepoint (the sharepoint file will become your current project)

    3. Close this project i.e the sharepoint opened project

    4. Open your pwa project back  again

    Now what happens or the issue.. is..

    When u open your original project back its still in readonly mode, beause of hte processing on the server because of operation in step 1.

    What i want is i want to save the Project, But dont want any snch operation with the server.

    app.FileSave() also causes synch... with server

    app.FileCloseex(pjsave, checkin : false) also is causing synch with server, wich at the end will make the project in readonly state

    how can i save my project locally or in cache whithout synch with server, when ever i want to checkin, or publish i will do it on demand.

    Thursday, June 23, 2011 12:55 PM

Answers

  • Hi There,

    Why not use the "Save As" option ? That way the file is saved locally without affecting the server copy. The go to your Doc Lib and upload the .mpp.

     

    Andre

    Thursday, June 23, 2011 3:00 PM

All replies

  • Try Save for sharing option.


    Thanks Gaurav Wason MCITP, PMP
    Thursday, June 23, 2011 2:22 PM
  • Hi There,

    Why not use the "Save As" option ? That way the file is saved locally without affecting the server copy. The go to your Doc Lib and upload the .mpp.

     

    Andre

    Thursday, June 23, 2011 3:00 PM
  • Never use Save for Sharing with 2010, there is a serious known issue around it.
    Thursday, June 23, 2011 3:06 PM