locked
You must enter the user name in the format <name>@<domain>. Correct the format and try again. RRS feed

  • Question

  • We have a CRM 2011 on-premise environment.  When we try to enter domain\username we receive the error below.

    Error

    You must enter the user name in the format <name>@<domain>.  Correct the format and try again.

    We don't have these issues on other CRM 2011 on-premise environments.  We prefer to not use the UPN username@domain because when authoring reports the filtered views will not return rows.

    Any ideas?



    Tuesday, September 30, 2014 9:44 PM

All replies

  • Where are you entering the user name? Is it for the log on name in the user form?

    Thursday, October 2, 2014 11:12 AM
    Moderator
  • When setting up a user account under Settings / Administration / Users
    Thursday, October 2, 2014 11:41 AM
  • Hmm. Well the domainname\username format should and does work. Has this ever worked for you?

    Do you have claims-based authentication configured?

    Thursday, October 2, 2014 11:49 AM
    Moderator
  • We have 3 separate environments and all 3 are claims based all 3 use their own active directory.  2 of the 3 environments work fine.
    Thursday, October 2, 2014 12:33 PM
  • All very puzzling. Is there anything "different" in the 2rd AD that might restrict the use of down level logon names? But then I don't see how CRM is enforcing the restriction.

    Please try the New Multiple Users button and see what options you are given on the Select Authentication Provider page. I have CRM with claims configured and I see Active Directory and Federated Identity provider options.

    I've run out of ideas.

    Thursday, October 2, 2014 1:44 PM
    Moderator