locked
Email and worflow don't work RRS feed

  • Question

  • Hi everybody !

    I created a worflow that should send a Email when a new activity "telephonic call" is created.

    In the systeme job, it's write "finished" but when i show details of the workflow it's write "This message has not been sent for delivery, consult help for more information"
    But there is nothing in the help.

    Someone have a idea of the problem please ?

    Thanks a lot

    Yousu
    Tuesday, March 2, 2010 1:32 PM

Answers

  • Good news, after uninstall and reinstall Outlook it works,

    Thanks all for your idea !

    Sincerely,

    Yousu
    Thursday, March 4, 2010 1:40 PM

All replies

  • A couple of things to check:

    Check CRM to see if the e-mail was created and is in Pending Send status.  If so, the system is most likely working as expected
    If the e-mail is created but in Draft status then you might have used the Create E-mail step rather than Send E-mail
    Check to ensure you have a valid Sender and Recipient for the e-mail
    Check the Regarding record of the e-mail to ensure it is a valid entity.  For example, you will receive an error if you try to set the E-mail Regarding to the Phone Activity.

    If none of the above are helpful in isolating the issue, then please provide more details about the workflow and what exactly is happening.


    Best Regards | Twitter: edwardsdna
    Tuesday, March 2, 2010 2:42 PM
  • Hi Donna,

    I checked all those things ( not the last one because i'm french and i don't understand your request ! ) and i've done some screenshot of the job statut ( unfortunatly my web environement is in french ).

    The first one show the worflow statut :
    http://www.casimages.com/img.php?i=100303111143386232.jpg

    This one show the information message :
    http://www.casimages.com/img.php?i=100303111143386232.jpg


    If you need more details ask me.

    Thanks again,


    Yousu
    Wednesday, March 3, 2010 10:17 AM
  • Hi Yousu,
    To send emails you will need to have Outlook Client or Exchange Email Router installed and configured otherwise you will not be able to send emails (they will stay in Pending Status). Other activities should be fine.
    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    Wednesday, March 3, 2010 10:41 AM
  • Hi Yousu,
    To send emails you will need to have Outlook Client or Exchange Email Router installed and configured otherwise you will not be able to send emails (they will stay in Pending Status). Other activities should be fine.
    My Dynamics CRM Blog: http://bovoweb.blogspot.com

    Hi !

    I have already Outlook with the CRM integrated.

    Are there some other configuration to make in Outlook to send E-mail ?

    ( I have the same problem for a quick Email campaign for example ).
    Wednesday, March 3, 2010 11:06 AM
  • In the Dynamics CRM on the user form you have selected Outgoing Email : Microsoft Dynamics CRM Outlook Client ?
    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    Wednesday, March 3, 2010 11:16 AM
  • In the Dynamics CRM on the user form you have selected Outgoing Email : Microsoft Dynamics CRM Outlook Client ?
    My Dynamics CRM Blog: http://bovoweb.blogspot.com

    Could you be more precise ?
    In fact a small pop-up window appear sometimes telling me that they are some mails in CRM which are not send, it ask me to make sure that Outlook is configurated, but the instruction are cut because the little pop-up window is too small and i can't elarge it ....
    Wednesday, March 3, 2010 1:04 PM
  • This popup windows it's asking if CRM Outlook Client may send an email. Select yes or Go to the CRM menu -> Options -> Email tab and mark option Allow send an emails ....

    After this it should work.
    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    Wednesday, March 3, 2010 1:47 PM
  • Have a look at this post for more information regarding the configuration needed.
    Best Regards | Twitter: edwardsdna
    Wednesday, March 3, 2010 2:50 PM
  • Good news, after uninstall and reinstall Outlook it works,

    Thanks all for your idea !

    Sincerely,

    Yousu
    Thursday, March 4, 2010 1:40 PM