Prompted to reinstall Windows as it is no longer recognised as valid. RRS feed

  • Question

  • Hello.

    I notice I am not the only person with a problem such as this but I am not computer savvy enough to know which solution might apply to me. Two weeks ago, I installed automatic updates to my computer (I believe the update was Service Pack 2) before going to bed that night. I went to work the next morning without using my laptop and then when I returned home, I turned on my computer and was then told my copy of Windows Vista is no longer valid and needs to be activated. I try to activate it but to no avail!

    I am using an ASUS Notebook with Windows Vista Ultimate.

    I try to activate it and the only message it gives me is to reinstall Windows which is the absolute last thing I want to have to do. I would be very grateful for any help on this matter.

    I ran a diagnostic as requested and here is the log.

    Diagnostic Report (1.9.0011.0):
    WGA Data-->
    Validation Status: Invalid License
    Validation Code: 50

    Cached Validation Code: N/A, hr = 0xc004f012
    Windows Product Key: *****-*****-YQQTB-FWK9V-932CC
    Windows Product Key Hash: L1zPFFvNQ04Nunm9BorPaqFl4jI=
    Windows Product ID: 89580-OEM-7332132-00031
    Windows Product ID Type: 2
    Windows License Type: OEM SLP
    Windows OS version: 6.0.6002.2.00010100.2.0.001
    ID: {4B23511A-4BF1-48B0-A4A0-E0A539E5C96A}(1)
    Is Admin: Yes
    TestCab: 0x0
    WGA Version: N/A, hr = 0x80070002
    Signed By: N/A, hr = 0x80070002
    Product Name: Windows Vista (TM) Ultimate
    Architecture: 0x00000000
    Build lab: 6002.lh_sp2rtm.090410-1830
    TTS Error:
    Validation Diagnostic:
    Resolution Status: N/A

    WgaER Data-->
    ThreatID(s): N/A, hr = 0x80070002
    Version: 6.0.6002.16398

    WGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    File Exists: No
    WgaTray.exe Signed By: Microsoft
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Notifications Data-->
    Cached Result: 102
    OGAExec.exe Signed By: N/A, hr = 0x80070002
    OGAAddin.dll Signed By: Microsoft

    OGA Data-->
    Office Status: 102
    2007 Microsoft Office system - 100 Genuine
    OGA Version: Registered,
    Signed By: Microsoft
    Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
    Default Browser: C:\Program Files\Mozilla Firefox\firefox.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{4B23511A-4BF1-48B0-A4A0-E0A539E5C96A}</UGUID><Version>1.9.0011.0</Version><OS>6.0.6002.2.00010100.2.0.001</OS><Architecture>x32</Architecture><PKey>*****-*****-*****-*****-932CC</PKey><PID>89580-OEM-7332132-00031</PID><PIDType>2</PIDType><SID>S-1-5-21-2127280691-795255804-2150988980</SID><SYSTEM><Manufacturer>ASUSTeK Computer Inc.        </Manufacturer><Model>M51Sn               </Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>303    </Version><SMBIOSVersion major="2" minor="4"/><Date>20071224000000.000000+000</Date></BIOS><HWID>8A313507018400F8</HWID><UserLCID>0C09</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Cen. Australia Standard Time(GMT+09:30)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>_ASUS_</OEMID><OEMTableID>Notebook</OEMTableID></OEM><GANotification><File Name="WgaTray.exe" Version=""/><File Name="OGAAddin.dll" Version=""/><File Name="OGAVerify.exe" Version=""/></GANotification></MachineData><Software><Office><Result>102</Result><Products><Product GUID="{91120000-0031-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>2007 Microsoft Office system</Name><Ver>12</Ver><Val>36B460104A4D820</Val><Hash>KeD9v95EjUr9y4A3qvwkt0YfGUQ=</Hash><Pid>89451-OEM-6601602-31982</Pid><PidType>11</PidType></Product></Products><Applications><App Id="15" Version="12" Result="100"/><App Id="16" Version="12" Result="100"/><App Id="18" Version="12" Result="100"/><App Id="19" Version="12" Result="100"/><App Id="1A" Version="12" Result="100"/><App Id="1B" Version="12" Result="100"/></Applications></Office></Software></GenuineResults> 

    Spsys.log Content: 0x80070002

    Licensing Data-->
    Software licensing service version: 6.0.6002.18005

    HWID Data-->

    OEM Activation 1.0 Data-->

    OEM Activation 2.0 Data-->
    BIOS valid for OA 2.0: yes
    Windows marker version: 0x20000
    OEMID and OEMTableID Consistent: yes
    BIOS Information:
      ACPI Table Name    OEMID Value    OEMTableID Value
      APIC            A_M_I_        OEMAPIC
      FACP            A_M_I_        OEMFACP
      DBGP            A_M_I_        OEMDBGP
      HPET            A_M_I_        OEMHPET
      BOOT            A_M_I_        OEMBOOT
      MCFG            A_M_I_        OEMMCFG
      SLIC            _ASUS_        Notebook
      ECDT            A_M_I_        OEMECDT
      OEMB            A_M_I_        AMI_OEM
      ATKG            A_M_I_        OEMATKG
      SSDT            PmRef        CpuPm

    I also tried to activate online as requested and received the following error code: [0x80080250]
    Thursday, August 27, 2009 9:15 AM


All replies

  • Hello fortunArcanum,

    It may be that Vista's Licensing Store is corrupt or malformed in some way. I would like you to try the below set of steps.  The first set will attempt to reset the Store and the second set will recreate it.  Try the first set and if that doesn't work, move on to the next.

    1) Click the option that launches an Internet Browser
    2) Type: %windir%\system32 into the address field
    3) Find the file cmd.exe
    4) Right-click on cmd.exe and select Run as Administrator
    5) Type: cscript %windir%\System32\slmgr.vbs /ilc %windir%\System32\licensing\ppdlic\Security-Licensing-SLC-ppdlic.xrm-ms
    6) Hit the Enter key
    7) Reboot twice

    1) Return to the cmd windows 
    2) Type: net stop slsvc  (it may ask you if you are sure, select yes)
    3) Type: cd %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareLicensing
    4) Type: rename tokens.dat tokens.bar
    5) Type: cd %windir%\system32
    6) Type: net start slsvc
    7) Type: cscript slmgr.vbs -rilc (It may take a long time for this to complete, please be patient)
    8) Reboot Twice
    9) You may be required to enter the Product Key (from the sticker on the side or bottom of the computer) and then Activate by Phone

    Please post if this resolves the issue or not,
    Darin MS

    • Proposed as answer by Darin Smith MS Thursday, August 27, 2009 5:16 PM
    Thursday, August 27, 2009 5:15 PM
  • Thank you for such a swift response, Darin.

    I tried the first set of steps and it didn't make a change so I moved on to the second set. Everything went fine until step 7, where it started to install some of the license files and the script ended with an error notice: 0xC004F01F and told me to run 'slui.exe 0x2a 0xC004F01F' to display the error text.

    The text read: An error has occured.
    Code: 0xC004F01F
    Description: The Software Licensing Service determined that the licence is invalid.

    Now, when I try to activate Windows, instead of the initial message telling me to reinstall Windows, I get a different message which reads:
    An error has occured.
    Code: 0xC004F055
    Description: The Software Licensing Service determined that the base SKU is not available.

    I'm not sure where to go from here.
    • Edited by fortunArcanum Friday, August 28, 2009 12:59 PM more information
    Friday, August 28, 2009 12:52 PM
  • Hello fortunArcanum,

    Just to confirm, you did do step "4) Type: rename tokens.dat tokens.bar"? The reason I ask is The Software Licensing Service should not be able to determined that the licence is invalid when the Licensing Store doesn't exist (as far as Vista is concerned renaming a file is the same as deleting it).

    I've never seen the second set of steps Not resolve a code 0xc004f012  (i'm actually think about removing the first set of steps since the second always works).  So, it's not that I don't believe you, I just want to make sure that it wasn't a fluke that it didn't work. Would you try the second set of steps one more time?

    2) Type: net stop slsvc  (it may ask you if you are sure, select yes)
    3) Type: cd %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareLicensing
    4) Type: rename tokens.dat tokens.car  <--Note changed this steps to avoid having 2 tokens.bar files
    5) Type: cd %windir%\system32
    6) Type: net start slsvc
    7) Type: cscript slmgr.vbs -rilc (It may take a long time for this to complete, please be patient)
    8) Reboot Twice
    9) You may be required to enter the Product Key (from the sticker on the side or bottom of the computer) and then Activate by Phone

    Thanks for your help confirming this,
    Darin MS
    • Proposed as answer by Darin Smith MS Friday, August 28, 2009 6:22 PM
    Friday, August 28, 2009 6:22 PM
  • Thanks again for your help, Darin, but still no luck. I did do all the steps the first time but I still followed them exactly again this time just to be on the safe side but it doesn't appear to be a fluke. It shows the following when I type in the last step:

    Re-installing licence files...
    License file C:\Windows\System32\licensing\channels\OCUR\Security-Licensing-SLC-Component-SKU-OCUR-pl.xrm-ms installed successfully.

    License file C:\Windows\System32\licensing\channels\OCUR\Security-Licensing-SLC-Component-SKU-OCUR-ul-oob.xrm-ms  installed successfully.

    License file C:\Windows\System32\licensing\channels\OCUR\Security-Licensing-SLC-Component-SKU-OCUR-ul-phn.xrm-ms  installed successfully.

    License file C:\Windows\System32\licensing\identity\rac-generic-private.xrm-ms installed successfully.

    License file C:\Windows\System32\licensing\identity\rac-generic-public.xrm-ms installed successfully.

    Run 'slui.exe 0x2a 0xC004F01F' to display the error text.
    Error: 0xC004F01F
    Friday, August 28, 2009 10:24 PM
  • So, is there any possible solution to my problem? It just seems very queer and it's already been three weeks. I'd like to have full functionality back.
    Tuesday, September 1, 2009 10:12 AM
  • Hello fortunArcanum,

      If you are still experiencing issues, I recommend creating a WGA service request at http://go.microsoft.com/fwlink/?linkid=52029

    Darin MS
    • Marked as answer by Darin Smith MS Wednesday, September 9, 2009 9:54 PM
    Wednesday, September 9, 2009 9:54 PM