locked
Verifying port forwarding for your router failed RRS feed

  • Question

  • I get this error pretty much at least once a day. It's easy enough to fix, go into console setting, unconfigure router, wait until that's done then click set up router and it fixes it until the next time it happens.

     

    Isn't the point of a server to be reliable and always there? If it keeps getting the same error that takes remote access out with it it is pretty useless.

     

    What causes this?

    Sunday, February 17, 2008 7:30 PM

Answers

  • You can learn how to manually forward ports on your specific router by going to portforward.com and looking your router up. As for routers and UPnP, that support changes from router to router, and even from one revision of a router's firmware to another. So I don't think anyone should really rely on it working right in the long term.
    Wednesday, July 2, 2008 11:40 AM
    Moderator

All replies

  • If I had to guess I would say the problem is actually with your router and not with WHS.


    Which router are you using and are you running the latest firmware on it?

     

    Andrew

     

    Sunday, February 17, 2008 7:38 PM
    Moderator
  • WRT54GL with DD-WRT v23 sp2. It's been rock solid for everything else

     

    Sunday, February 17, 2008 7:57 PM
  • I get the same problem with a LinkSys WRT54G V8.

     

    I realize that WHS is based on Windows Business Server, and NOT Vista;

    but, I suspect that WHS may use some of the new advanced networking features

    and scenarios supported in Windows Vista.

     

    I ran a Windows utility recommended by the WHS Help system

    ( http://go.microsoft.com/fwlink/?LinkID=87241 ) ==> ( IGDTool 1.3.5 ).

    The tool says that my router has all the functionality required to

    support new advanced networking features and scenarios in Windows Vista;

    however, my router does NOT appear in the list of Vista Certified devices.

    I suspect that I will have to purchase a router with more up to date features.

     

    FYI - When I get the problem ...

    I just Reset my router, by pressing the Reset button on the back of the router.

     

    Saturday, March 1, 2008 9:18 PM
  • I get the same error with my WRT54GS also.  But then again this WHS system has many more issues than that.  Like continued corrupt files.

     

    Saturday, March 1, 2008 11:24 PM
  • I get the same error with my Linksys 330N.  Whevever the server tries to check the windows domain it stops all traffic through my router until I unplug it and plug it in.  Then everything is fine. 

     

    I have tried everything I can think of, including turning off the automatic router settings in WHS, and turning off uPNP in the router, and it still does it. I had to teach everyone in my house how to turn the router off and back on again in case I can't be home to do it.

    Thursday, March 6, 2008 4:47 PM
  • I put my router and cable modem on their own power strip and when somebody thinks "the internet is down" in my house.  I tell them to turn off the power to the power switch, go to the bathroom and then come turn it back on ...

     

    It has worked 5 times in a row ...

     

    Friday, March 7, 2008 2:02 AM
  • still getting same error, even bought a new router thinking it might be that. Same once a day verifying port forwarding to your router failed error with a d-link DIR-615 as with the old linksys.

     

    WHS remote access = unreliable to the point of uselessness

    Sunday, June 29, 2008 8:34 PM
  •  EncoreCestMoi wrote:
    still getting same error, even bought a new router thinking it might be that. Same once a day verifying port forwarding to your router failed error with a d-link DIR-615 as with the old linksys.

     

    WHS remote access = unreliable to the point of uselessness

     

    I've had WHS (including Remote Access) up and running literally 24/7 since last September.  I have yet to have a single issue with Remote Access (or anything else for that matter).  Any chance it could be your server NIC?  Network cable?  ISP doing something funky on their end?

    Sunday, June 29, 2008 9:32 PM
    Moderator
  •  

    I get the same problem with my LinkSys WRT54G as well...
    Sunday, June 29, 2008 10:10 PM
  •  DudeRick wrote:
    I get the same problem with my LinkSys WRT54G as well...

     

    That's the same router I have and it works fine.  Did you try to use the uPnP set up for WHS?  If so, that could be your problem.  (I configured my router manually.)

    Monday, June 30, 2008 12:57 AM
    Moderator
  •  

    I have a LinkSys WRT54G and have the same issue, repeated any time the server must reboot, which is not very often, but, if the power goes out, I have to redo my remote access, to get it back up and running

     

    Any suggestions?

     

    MR

    Monday, June 30, 2008 3:48 AM
  • I was getting the same error occassionally and what I did was assign a static IP to the server.  This can be done two different ways.  One is to remote desktop into the server and set it up.  I don't have the exact procedures with me at this time because I am at work, but I read about this method in the "WHS For Dummies" book.  The second way of which I used and is the easiest way is to (if your router has this feature) reserve an IP address for the server within the router's setup.  That way the router will always assign the same IP address to the server.  I've used the second method for several items on my network to include my Slingbox, Media Player, Network Printer, and Primary Client PC.

     

    I hope this helps,

     

    SilkRod

    Monday, June 30, 2008 6:04 AM
  •  

    I have had a static IP since day one, it does not resolve this issue

     

    My issue is easy to duplicate, just unplug the router, plug it back in, Network Health warning follows

    Tuesday, July 1, 2008 1:33 AM
  • On another WHS forum, there was a related posting, it seems the cause was not determined, but the fix was Tomato.
    Sorry, but I did notice this had not been attempted, and dd-wrt had without success.

    Ben
    Tuesday, July 1, 2008 3:11 PM
  •  kariya21 wrote:

     DudeRick wrote:
    I get the same problem with my LinkSys WRT54G as well...

     

    That's the same router I have and it works fine.  Did you try to use the uPnP set up for WHS?  If so, that could be your problem.  (I configured my router manually.)

     

    Yes...

    I reconfigured mine manually and loaded the latest filmware into the router and so far so good... :~

    Tuesday, July 1, 2008 11:51 PM
  •  

    Could you post a screen shot or some directions on what the successful set up looks like in the router set up page, I think I have mine right, but, does not "stay" set up, just keep getting the error

     

    Interestingly, since I posted here, my server has now decided the WRT54GL no longer supports UPnP, giving that message in the details page

     

    This is after having set it up automatically via UPnP dozens of times............who knows (?)

    Wednesday, July 2, 2008 1:02 AM
  • You can learn how to manually forward ports on your specific router by going to portforward.com and looking your router up. As for routers and UPnP, that support changes from router to router, and even from one revision of a router's firmware to another. So I don't think anyone should really rely on it working right in the long term.
    Wednesday, July 2, 2008 11:40 AM
    Moderator
  • I get the same error - however it's only the verification that fails, the actual forwarding is working fine.  My router does not support uPnP, and even if it did, I would disable for security reasons.  I manually set up my router and it works perfectly.  The error message is a continuing annoyance.  I select "ignore this issue" in the Home Network Health window, and that does turn the status green for a while, but the error returns.  Is there some way to tell WHS to permanently ignore the issue?

     

    Saturday, July 19, 2008 2:43 PM
  • Hi all,

    just wanted to chime in....i had the same problem, every week or so my whs would lose it's connection to everything...including the network...a $10.00 network card with server 2003 drivers has sloved the problem for well over a month now...happy home serving

    Gene

    Sunday, July 20, 2008 3:36 AM
  • ABruceC, did you initially configure your router and server to use UPnP, then turn it off later? You should be able to turn off automatic configuration of your router:
    • Open the Windows Home Server console.
    • Click on the Settings button.
    • Click on Remote Access.
    • Click on Setup... in the router section.
    • Click on the Configure Router... button.
    • Log in to your router's configuration tool and make sure that manual port forwarding is correctly configured.
    • Click Close, then Details...
    At this point, your router should be shown in the console as "Manually configured".
    Sunday, July 20, 2008 2:06 PM
    Moderator
  •  

    No, I never did try to configure with UPnP because my router doesn't support it, nonetheless, even though I did manually configure my router, the console didn't show me as "Manually configured."  I just now unconfigured and reconfigured and now it does show manually configured.  Perhaps when I configured the router the first time, I didn't completely do the configuration while in the server console.  When I used to check details before, it would test and I would occasionally get 4 green check marks (the UPnP wouldn't be green) but not always.  Now when I check details, it doesn't attempt to test like it always would before, rather it immedately shows 4 green checks and manually configured.  I suspect this is going to fix the problem.  Thanks for your help!
    Wednesday, July 23, 2008 11:17 AM
  • "I get the same problem with my LinkSys WRT54G as well... "

     

     I had so many problems with my Linksys WRT54G including not being able to make it function remotely with WHS that I gave up on it and threw it in the garbage. I bought the Actiontec router instead (Qwest Reccomended). If you do some googling you'll find out that many folks have experienced many different problems with the series of WRT54 routers. I don't know if the folks caused their own problems or if it was actually the router...  You could also be sure your firmware is up to date... some earlier firmware versions were a bit on the buggy side... Have been VERY happy with the Actiontec and so has WHS.

     

    Mark

     

    Wednesday, July 23, 2008 2:00 PM
  • I started getting the same error after updating to PowerPack 1, but it is false, I can access the system remotely without any problems. Sometimes the red X changes to a question mark then back to a red X, but as long as everything is working I am going to ignore it.
    Wednesday, July 23, 2008 4:44 PM
  • Similar problem here. I have a D-link DSL-G604T, UPnP is enabled and remote access works fine. WHS can't verify it, but I think that's because it doesn't support NAT Loopback and thus gets confused attempting to check itself. What is annoying however is I still keep getting the "Updating port forwarding for your router" warning from WHS and can't find a way to permanently tell it to stay quiet.

     

    Anyone got any ideas?

    Wednesday, July 23, 2008 8:21 PM
  • Yes, alot of people have found the advanced controls of DD-WRT or Tomato have been of great help. You will have to install these systems on your router, they are free.

    Ben
    Wednesday, July 23, 2008 9:37 PM
  • I've suddenly started getting this problem too since upgrading to PowerPack 1. I have a Belkin N Wireless Router and the "Verifying port forwarding failed" message appears at least every other day. But when I check the "Remote Access" settings the router status is "Working" with green check marks on every option!!

    I use the auto configuration with UPnP so maybe manual selection is the answer here?

    Saturday, September 20, 2008 9:00 AM
  • I'd recommend forgetting uPNP and just controlling the port forwarding/firewall manually. My Netgear DG 834G has been fine since I did that.
    Saturday, September 20, 2008 1:17 PM
  •  Hi Spile1,

    I have a Netgear DG834G too and am having the same problems.

    Would it be possible for you to guide me - step-by-step- to do the manual configuration. Everytime I do it the port forwarding definitely fails. Maybe I am doing something wrong.

    Any help will be appreciated

    Thanks in advance.

    vinsup

    Monday, November 17, 2008 10:13 AM
  • Try PortForward.com and start here for your router. None of the guides are specific to WHS but they all show you how to forward a port on your router.
    I'm not on the WHS team, I just post a lot. :)
    Monday, November 17, 2008 1:03 PM
    Moderator
  • Thanks. Will try it out. Hope it works.

    Cheers,

    Vin
    Monday, November 17, 2008 6:44 PM
  • Just want to add that im using a Linksys WRT54GL v1.1 with dd-wrt v.24 sp1 and it works perfectly and flawlessly with my server. Its very stable. It shows green lights in all, but not the two last, so it cant verify itself. Anyway, it gives no verbose warning in the console, and the remote access works very well from outside the network.  

    What i did, i set up manual port forwarding in the router, 4 ports, http (80), https (443), Remote Web Workplace (4125) and Remote Desktop Protocol (3389) to the server, which is on a static ip adress. In addition i enabled the upnp feature in the router. The server is very happy with this setup, and gives no warnings, and is reliable and accessible from any location, locally and remotely. 


    Lars
    Tuesday, November 18, 2008 2:11 AM
  • Thanks.

    I tried as you guys suggested.

    Initially the WHS refused to acknowledge the manual forwarding.

    Then I placed the WHS in DMZ and everything worked brilliantly.

    Now here's to hpoing that it keeps on working.

    Once again thanks a lot.
    Tuesday, November 18, 2008 3:22 PM
  • You should sort out the port forwarding so you can take your server out of your router's DMZ. The DMZ exposes a computer to the network with no protection other than whatever's installed on it. Your router uses Network Address translation to mask your home computers from the Internet, and has a firewall built in to protect against unexpected requests on odd ports (which are often malefactors probing for vulnerable systems).
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, November 18, 2008 3:25 PM
    Moderator
  • DMZ as represented in home consumer routers, should only be used temporarily, just to confirm if it is the router stopping the server or not. 

    To stay protected, you need to figure out how to set up port forwarding correctly. It should be the 4 ports i mentioned in my previous post, and to make things easier, set the server on a static IP adress.. i. e. if ur DHCP starts handing out IP's from 192.168.1.100, RDP into the server and set the network configuration to use 192.168.1.50, in that way it would not make a conflict with the DHCP. Or, if your router supports it, reserve the current DHCP IP to your server, it usually is a button for it in the client list in the router. Not all routers supports this feature though.


    Lars
    Tuesday, November 18, 2008 7:37 PM
  • Lars, one thing: there is no need to forward port 3389 to your server (it's not one of the ports that your server needs to function correctly), and it's probably not a good idea, unless you have an excellent reason.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, November 18, 2008 7:51 PM
    Moderator
  • Its not needed for functionality, but i use it to be able to RDP into my server from a remote location. I have a strong password, and havent caused any problems yet. There has been situations where this has been very helpful. Anyway, that might be in my particular use of the server, and might not be applicable to everyone. 

    Lars
    Tuesday, November 18, 2008 7:56 PM
  • Hi Ken and Lars,

    I have been reading through this thread and other posts at various forums and cannot work out what the ultimate solution to my problem with port forwarding is.

    I am using the WRT54GL ver1.1, have setup a static IP address on my home server, manually configured port forwarding on the router, have UPnP disabled but remote access will not work.

    I am hesitant about upgrading the firmware to a non-Linksys version like you have Lars (the dd-wrt). But it is possibly one last step before I throw the router out and replace it by one that's known to work well.

    What are the risks of replacing the current Linksys firmware (v4.30.7) with a non-Linksys firmware like dd-wrt?

    Best regards,

    Bart

    Tuesday, November 18, 2008 8:17 PM
  • First of all, i think the current firmware, atleast in europe is at v4.30.11, small update from the 4.30.7.. 

    None the less, the dd-wrt adds alot of great features to this router, and there is little risks in doing this, as the WRT54GL v1.1 is a well known router to flash dd-wrt on to. The way to do it, is to download the mini generic image and flash it on to the router, and then follow up with an upgrade to the std generic image, this is because the original linksys firmware has a limit on the firmware file to be flashed.

    I was hesitant on doing this myself, and i read alot on the forums at dd-wrt and also their wiki about how to rescue your router if you manage to brick it, and decided to give it a try. I really dont regret this. The flashing process itself doesnt have more risks then flashing a original linksys firmware. 

    Of course, you need to have some knowledge about doing these kind of things. I could try to help more closely if you would like.


    Lars
    Tuesday, November 18, 2008 9:36 PM
  • Thanks Lars for your prompt reply and the offer for your support. It is reassuring. I was reading through their extensive wiki and I think I will give it a try. It's a bit of a stretch for a non-techie like me, but I think I can manage. I'll let you know!

    Tuesday, November 18, 2008 9:48 PM
  • Skauber said:

    Its not needed for functionality, but i use it to be able to RDP into my server from a remote location. I have a strong password, and havent caused any problems yet. There has been situations where this has been very helpful. Anyway, that might be in my particular use of the server, and might not be applicable to everyone. 


    Lars




    Or you could just modify the rdpload.aspx file (which is unsupported, but it does work) to show you the server desktop instead of the Console in the Remote Access website... ;)
    Wednesday, November 19, 2008 6:33 AM
    Moderator
  • BB68 said:

    Thanks Lars for your prompt reply and the offer for your support. It is reassuring. I was reading through their extensive wiki and I think I will give it a try. It's a bit of a stretch for a non-techie like me, but I think I can manage. I'll let you know!


    Did you just forget to post back how the flashing went, or did you just brick your router? hehe.. Got a bit worried that you might have bricked your router.. :)


    Lars
    Thursday, November 20, 2008 6:12 PM
  •  

    I was having the same problem and could not get my website and remote access set up on the home server. I have fios and messed with the router for hours trying to get the the domain and router configured from the home server, kept getting the error that port forwarding was not enabled, even though it was and I did it manually as well. I finally broke down and started RDP session to my server and checked out the windows firewall advanced local area connection settings. I noticed that allow http & https were not checked off. Checked the boxes, then ran the configure my router from the home server console and TADA all is well.

    Hope this helps!

    Wednesday, December 3, 2008 5:00 AM
  • Here's my story... it may likely sound familiar to most of you...

     My primary router was the Linksys WRT54G V3.0 running factory firmware version 4.20.7
     WHS was running great, no issues to report - remote connectivity from the interwebz to the home server network was configured manually and largely reliable. Except that every few weeks my overall internet connection would deterriorate to the point of unusability, requiring a reboot of the router. Which is actually a pretty popular problem with the Linkys, so I decided 'oh hey... new FW available... let's try upgrading'. Yeah.. NOT
     - The latest firmware version 4.21.1 - is evil, buggy, and ultimately bricked my router when trying to fix it by flashing to DDWRT. 
     Avoid the latest Linksys firmware at all costs!

    So, needing a new router I decided to get something a little nicer (and hopefully that wouldn't need rebooted every other week)

    Picked up the NetGear WNDR3300. Snazzy little router, great range, good factory interface. Fully uPNP supported and auto-configured by WHS like a dream.  Except that now, about once a week the taskbar icon flips out about server health, and WHS complains that port forwarding has failed.
    - sometimes it lies... and the connections appear to be fine, but if I leave it be and just ignore it... the connections will eventually fail.
    I suspect it stops trying to update the dynamic DNS service and when I try connecting remotely after my ISP's IP has changed I get squat.

    I thought it was maybe a bug with uPNP on the router, so I added the port forwarding routes manually. (my server runs a static IP). - Nope.. it still happens as before, even with uPNP disabled.

    Okay then.. I'll just have to go back to rebooting the router every week. Which... fixes the problem (for a week), but pisses the roommates off particularly when the router is working flawlessly for everything but my WHS remote connectivity. One roomie that has a NAS box which also leverages the uPNP has no issues. We haven't had the issues with this router degrading the internet connection like we did with the Linksys... so at this point there are no indications that the router is the major culprit here when so many others are having this same behavior with other brands of router.  (had my old linksys been stable enough to have decent uptime, I very well might have hit this same issue on that router as well).

    One guy earlier said he had good luck putting a new NIC in the machine. I kindof like that suggestion and will try that next. The on-board NIC in my shuttle is the Realtek RTL8139 Family. 

    However... in my troubleshooting, I did notice something helpful. Rebooting the WHS box is just as effective at clearing up the issue as rebooting the router... (that will make the roommates happy!)  I just discovered this, so before I add the new NIC I'm going to try running a REPAIR operation on the network connection inside of WHS (the next time it happens) to see if that will work.  Meanwhile, I have the suggestion to create a scheduled task on WHS to reboot the server every few days during a window when the downtime wont cause loss of service to users, or interfere with your scheduled backups.

    Moreover - I know the DDWRT firmware, which is available for most routers... has a neat little feature to do an automated scheduled reboot of the router, for those that feel better about hammering the router instead of the server. I'll post back in a couple weeks to report on my findings with the NIC REPAIR operation and\or using a new NIC.
    -It would be helpful if folks could start posting what brand of NIC they are using on their WHS servers, to see if there is any common ground. (Intel vs Broadcom, etc).

    Cheers!
    Greg

    • Proposed as answer by Gregory3 Saturday, January 24, 2009 11:55 AM
    Saturday, January 24, 2009 11:52 AM
  • I just bought HP medismart home server and I have Linksywrtgs router which has beein giving me problems for remote access. Did you find any solution

    Appreciate your help
    Monday, May 4, 2009 1:52 AM
  • I just bought HP medismart home server and I have Linksywrtgs router which has beein giving me problems for remote access. Did you find any solution

    Appreciate your help

    It would be better if you started your own thread and provided as many details as possible.
    Monday, May 4, 2009 5:01 AM
    Moderator
  • (this is Gregory3) - Running the REPAIR operation worked great; for a while... until it cropped up again. Ultimately I replaced the NIC with a Broadcom NetExtreme 57xx and it seems to be quite happy.  I tried updating the drivers on my old 3COM; but there wasn't a more current driver available than the one I had installed. - when in doubt, try another NIC.

    Cheers!
    Greg

    Tuesday, June 23, 2009 7:13 AM
  • So, one question still remains that I have not been able to find the answer for: When the "unable to configure port forwarding" warning appears in the network health page, there is an option to "ignore this issue". Checking it *should* mean that WHS stops popping up warnings. But, it doesn't seem to work. It keeps popping up with that error over and over again.

    Anyone have any ideas why this is occurring?

    Of course, there is still the underlying problem of WHY WHS is reporting it as an error when everything is working correctly, but if it would just ignore the problem, I wouldn't care, either!
    Tuesday, December 8, 2009 12:25 AM
  • Any ideas on why the "ignore this issue" doesn't work?
    Tuesday, February 9, 2010 3:17 AM
  • Any ideas on why the "ignore this issue" doesn't work?

    I have the exact same problem - just upgraded to a fancy Netgear WNDR3700 and get frequent "Updating port forwarding..." warnings. I did try clicking on the ignore this issue, but it keeps coming back.

    I have also noticed that after a while the taskbar icon goes back from yellow (with the warning) to green a little later...

    This has "firmware" written all over it.
    Wednesday, February 17, 2010 1:02 AM
  • I know I am bumping a old thread but I am having this problem but I have two WHS on a single router and only one keeps dropping connection because of this.  Wouldn't the same thing apply to both servers?
    Tuesday, January 11, 2011 7:05 AM
  • I was messing around with suppressing the port forwarding error for the gazillionth time and it finally caught.

    What I found was a registry entry that was created in

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Home Server\Notification\1.0\Suppressions

    with the name "PortForwarding".

    Here is the export of the node.  I edited out some machine backup warnings that I have being suppressed.

    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Home Server\Notification\1.0\Suppressions]
    "PortForwarding"=""
    

    Hope this helps someone.

    Metro.

    Friday, June 22, 2012 3:59 AM