locked
CRM for Outlook installation problem RRS feed

  • Question

  • Hi All,

    I have been trying to install CRM 4.0 for Microsoft Outlook. On the copying files stage of the installation it seems about to finish, then it pauses for some time and then starts a 'Rolling Back Action' and then it tells me that the installation was incomplete because there was an error during install.
     
    Does anyone know why it is doing this? Any information will be appreciated.

    Matthew Hart
    Thursday, March 11, 2010 11:40 AM

All replies

  • Did you look at the installation log files?

    You can find them 
    • Windows XP: SystemDrive:\Documents and Settings\<User>\Application Data\Microsoft\MSCRM\Logs\
    • Windows Vista: SystemDrive:\Users\<User>\AppData\Roaming\Microsoft\MSCRM\Logs\

    My blog : http://mscrmtools.blogspot.com
    You will find:
    Bulk Delete Launcher(Delete data based on advanced find queries)
    Form Javascript Manager (export/import javascript from forms)
    ISV.Config Manager (graphical ISV.config edition - export/import)
    View Layout replicator (customize one view and replicate to others)
    And others (use tool tag on my blog)
    Thursday, March 11, 2010 12:39 PM
    Moderator
  • These are the logs for the installation. Any explanation on what to do from here would be a great help.


     9: 4:30|    Info| =================CrmForOutlookInstaller starting==================
     9: 4:30|    Info| InstallOptions Parsed
     9: 4:30|    Info| InstallAbp=0
     9: 4:30|    Info| InstallPst=0
     9: 4:30|    Info| UninstallAbp=1
     9: 4:30|    Info| UninstallPst=1
     9: 4:30|    Info| UpgradeItems=0
     9: 4:30|    Info| UpgradeAbp=0
     9: 4:30|    Info| UpgradePst=0
     9: 4:30|    Info| LogFile=.\Crm40ForOutlookInstaller.log
     9: 4:30|    Info| Progress event not found
     9: 4:30|    Info| Entering DoInstallPst
     9: 4:30|    Info| DoInstallPst called with installPst = 0
     9: 4:30|    Info| Entering GetMapiSession
     9: 4:30|    Info| Exiting GetMapiSession
     9: 4:30|    Info| Entering GetServiceMuid
     9: 4:30|    Info| Msg Service not found
     9: 4:30|    Info| Exiting GetServiceMuid
     9: 4:30|    Info| Entering GetServiceMuid
     9: 4:30|    Info| Msg Service not found
     9: 4:30|    Info| Exiting GetServiceMuid
     9: 4:30|    Info| Exiting DoInstallPst
     9: 4:30|    Info| DoInstallAbp called with installAbp=0
     9: 4:30|    Info| Entering DeleteAbp
     9: 4:30|    Info| Entering GetMapiSession
     9: 4:30|    Info| Exiting GetMapiSession
     9: 4:30|    Info| Entering ModifySearchPath
     9: 4:32|    Info| Entering AddNewRow
     9: 4:32|    Info| Exiting AddNewRow
     9: 4:32|    Info| Entering AddNewRow
     9: 4:32|    Info| Exiting AddNewRow
     9: 4:32|    Info| Exiting ModifySearchPath
     9: 4:32|    Info| Entering RegisterProvider
     9: 4:32|    Info| Entering GetServiceMuid
     9: 4:32|    Info| Msg Service not found
     9: 4:32|    Info| Exiting GetServiceMuid
     9: 4:32|    Info| Exiting RegisterProvider
     9: 4:32|    Info| Exiting DeleteAbp
     9: 4:32|    Info| =================CrmForOutlookInstaller finished==================

    Matthew Hart
    Friday, March 12, 2010 8:46 AM
  • Hello, here's another CRM Forum post with a similar issue that was resolved:
    http://social.microsoft.com/Forums/en/crmdeployment/thread/2cfd49e2-0c49-4830-9d2c-e48d4ccfb74e

    Hope this helps.

    Neil
    Friday, March 12, 2010 10:21 AM
    Moderator
  • Hello, I have tried the solutions given on the other link but still nothing seems to be keeping the installation from rolling back. Believe I put up the incorrect logs so here is the right one with just the errors because of the size. Any help appeciated. Many thanks.

    Matthew Hart

    09:33:37|  Error| Error attempting to retrieve parameters from patch file C:\DOCUME~1\Matthew\LOCALS~1\Temp\MSCRM_{04C50D36-70AA-4018-B12A-185E3C0CA57A}\Client.msp:  1636

    09:33:37|  Error| %s failed.(error = 1636) (msiutility.cpp:CMsiUtility::ExtractPatchXMLData:469).

    09:33:37|  Error| The update file is not valid for installation of this application.

    09:33:55|  Error| Error launching MSI Installer

    09:48:09|  Error| Failed to find the job for the file Client.msp. Error : 0x80200001.

    And also a host of warnings. A small example:

    09:49:24|Warning| CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}
    09:49:24|   Info| Software\Classes\CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}

    09:49:24|Warning| CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\Implemented Categories\{62C8FE65-4EBB-45e7-B440-6E39B2CDBF29}
    09:49:24|   Info| Software\Classes\CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\Implemented Categories\{62C8FE65-4EBB-45e7-B440-6E39B2CDBF29}

    09:49:24|Warning| CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32
    09:49:24|   Info| Software\Classes\CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32

    09:49:24|Warning| CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32
    09:49:24|   Info| Software\Classes\CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32

    09:49:24|Warning| CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32
    09:49:24|   Info| Software\Classes\CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32

    09:49:24|Warning| CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32
    09:49:24|   Info| Software\Classes\CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32

    09:49:25|Warning| CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32
    09:49:25|   Info| Software\Classes\CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32

    09:49:25|Warning| CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32
    09:49:25|   Info| Software\Classes\CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32

    09:49:25|Warning| CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32\3.0.5300.0
    09:49:25|   Info| Software\Classes\CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32\3.0.5300.0

    09:49:25|Warning| CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32\3.0.5300.0
    09:49:25|   Info| Software\Classes\CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32\3.0.5300.0

    09:49:25|Warning| CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32\3.0.5300.0
    09:49:25|   Info| Software\Classes\CLSID\{04200B27-8C49-40DC-BD6A-C7677E6D2055}\InprocServer32\3.0.5300.0

    10:44:05|  Error| Error 1603 reported by MsiInstallProduct

    10:44:05|  Error| Setup cannot proceed because an error occured while copying installer files to the local system: Fatal error during installation.   (clientsetup.cpp:CCrmClientSetup::CopyInstallerFiles:691).

    10:45:29|  Error| Setup cannot proceed because an error occured while copying installer files to the local system: Fatal error during installation.  , Error, OK

    Tuesday, March 16, 2010 9:23 AM
  • Ensure that the download file you are using is not corrupt.  I suggest you go out and download the latest version.  Also ensure you have full rights on the workstation and that you are using the correct file for your workstation OS.
    Best Regards | Twitter: edwardsdna
    Thursday, March 18, 2010 8:39 PM
  • Did you ever get this fixed Matthew? I'm getting some similar errors ...

    Thanks,

    Andy


    Web: http://invoc.net Blog: http://invoc.net/CRM_BPOS_Blog
    Tuesday, June 15, 2010 8:03 PM
  • I had to delete all of the registry keys (I even found some called ~MSCRM - not sure if that squiggly was added by a previous resource, or what).

    The main problem was that the laptop I was installing on had one foot in the grave.


    Web: http://invoc.net Blog: http://invoc.net/CRM_BPOS_Blog
    Friday, June 18, 2010 7:11 PM
  • Hi,

    There could be an issue with system registry. Clean up your registry and try installing again.

    If you're installing on Office Outlook 2010, have a look at this

    http://community.dynamics.com/blogs/crmfranklee/archive/2010/05/10/microsoft-office-2010-and-microsoft-dynamics-crm.aspx

    Hope it helps!


    Best Regards,
    Gagandeep Singh
    http://mscrmnovice.blogspot.com
    Friday, June 18, 2010 9:51 PM
  • what OS
    Friday, June 25, 2010 3:38 AM