locked
HP Proliant Microserver And Bare Metal Restore Backup Issues RRS feed

  • Question

  • I've been having some issues recently with my N40L Microserver following a couple of bad sectors being found on the boot drive.

     

    After running check disk and having that mark the bad sectors out of action, I was finally able to use the Windows Server Backup tool in WHS 2011 to create a bare metal restore image and save it to a second physical drive in the box, around 40GB. 

     

    I don't have a DVD drive in the server so I made an ISO of the DVD Install disc, and then put that on to a bootable USB stick with the Windows USB / DVD tool from MS. I removed the damaged drive and put in a new blank drive that is twice the size of the damaged one. When I boot the installer dvd on the USB stick, it gets in to the initial screen where it asks you if you want to install a new copy or repair an installation. When I select repair, instantly I receive the error message

    "An internal error occurred.  The following information might help you resolve the error: 

    The system cannot find the specified file. (0x80070002)


    I get no options other than pressing the OK button and it then reboots the server. I remember having issues originally installing it from a USB drive and trying to install on an 80GB SSD - I gave up after a few hours and went with a 60GB HD partition. The install runs now if I select a new installation, it's just the repair option I can't launch. 

     

    I double checked the USB stick was fine by creating a new VM on my Mac, and I was able to boot that from USB and select Repair without any problem. I could browse to the network share that contains the BMR image (after replacing the dodgy boot drive back in to get back to windows) and I was able to restore the image successfully. So it seems to me there are issues with the hardware I am running and setup for WHS. It's the HP Proliant Microserver N40L @ 1.5GHz with 8GB RAM, no other changes to the standard box. 

     

    Any ideas how to get Repair working? 

     

    I managed to clone the dodgy boot drive in the end with clonezilla and so far it's working perfectly with the new drive. It would be good to know I have a proper system backup of the boot drive with a bare metal restore option in the future but until I can get Repair working on the installer dvd this isn't an option. Any suggestions greatly appreciated! 

    Sunday, May 10, 2015 9:50 AM

All replies

  • Hi,

    According to your description, my understanding is that repair installation prompts error message "The system cannot find the specified file. (0x80070002).” This USB stick which is used to reparation can work properly(new and repair installation) on other device.

    In general, error 0x80070002 may be caused by denied access, missing/corrupted files.

    Locate the backup folder, make sure that the SYSTEM account has read permissions for all the backup folder's subfolders:
    Properties – Security. 

    Besides, confirm that your backup folders has the correct file structure.

    Best Regards,
    Eve Wang 

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, May 12, 2015 6:38 AM
  • Thanks Eve. I have checked the permissions on the drive and folder that contains the BMR image of my WHS 2011 box and it all checks out. This is further confirmed to me when I am able to use the VM I created on my mac to browse over the network to the very same folder and start the restore process of the image  on to the virtual machine. 

    The issue is that as soon as the Repair installation button is clicked on setup running on the HP hardware, it fails instantly. No questions about locating the image to use or whether to use the DVD installer to repair - it just throws the error message shown. 

    Is it due to the fact that it's running on a USB stick (the installer) ? I ran it via USB when using the virtual machine to test and it worked fine, but maybe the hardware on the HP server doesn't cope as well. I have tried to download the latest BIOS from HP but you seem to need an active support agreement to get at the download. 

    Wednesday, May 13, 2015 12:00 PM