Problems with configuring a RDP-Connection outside the Website RRS feed

  • Question

  • Hi!

    Normally my RDP-Connection from the website starts the Vail-Dashboard without a problem. At the moment the website reports an error and is unavailable and I'm not at home for a reboot so I tried to establish a connection via RDP-client. I added the TS-Gateway adress and the Logon-Credentials, but when I try to connect I always get an error, that the authentification method required is different from the one I attempted.

    RDP-client is from XPSP3 in version 6.1.7600, Info states that Authentification via NTLM is available and also RDP-protocoll 7.0.

    I've tried several configurations and submitted the credentials with Servername\Username or IP\Username or just Username.

    Can anyone help me out? The server is running an the router is reachable, the error page from the website is generated by vail.

    Wednesday, September 8, 2010 10:53 AM

All replies

  • Hi,
    the default setting on the Remote tab of Windows Server 2008 is to allow connections only from computers running Remote Desktop with Network Level Authentication.

    This is not supported by Windows XP, therefore your connection fails. You would have to reconfigure this setting on the server to allow connections from computers running any version of Remote Desktop or to use Vista/Win7.

    Or try, if this method works on your XP client to enable NLA support:

    1. Click Start/Run, type regedit, and then press ENTER.
    2. In the navigation pane, locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. In the details pane, right-click Security Packages, and then click Modify.
    4. In the Value data box, type tspkg. Leave any data that is specific to other SSPs, and then click OK.
    5. In the navigation pane, locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders
    6. In the details pane, right-click SecurityProviders, and then click Modify.
    7. In the Value data box, type credssp.dll. Leave any data that is specific to other SSPs, and then click OK.
    8. Exit Registry Editor.
    9. Restart the computer.

    Best greetings from Germany

    Wednesday, September 8, 2010 11:17 AM
  • Hi Olaf!


    Thanks for your answer.
    I've already made these steps, but they didn't solve the problem. My RDP-Client states in the info tab: "Authentifizierung auf Netzwerkebene wird unterstützt."

    Also I tried to connect from a vail-installation in a VM, there should be everything set up as needed.


    Wednesday, September 8, 2010 11:47 AM
  • Well could also be the Windows Firewall settings on the Vail server, blocking incoming connections from other than the local network. (Already powered down my Vail machine for the day - its after midnight here - so cannot check the settings now.) Although the message points not to the Firewall.

    Best greetings from Germany

    Wednesday, September 8, 2010 10:09 PM
  • Hi!

    I'm still trying to establish a RDP-connection to my vail server without luck. Is anyone able to establish a RDP-connection from the RDP-Client via TS-Gateway and not from the remote-website? From the website there is no problem opening the dashboard and via the RemoteLauncher-addin from awieco I can start the local RDP-client from vail an establish a connection. But from my XPSP3 I can't. As statet above, NTLM is enabled. Any suggestions? Anyone else got this problem?

    Thursday, October 28, 2010 6:24 AM
  • Apparently we're the only two people in the WHOLE world who want this functionality :-)

    Did you ever figure this out?  I've got a client wanting to access his desktop on his iPad.  We've got an RDP app that supports TS Gateway (tested and works fine with SBS Essentials, SBS Standard, and real Windows 2008 R2).  He will not be buying any of the previously mentioned systems, instead, I've either got to get RDP to work or go with a VPN first, then RDP with no gateway.

    Tuesday, May 3, 2011 2:48 AM