none
:( Oops. 500 Internal Server Error - An error occurred while starting the application. RRS feed

  • Question

  • I have created .net core web <g class="gr_ gr_266 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="266" id="266">api</g> application. When I start my .net core application I'm getting ":( Oops. 500 Internal Server Error - An error occurred while starting the application." error on the web page. Previously it's working fine but when I added "net462" into the project.<g class="gr_ gr_170 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="170" id="170">json</g> file it's occurred. Could you please let me know if anyone knows this issue?

    Project.json

    {
      "dependencies": {
        //"Microsoft.NETCore.App": {
        //  "version": "1.0.1",
        //  "type": "platform"
        //},
        "Microsoft.AspNetCore.Mvc": "1.0.1",
        "Microsoft.AspNetCore.Routing": "1.0.1",
        "Microsoft.AspNetCore.Server.IISIntegration": "1.0.0",
        "Microsoft.AspNetCore.Server.Kestrel": "1.0.1",
        "Microsoft.Extensions.Configuration.EnvironmentVariables": "1.0.0",
        "Microsoft.Extensions.Configuration.FileExtensions": "1.0.0",
        "Microsoft.Extensions.Configuration.Json": "1.0.0",
        "Microsoft.Extensions.Logging": "1.0.0",
        "Microsoft.Extensions.Logging.Console": "1.0.0",
        "Microsoft.Extensions.Logging.Debug": "1.0.0",
        "Microsoft.Extensions.Options.ConfigurationExtensions": "1.0.0",
        "IdentityModel": "2.0.0",
        "Microsoft.AspNetCore.Diagnostics": "1.0.0",
        "Microsoft.AspNetCore.Cors": "1.1.0",
        "Newtonsoft.Json": "9.0.1",
        "JsonWebTokens": "1.3.0",
        "jose-jwt": "2.1.0",
        "IdentityServer.DAL": "1.0.0-*",
        "Microsoft.AspNetCore.Mvc.WebApiCompatShim": "1.0.1",
        "System.IdentityModel.Tokens.Jwt": "5.1.3",
        "Microsoft.IdentityModel.Protocols": "2.1.0",
        "Microsoft.AspNetCore.Authentication.JwtBearer": "1.0.0",
        "BouncyCastle.NetCore": "1.8.1.2",
        "Sendgrid": "9.0.12",
        "RollbarDotNet": "0.5.1",
        "Microsoft.ApplicationInsights.AspNetCore": "1.0.2",
        "IDAM.Sync": "1.0.0-*",
        "Nse.ServiceBus.DataContracts": "1.8.0.350"
      },
    
      "tools": {
        "Microsoft.AspNetCore.Server.IISIntegration.Tools": "1.0.0-preview2-final"
      },
      "frameworks": {
        "net462": {}
      },
      //"frameworks": {
      //  "netcoreapp1.0": {
      //    "imports": [
      //      "dotnet5.6",
      //      "portable-net45+win8"
      //    ]
      //  }
      //},
    
      "buildOptions": {
        "emitEntryPoint": true,
        "preserveCompilationContext": true
      },
    
      "runtimeOptions": {
        "configProperties": {
          "System.GC.Server": true
        }
      },
    
      "publishOptions": {
        "include": [
          "wwwroot",
          "appsettings.json",
          "web.config",
          "nse.p12"
        ]
      },
    
      "scripts": {
        "postpublish": [ "dotnet publish-iis --publish-folder %publish:OutputPath% --framework %publish:FullTargetFramework%" ]
      }
    }
    

    Thanks,

    Parthiban


    Parthiban

    • Moved by CoolDadTx Wednesday, May 10, 2017 2:04 PM ASP.NET related
    Wednesday, May 10, 2017 3:04 AM

All replies

  • Hi Parthiban K,

    Sorry, I don't read whole of your code.
    But I suppose the error (internal server error 500) causes from browser, instead of your code/web page.

    Please refer to: How To Fix a 500 Internal Server Error
    https://www.lifewire.com/500-internal-server-error-explained-2622938

    It read:
    (1) reload web page (refresh browser by [F5])
    (2) clear browser's cache
    (3) delete browser's cookies
    and so on...
    ______________
    Ashidacchi
    Wednesday, May 10, 2017 3:39 AM
  • Please post questions related to web development in the ASP.NET forums.
    Wednesday, May 10, 2017 2:04 PM