locked
Dial-In Authentication Phone and PIN RRS feed

  • Question


  • Hi,

    I have a problem where a user cannot authenticate into a conference with their dialin extension and pin. It seems that the Line URI must be in the format of tel:nnnn and not have any other parameters on it. 

    I'm using RCC with Cisco Call Manager and need to provide the users telephone uri with the partition details etc.

    e.g.

    tel:nnnnn;phone-context=dialstring;partition=PT_Int

    Is there a way to provide this information and still get the dial-in authentication working?

    Regards

    Keith.
    Thursday, May 28, 2009 2:50 PM

All replies

  • Keith, I've been able to use the tel:+<Main Number>;ext=1234 format successfully for conferencing. Not sure if that would actually work with your CUCM integration, but it's worth a shot.
    Friday, May 29, 2009 8:58 PM
  • Hey,
    The coferencing service uses normalization rules to process the extension. so add a new location profile and you could try a rule like this:

    "$1;phone-context=dialstring;partition=PT_Int"

    that converts extensions into the full path of what you've defined in the line uri.

    you'd apply that to the conference service by using that location profile.

    hope that helps!


    regards,
    matt
    Matt McGillen, PointBridge - https://blogs.pointbridge.com/Blogs/mcgillen_matt/default.aspx
    Friday, May 29, 2009 9:42 PM
  • Having a similar issue. In this case we have both Enterprise voice users and RCC users. We defined a 4 digit normalization rule amoung others that allows 4 digit dialing between CUCM and OCS. RCC users recieve ""The phone number and PIN you have entered do not match".  Found

    http://support.microsoft.com/kb/972715/ that talks about number not being unique but I am not sure if it applies unless the 4 digit normalization rule and the Line URI on the RCC profile are aware of each other somehow.  When dialing from an external cell phone and pressing #1 to enter extension and PIN number my test user gets the same results. 

    RCC profile:
    SIP URI: pgurman@ocs-cup@acme.com
    Line URI: tel:6209;phone-contect=dialstring

    Best Regards,
    Paul

    Tuesday, August 25, 2009 6:54 PM

  • Just a quick update. I haven't properly tried your solution matt as it's for a customer but I gave it a quick go and no joy.  When I get back there I'll spend some time on it and let you know.

    Cheers for the help.

    Keith.
    • Edited by -Keith- Tuesday, August 25, 2009 7:02 PM
    Tuesday, August 25, 2009 7:01 PM
  • We have discovered this exact same issue today while configuring the Conferencing Service. Users using RCC with CUPS cannot authenticate.

    I am trying to create a normalization rule to convert the extension from xxxx to xxxx;phone-context=dialstring to authenticate users with the extension/PIN combo. No luck so far.

    I am going to apply the July 2009 updates to the server this evening to see if that helps.

    Tuesday, August 25, 2009 10:04 PM
  • I got this working in the end. A normalization rule that didn’t trigger on dialed numbers worked, transforming xxxx to xxxx;phone-context=dialstring. We can now use CUPS and authenticate to meetings with the extension/PIN combo.

    The July 2009 updates are well worth applying for the conferencing service. The voice prompts are much more useful.

    Wednesday, August 26, 2009 2:10 PM

  • Nice one.

    I'll give the updates a go next time im with the customer.

    Cheers all.

    Keith.
    Wednesday, August 26, 2009 2:50 PM