locked
Outlook Unable to Configure on DIfferent Domains RRS feed

  • Question

  • Hello, every one.

    I have this issue when configuring Outlook Client for Dynamics CRM 2011.

    The configuration goes a half way and says there is an error communicating with server.

    I have the log file on client machine, it says:

    18:12:27|   Info| Query all rows in msg service table

    18:12:27|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.GetServiceIds

    18:12:27|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.GetCrmStoreServiceId

    18:12:27|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.DeleteV4CrmDatastore

    18:12:27|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.InitializeMapiStoreForFirstTime

    18:12:39|  Error| Exception : Server was unable to process request.    at Microsoft.Crm.MapiStore.DataStore.WaitInitialized()

       at Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.InitializeMapiStoreForFirstTime()

       at Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.Configure(IProgressEventHandler progressEventHandler)

       at Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure(Object stateInfo)

    18:12:39|  Error| Exception : Server was unable to process request. 

    18:12:41|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.Unconfigure

    18:12:41|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.Unconfigure

     

     

    Also, I have enabled trace, which gives following information at the same time:

    >Crm Exception: Message: Server was unable to process request., ErrorCode: -2147221221, InnerException: System.Net.WebException: The remote server returned an error: (401) Unauthorized.

       at System.Net.HttpWebRequest.GetResponse()

       at Microsoft.Crm.Application.SMWrappers.HttpSupport.Microsoft.Crm.Application.SMWrappers.IHttpSupport.LoadDataWithExtendedTimeout(String url)

       at Microsoft.Crm.MapiStore.ServerStore.<>c__DisplayClass2e.<FetchUIXml>b__2d()

       at Microsoft.Crm.MapiStore.DataStore.HandleServerFailures(Boolean specialPrivilegeDeniedHandling, Action action)

     

     

    I can use the CRM through IE correctly.

     

    Here are some my environment information:

    Server: windows 2008 server, sql server 2008, domain controller

    Client: windows 7, different domain than server domain.


    希意禧(上海)系统有限公司 CRM销售顾问 guochuangang@cec-ltd.cn 我们为在中日企提供专业的ERP和CRM解决方案,有兴趣请电邮查询。 シーイーシー(上海) CRM営業コンサルタント guochuangang@cec-ltd.cn弊社は在中日系企業に専門的なERPやCRMソリューションをご提供します。お気軽にメールください。
    Friday, April 8, 2011 10:26 AM

Answers

  • One of the few things to check if the CRM server is configured correctly. If credentials are indeed cached correctly, can try the following?

    1. Please check that you're running at least RTM versions of CRM server and client and that versions match (should be 5.0.9688.583)
    2. Is it possible to configure Outlook Client for CRM on the same domain? If so, it could help pinpoint the problem.
    3. You can try checking some authentication settings on IIS website itself, it's been known to cause some problems before.
    4. Go to the server and check authentication settings for website in IIS manager
      • Open inetmgr
      • Go to the Microsoft Dynamics CRM site -> Authentication
      • Enable Anonymous authentication
      • Do iisreset
    5. Enable Negotiate authentication for the website
      • Open inetmgr
      • Go to the Microsoft Dynamics CRM site
      • Select Authentication
      • Select Windows Authentication and add 'Negotiate' before NTLM
      • Do iisreset

    Also, take a look at this post in CRM Deployment forum

    http://social.microsoft.com/Forums/en-US/crmdeployment/thread/9942ea5f-52cc-4535-a3af-f93b6a5b1eb1/#3d539ade-e6d1-4259-9d8e-2a2

    • Marked as answer by Leo_GUO Wednesday, April 13, 2011 1:29 AM
    Tuesday, April 12, 2011 5:18 PM

All replies

  • If you are configuring across domains, you'll need to have at least a one-way trust relationship set between them.

    Alternatively, you can try caching the domain credentials on the machine itself:

    In Windows 7 the steps would be as follows (might differ a little for Vista or XP)

    1. Go to Control Panel
    2. Select User Accounts -> Manager Your Credentials
    3. Under Windows Credentials select 'Add a Windows credential
    4. Enter address servername (no need to add http)
    5. Enter your domain username and password
    Friday, April 8, 2011 5:15 PM
  • If you are configuring across domains, you'll need to have at least a one-way trust relationship set between them.

    Alternatively, you can try caching the domain credentials on the machine itself:

    In Windows 7 the steps would be as follows (might differ a little for Vista or XP)

    1. Go to Control Panel
    2. Select User Accounts -> Manager Your Credentials
    3. Under Windows Credentials select 'Add a Windows credential
    4. Enter address servername (no need to add http)
    5. Enter your domain username and password

     

    Hi, Alex. Thank you for your reply.

    Actually I have already done the caching of credentials.

    Before that, I cannot even retrieve the organization list. 

     

    After I cache the credentials, I can now retrieve the organization list, and select one to add it.

    But the adding process fails in middle way.

    Can you please give me some more advise? Thank you.

     

    Best regards


    希意禧(上海)系统有限公司 CRM销售顾问 guochuangang@cec-ltd.cn 我们为在中日企提供专业的ERP和CRM解决方案,有兴趣请电邮查询。 シーイーシー(上海) CRM営業コンサルタント guochuangang@cec-ltd.cn弊社は在中日系企業に専門的なERPやCRMソリューションをご提供します。お気軽にメールください。
    Monday, April 11, 2011 12:57 AM
  • I've the same issue here..any suggestions on this?

    Thanks,
    Peter

    Monday, April 11, 2011 7:59 AM
  • Any suggestions please?
    希意禧(上海)系统有限公司 CRM销售顾问 guochuangang@cec-ltd.cn 我们为在中日企提供专业的ERP和CRM解决方案,有兴趣请电邮查询。 シーイーシー(上海) CRM営業コンサルタント guochuangang@cec-ltd.cn弊社は在中日系企業に専門的なERPやCRMソリューションをご提供します。お気軽にメールください。
    Tuesday, April 12, 2011 1:57 AM
  • One of the few things to check if the CRM server is configured correctly. If credentials are indeed cached correctly, can try the following?

    1. Please check that you're running at least RTM versions of CRM server and client and that versions match (should be 5.0.9688.583)
    2. Is it possible to configure Outlook Client for CRM on the same domain? If so, it could help pinpoint the problem.
    3. You can try checking some authentication settings on IIS website itself, it's been known to cause some problems before.
    4. Go to the server and check authentication settings for website in IIS manager
      • Open inetmgr
      • Go to the Microsoft Dynamics CRM site -> Authentication
      • Enable Anonymous authentication
      • Do iisreset
    5. Enable Negotiate authentication for the website
      • Open inetmgr
      • Go to the Microsoft Dynamics CRM site
      • Select Authentication
      • Select Windows Authentication and add 'Negotiate' before NTLM
      • Do iisreset

    Also, take a look at this post in CRM Deployment forum

    http://social.microsoft.com/Forums/en-US/crmdeployment/thread/9942ea5f-52cc-4535-a3af-f93b6a5b1eb1/#3d539ade-e6d1-4259-9d8e-2a2

    • Marked as answer by Leo_GUO Wednesday, April 13, 2011 1:29 AM
    Tuesday, April 12, 2011 5:18 PM
  • One of the few things to check if the CRM server is configured correctly. If credentials are indeed cached correctly, can try the following?

    1. Please check that you're running at least RTM versions of CRM server and client and that versions match (should be 5.0.9688.583)
    2. Is it possible to configure Outlook Client for CRM on the same domain? If so, it could help pinpoint the problem.
    3. You can try checking some authentication settings on IIS website itself, it's been known to cause some problems before.
    4. Go to the server and check authentication settings for website in IIS manager
      • Open inetmgr
      • Go to the Microsoft Dynamics CRM site -> Authentication
      • Enable Anonymous authentication
      • Do iisreset
    5. Enable Negotiate authentication for the website
      • Open inetmgr
      • Go to the Microsoft Dynamics CRM site
      • Select Authentication
      • Select Windows Authentication and add 'Negotiate' before NTLM
      • Do iisreset

    Also, take a look at this post in CRM Deployment forum

    http://social.microsoft.com/Forums/en-US/crmdeployment/thread/9942ea5f-52cc-4535-a3af-f93b6a5b1eb1/#3d539ade-e6d1-4259-9d8e-2a2

    Thank you Alex. You link helped.

    After I change the url in deployment manager, the problem is gone.

    I guess adding the computer name to hosts file also can do, but I have not tried that.

     

    Best regards


    希意禧(上海)系统有限公司 CRM销售顾问 guochuangang@cec-ltd.cn 我们为在中日企提供专业的ERP和CRM解决方案,有兴趣请电邮查询。 シーイーシー(上海) CRM営業コンサルタント guochuangang@cec-ltd.cn弊社は在中日系企業に専門的なERPやCRMソリューションをご提供します。お気軽にメールください。
    Wednesday, April 13, 2011 1:31 AM