Can't install WINDOWS MEDIA CENTER CONNECTOR: "Incorrect Password" error RRS feed

  • Question

  • You cannot vote on your own post
    Well, I think I've tried everything ever suggested on this subject...to no avail!  All the patches and settings and switches anyone on the Internet has come up with fail to work on ANY on my PCs. I have 1 XP machine, 2 Vista, 1 WHS and 1 Win7 and the Media Center Connector software just won't run. One PC I can understand, but a Brand-Spanking-New Install of a freshly-bought copy of WINDOWS 7? (Count up the $$ for all these OSes.) Every time I run the setup its always "Incorrect Password" when I KNOW it's correct. Every time. On each machine. And everywhere I've looked its obvious to me that MS doesn't even understand what the problem is. The answers from the software's designer show that they think its either WHS Connector or RDP connections . Its the MEDIA CENTER CONNECTOR s/w, guys. The one that came with WHS Power Pack 2 and 3. And it doesn't work for many of us! I don't know if MS tech support monitors these forums, but I think it behooves them to find out what is going on, and try to fix it.

    I glad that some sufferers were able to resolve this problem. But, many of you had to endure ____ first. And yet MS still hasn't even acknowledged that its a serious bug and not just us fumbling end-users.

    Yeah, I'm mad. And I don't even know if this s/w will do anything for me...


    (btw: The password is my mother's name)

    P.S. Sorry about the gaff above. I didn't know h*ll was a forbidden word. It is, after all, where MS designers are headed to anyway, so who knew?
    Monday, November 2, 2009 5:56 PM

All replies

  • Hello Gary,
    it could be, if you uninstall the Windows Home Server Connector software and try to reinstall it again, you will face the same situation, that the password will not work as with the Media Center Connector.
    This can happen in some situations - I could imagine or have experienced scenarios like:
    If you installed some software on the server, which altered IIS settings or DCOM permissions. In this case you should find some related error messages or warnings in the Event lof of the server around the time of the failed installation.
    The date and time of the server are out of range with the client PCs. This can happen due to an empty motherboard battery, if the server is taken down for a while or because on a self built system the time zone is set to Pacific by default. An attempt to adjust the time will either not match the real time any more or correction of the time zone will alter the system time, if you are not correcting this also.
    Sometimes also something goes wrong with name resolution - if a server with the same name is located in the DNS domain, which may be configured as DNS or DNS Search Suffix, the client may attempt to authorize against that server instead of the server at your home - which fails.
    Access to shared folders on the server may not match, if you run the installation with User Account Control enabled on a Vista client, since elevated execution runs as local admin, which cannot access the shared folder on the server. Not sure, how the error message looks in this case.
    (The other reason, which makes connections via console or Remote Desktop fail, should not fit for the Media Center connector, but who knows - can you connect either way? If not, NVidia graphic card drivers on the server are often the culprit.)

    Without knowing your exact situation, which is hardly to interprete from your writing, it may be hard to nail down the exact cause.

    Best greetings from Germany
    Monday, November 2, 2009 8:50 PM
  • Hi Olaf,
    I have tried everything you suggested. I checked all of these things again since receiving your post. My server is named Server as in the default installation. WHS Connector connections and RDP work fine. I tried with UAC on and off. I do have nVidia drivers installed, but they are the latest and I tried running with on-motherboard video control without the nVidia card. The time is in sync on all PCs with Windows time server in Eastern Standard time (East coast USA). All this is to say I think I've tried it all, but I believe the MCC s/w is faulty and doesn't understand its own OSes ;) . For MCC to not work on 4 PCs means its either that s/w or WHS that has a defect. I don't know how to alter IIS or DCOM settings, but if you know of a program that messes (or fixes) these up I'll sure look into it.

    Thanks from Pennsylvania, USA,


    (P.S. Hey, what happened to the little medal I had last time I logged in? Did I get demoted 'cause of my little tirade?)
    Monday, November 2, 2009 9:44 PM
  • Hi Gary,
    I still can see your medal ;-)
    Can you log in to your server locally or via Remote Desktop and check the event log for warnings or errors around the time of the failed MC Connector installation attempt? Without such we will not come any further here. (I assume, a reboot of the server has already be attempted, if not, its sometimes worth a try.) The official recommended method (and in such minor cases most annoying) would be to attempt a server reinstall, run all upgrades, try again.

    (I had never use for this function, since I do not want to have all my temporary TV recordings stored on the server, so I have not tried it seriously. And MCE allows to add sources for videos, which can also be a share on the server - at least for Vista and Win7.)

    Best greetings from Germany
    Tuesday, November 3, 2009 10:18 AM