locked
WHS Remote Access Trouble RRS feed

  • Question

  •  

    I am having trouble setting up my remote access for my home server. I have a Belkin wireless g router. I set up my domain name and it says that everything is working. When I try to access my domain via the Internet, it tells me that (Internet Explorer cannot display the webpage). My router config is not setting up correctly either. I keep getting the same error messages (Verifying that your router is accepting Web site connections) and (Verifying that your router is accepting Remote Access connections). Does anyone know how to fix this problem or point me in the direction to fix it?  I do have Web Site Connectivity turned on also.

     

    Thank you,

     

    David

    Sunday, August 17, 2008 5:30 AM

Answers

  • Have you tested remote access from somewhere other than your home? The public library? The local Starbucks? Some routers don't deal properly with looping back to their external IP address from within the local network. You could also determine your external IP address (usually exposed in your router's configuration pages as internet IP, External IP or WAN IP) and try accessing that IP directly, e.g. http://www.xxx.yyy.zzz to make sure it's not a temporary problem with DNS.

    But it sounds like either you haven't set up port forwarding correctly, or possibly your ISP is blocking ports used by Windows Home Server. To set up port forwarding manually for your router (I don't advise relying on the UPnP port forwarding that WHS does, as many routers don't fully support UPnP even if they say they do) you should give your server a static IP address, then find the appropriate guide at Portforward.com and follow it, forwarding ports 80, 443, and 4125 to your server.

    If after that you still have problems with remote access, you can try testing the ports to see if your ISP is blocking them using ShieldsUp!. If ShieldsUp! reports STEALTH only for port 80, you should still be able to access your server using secure HTTP, e.g. https://<yourserver>.homeserver.com/remote. If ShieldsUp! reports STEALTH for port 443 as well, you can either try changing the ports that WHS uses or work with your ISP to determine what service plan (often a business plan) they offer that will allow your to use those ports. I would recommend working with your ISP first, as they can detect incoming traffic if they want to, and if running servers is against your terms of service, they could terminate your service or charge you retroactively to the beginning of your plan for a higher class of service.

    You may also want to read the Remote Access technical brief, available from the Windows Home Server support page.
    Sunday, August 17, 2008 12:33 PM
    Moderator

All replies

  • Hi David,

    check your router, if if has enabled port forwarding for the ports 80, 443, 4125 to the IP address of your home server and that the home server did not receive a different IP address since the configuration has been done. (Thats why I prefer to assign a fixed IP address to the Windows Home Server.)

    If you enter your domain name in a browser directly on the server desktop, does it work?

    If you do it from a workstation in the same subnet, does it work?

     

    In this case check the Windows Firewall on the server, that it allows also connections for computers from the Internet rather than only the local subnet to the exceptions mentioned. Should be autmatically configured, but sometimes wierd things are happening.

    Best greetings from Germany

    Olaf

    Sunday, August 17, 2008 9:43 AM
    Moderator
  • Have you tested remote access from somewhere other than your home? The public library? The local Starbucks? Some routers don't deal properly with looping back to their external IP address from within the local network. You could also determine your external IP address (usually exposed in your router's configuration pages as internet IP, External IP or WAN IP) and try accessing that IP directly, e.g. http://www.xxx.yyy.zzz to make sure it's not a temporary problem with DNS.

    But it sounds like either you haven't set up port forwarding correctly, or possibly your ISP is blocking ports used by Windows Home Server. To set up port forwarding manually for your router (I don't advise relying on the UPnP port forwarding that WHS does, as many routers don't fully support UPnP even if they say they do) you should give your server a static IP address, then find the appropriate guide at Portforward.com and follow it, forwarding ports 80, 443, and 4125 to your server.

    If after that you still have problems with remote access, you can try testing the ports to see if your ISP is blocking them using ShieldsUp!. If ShieldsUp! reports STEALTH only for port 80, you should still be able to access your server using secure HTTP, e.g. https://<yourserver>.homeserver.com/remote. If ShieldsUp! reports STEALTH for port 443 as well, you can either try changing the ports that WHS uses or work with your ISP to determine what service plan (often a business plan) they offer that will allow your to use those ports. I would recommend working with your ISP first, as they can detect incoming traffic if they want to, and if running servers is against your terms of service, they could terminate your service or charge you retroactively to the beginning of your plan for a higher class of service.

    You may also want to read the Remote Access technical brief, available from the Windows Home Server support page.
    Sunday, August 17, 2008 12:33 PM
    Moderator
  • Help me Obi-Wan KENobi, you're my only hope!

    My remote access stopped working a couple of weeks ago. Nothing had changed. Everything worked fine even though it did pass all of the tests. So I checked the list of compatible routers and went out and bought one (Netgear WNDR3300). Set to UPNP, let it do its thang, and still no go. I cannont even access the remote web site locally (I opened IE and typed in localhost). Nothing happened. I forwarded the ports manually. I checked all the settings in IIS (although I couldnt find where there might be something listening to port 80). I turned Windows Firewall off. I turned remote access off and back on. I repaired. I double checked everything. This is becoming a total PITA, and the worst part is that it was working with nothing touched. Every solution I have come across brings no results, and it seems to solution for every home server is different. Im kinda at my wits ends, thinking about getting my Linux book out and teaching myself Linux and Apache. Ideas?

    Mazter Jedi

    Afterthougts: Is there anyway to re-direct which ports are listened to? Any other words, can I tell the box to listen to port 8080 instead of 80? (it seems Cox blocks port 80, see http://support.cox.com/sdccommon/asp/contentredirect.asp to see yourself. My company uses a software package all the time that uses a web server that listens to port 80. Since the local ISP blocks port 80, we can simply tell the program to listen to port 8080 and all is well. What I dont get is how Sheilds Up! reports all ports are stealth except 443, which is open. It shows nothing is blocked. Aargh! Time for a beer.
    Friday, December 11, 2009 4:26 AM
  • It is not a good idea, to attach the own problem to a posting, which already has been marked as answered and is more than one year old.

    If you attempt accessing http://yourservername from within your home network and nothing comes up, you may have a problem with your Home Server itself.
    Usually the recommended method is to perform a server reinstall.
    If the connection worked before Power Pack 3 has been applied, it could also help, to login locally on the server and uninstall Power Pack 3 through control panel.
    Reboot, check, if access is working now and try reinstalling Power Pack 3 through Windows Update.
    Best greetings from Germany
    Olaf
    Friday, December 11, 2009 8:48 AM
    Moderator
  • Okay, I removed PP3, reboot, test, not working. Removed PP2, reboot, test, not working. Just out of curiosity, I opened IE and typed in localhost, and got nothing. I connected my laptop to my 3G connection, and attempted to login and got nothing. I did notice that it tried connecting to my current IP address, which I confirmed with the DynDNS updater, which I also tried with it disabled, and still nothing. I went thru and removed all updates installed after 11-1-09 (thats about when it stopped working) and still does not work. This is super annoying, considering all was working well and just stopped all of the sudden. I have heard I may need to do a server reinstall (which I shouldnt ever have to do for such a small problem, thanks Microsoft) but I am not comfortable with reinstalling simply because of the idea of losing all my data is unfathomable (which I cant backup, because the backup service has had an issue for quite a while). Are there any particular settings in IIS I should check? How safe is a server reinstall, and might you know how a guide? Thanks.
    Monday, December 28, 2009 11:46 PM
  • Okay, I removed PP3, reboot, test, not working. Removed PP2, reboot, test, not working. Just out of curiosity, I opened IE and typed in localhost, and got nothing. I connected my laptop to my 3G connection, and attempted to login and got nothing. I did notice that it tried connecting to my current IP address, which I confirmed with the DynDNS updater, which I also tried with it disabled, and still nothing. I went thru and removed all updates installed after 11-1-09 (thats about when it stopped working) and still does not work. This is super annoying, considering all was working well and just stopped all of the sudden. I have heard I may need to do a server reinstall (which I shouldnt ever have to do for such a small problem, thanks Microsoft) but I am not comfortable with reinstalling simply because of the idea of losing all my data is unfathomable (which I cant backup, because the backup service has had an issue for quite a while). Are there any particular settings in IIS I should check? How safe is a server reinstall, and might you know how a guide? Thanks.
    Server Reinstallation should not touch your data.  It formats only the OS partition, leaving the rest in tact.  As for how to do it, just boot from the DVD, make sure all of your hard drives show up in the Load Additional Storage Drivers screen, then select Server Reinstallation from the drop-down menu (do not select New Installation as that will wipe everything).  If it doesn't appear, make sure your primary drive is the first drive seen by WHS (usually done by plugging it into the first port on your mobo).
    Tuesday, December 29, 2009 2:49 AM
    Moderator