locked
Java client connection to CRM Online 2013 - issues RRS feed

  • Question

  • Hi guys,

    I've tried using the Java sample from the blog on MSDN (subject is "Integrating Microsoft Dynamics CRM 2011 Online with Java and other non-.Net Clients" - I can't post links for some reason right now - my account hasn't been 'verified') against a CRM 2013 Online instance and it doesn't appear to work.

    I posted the stack dump at the end of the post.

    Has anyone managed to get this working with 2013 Online?

    I've also tried using the Java sample from the 2011 SDK against it, but again with no sucess (error illustrated on stackoverflow.com, question subject is "Undeclared namespace prefix “wsx” error accessing MS Dynamics CRM Online (2011) access from Java").

    Has anyone had any positive experiences of using these two samples?

    Regards.


    • Edited by Mark Matten Monday, December 30, 2013 12:03 PM
    Monday, December 30, 2013 12:02 PM

All replies

  • Hi,

    did you manage to find a solution?

    Regards

    Saturday, March 1, 2014 9:26 PM
  • wsx error can resolve by below steps:

    src: http://blogs.msdn.com/b/dynamics-coe/archive/2013/09/21/integrating-microsoft-dynamics-crm-2011-online-with-java-and-other-non-net-clients.aspx

    • Exception detail: org.apache.neethi.builders.converters.ConverterException: com.ctc.wstx.exc.WstxParsingException: Undeclared namespace prefix "wsx"
    • Probable cause: the generated stub is declaring the "wsx" domain for some tags that are already embedded within some tags from the same domain and the domain is locally declared and not with a global prefix.
    • Proposed solution: edit the generated Organization Service stub "OrganizationServiceStub.java", search and replace:
      • wsx:MetadataReference by MetadataReference
      • wsx:MetadataSection by MetadataSection


    Tuesday, March 25, 2014 5:22 AM
  • Hi, I tried removing the wsx part from the xml in the OraganizationServiceStub but the error still prevails. Did anyone succeed in fixing that error?
    Tuesday, April 1, 2014 12:06 PM
  • If you are following the example and sdk, then you will also need to remove the wsx prefix from the DiscoveryServiceStub as well as the OrganizationServiceStub.  As soon as I removed the prefixes the example worked for me.

    Thanks,

    Brennan

    Tuesday, September 9, 2014 8:21 PM