locked
What client should I use in my PDA? RRS feed

  • General discussion

  • My company have the Office Communicator Server 2005 and I usually use the PC client (Microsoft Office Communicator vers. 1.0.559.224).

    Now I have a HTC TYTn II PDA with Windows Mobile 6.1 and I would like to install the proper client on it.

    However when I install the last MS Office Communicator Mobile 2007 R2 (from www.GetCoMo.com) when it try to connect to the server it says that the server version is not compatible (error code: 80ee0061).

    So I tried to install the old mobile client from http://www.microsoft.com/downloads/details.aspx?familyid=bc89ec5e-5f3b-47d2-955b-b0c1deac94d8&displaylang=en but when I try to install it on the PDA it says that is incompatible (probably it is for win mobile 5.0 and not for the 6.1).
     
    How can I do? Where I can find a mobile client that can be installed in my win mobile 6.1 PDA and that it is able to connect to the old Office Communicator 2005?

    Waiting for some suggestions/links
    Enzo

    Wednesday, August 5, 2009 12:45 PM

All replies

  • You did try to install this version?

    Windows Mobile 5.0 for Pocket PCs
    Downloadable file name: CommunicatorMobile_PPC50.msi.

    Otherwise you might try to use the OC 2007 Mobile version
    http://www.microsoft.com/downloads/details.aspx?familyid=2EEA3E24-F216-4887-92B0-F37D942E26E0&displaylang=en
    - Belgian Unified Communications Community : http://www.pro-exchange.be -
    Wednesday, August 5, 2009 3:41 PM
  • Thank you for your answer and for your help.

    Windows Mobile 5.0 for Pocket PCs (downloadable file name: CommunicatorMobile_PPC50.msi) WORKS properly!!! 


    I tried the OC 2007 Mobile version but, as the more recent R2 version, also that one, when it tries to connect to the server, gives a popup message saying "Cannot sign in. The server version is incompatible with Communicator Mobile. Contact your system administrator with this information".

    One more question:
    I succeded to make the client work with WM 5.0 using a TCP connection. If I try to choose the default TSL connection a popup windows says "Unable to connect to the server. Please check if correct certificates are installed".
    It is a matter of how is the Windows Communicator Server configured or I need to install on my PDA some certificate (that should be provided by the administrator of the Windows COmmunicator Server running in my company or what?).

    Waiting for an answer ....


    Kind regards
    Enzo

    Thursday, August 6, 2009 9:10 AM
  • An other question ...

    Every phone number displayed (and used) for a contact in CoMo has an added "0" number before (like if I would need to phone outside a local phone network), while this doesn't happens when I see the phone number from the contact's properties from outlook on my PC.
    It is a matter of how the Windows Communicator Server is configured?? DO I need to ask the administrator to do something to avoid this (otherwise when I try to make a call from CoMo, it fails because the used phone number is  not correct having the added "0" number before!).

    Let me know also regarding the TSL connection, please.

    Thanks
    Enzo
    Thursday, August 6, 2009 10:19 AM
  • Adding the '0' has in my opinion nothing to do with OCS configuration
    The Mobile device does not use OCS to call someone ... it uses the cellular network.
    If contacts do not have the leading zero then it might have something to do with your Mobile device configuration.

    What do you need to know about TLS?
    - Belgian Unified Communications Community : http://www.pro-exchange.be -
    Thursday, August 6, 2009 1:28 PM
  • Thank you again Dali.

    The phone numbers of the company people that are visible in the Win Communication Client should come from the Server (i don't have locally on my PDA that infos) but, while on PC I see the phone number correctly, from the client on PDA it has a "0" added before the number so when I try to contact the guy from the client communicator it starts a call with that wrong number ....??? I couldn't find any local setting in my PDA that could add that prefix on phone numbers ....

    Related to TLS, as I said, I succeded to make the client work with WM 5.0 using a TCP connection. However I'd prefer to choose the default TSL connection, but if I choose that option a popup windows says "Unable to connect to the server. Please check if correct certificates are installed".
    It is a matter of how is the Windows Communicator Server configured or I need to install on my PDA some certificate (that should be provided by the administrator of the Windows COmmunicator Server running in my company or what?)???.

    Thank you
    Enzo
    Thursday, August 6, 2009 2:59 PM
  • The prefix problem is a mistery to me, that seems very odd...

    For TLS you must make sure that the Root CA Cert is imported into the PDA.
    Possibly you need to import it into your PDA

    What CA has issued your EDGE Cert? You should request this info from your Administrator
    2 options
    - either you have an internal CA that issued the cert then you must almost certainly import the cert into the PDA
    - or either you have an external CA that issued the cert and then depending on the configuration of your PDA you might need to import the cert

    - Belgian Unified Communications Community : http://www.pro-exchange.be -
    Thursday, August 6, 2009 3:38 PM