locked
How to enable Remote Web Access in Windows XP SP3 RRS feed

  • General discussion


  • Got the problem after a clean slipstreamed xp sp3 install. Couldn't get the remote web access to work. There was no "Microsoft Terminal Services Client Control (redist)" in "Manage add-ons" to enable.

    After a new search of the problem on the web I stumbled on this solution:

    1. Copy the following two files from your slipstreamed xp sp3 installation media to a temp folder on your HDD (say c:\tsc):

            tscdsbl.ba_
            tscuinst.vb_

    If you use a downloaded xp sp3 installation file look on the web how to extract the two files. I'm not sure here but I think it involves extracting the whole installation file to your HDD (usually by running the installation file in a comman prompt with the modifier -x) and then grabbing the two files.


    2. Then in a command prompt standing in C:\tsc write the following:

            expand tscdsbl.ba_ tscdsbl.bat [RETURN]
            expand tscuinst.vb_ tscuinst.vbs [RETURN]


    3. After that run the two files by writing:

            tscdsbl.bat [RETURN]
            tscuinst.vbs [RETURN]

    4. Now start IE and try to remote access to your home server. You get the usual error message.

    5. Go to Tools -> Manage Add-ons. In the list "Currently loaded add-ons" you will now find "Microsoft RDP Client Control (redist)" and it's disabled. Enable it and try to remote access again.

    Hopfully this will work for you. It worked for me.

    I got the info from the following link:
    http://www.eggheadcafe.com/software/aspnet/33102353/addons-prompted-to-enab.aspx

    Reine
    Saturday, September 20, 2008 8:34 AM

All replies

  • Thanks for the info....been trying to fix this problem for weeks now....and now when i run the tscuinst.vsb i get a script error...TYPE MISMATCH 'MSCF'
    any clues?
    Gene
    Sunday, September 21, 2008 4:24 PM
  • Sorry Gene, havn't got the slightest idea.
    Anybody else?

    Reine
    Sunday, September 21, 2008 10:05 PM
  • Thank you so very much this worked!!!!!
    Kenneth
    Monday, November 24, 2008 10:08 PM
  • Reine, thanks a lot!!!
    Perfect, now it works!
    Very helpful! :)
    Wednesday, May 6, 2009 10:34 AM
  • Hi All,

    I've been fighting with this all day and have just come across a new solution that may help people in addition to these ideas.

    I installed the RDP7 client for Win XP Pro SP3 from the MS download site and this fixed the issue for me.

     

    Hope that helps other people!

    Friday, July 30, 2010 12:37 PM
  • OK, I have tried enabling all the ActiveX controls, downloaded the RPD7 client, added the local RemoteApp server to my trusted zone and I still get the page saying that the ActiveX control is either not installed or not enabled. No prompts to enable to install either. Any ideas?
    Friday, September 3, 2010 2:07 PM
  • OK, I have tried enabling all the ActiveX controls, downloaded the RPD7 client, added the local RemoteApp server to my trusted zone and I still get the page saying that the ActiveX control is either not installed or not enabled. No prompts to enable to install either. Any ideas?

    Same here, tried all the fixes but still not working.
    Sunday, November 6, 2011 1:12 PM