locked
Network printer problem RRS feed

  • Question

  •  

    I have vista home premium sp1.  I cannot print to a hpdeskjet 940c located and shared on a machine running windows 2000 pro.  I am using one care on the vista machine.  I also have an XP SP3 machine that can print to he 940c just fine.  I've turned on vista file & print sharing.  I can see the printer fine in network discovery plus the other 2 machines.  I just can't print to it.  HELP!!!
    Wednesday, July 2, 2008 2:50 AM

Answers

  • I moved your post to the firewall topic folder as the fact that the printer is located on a Windows 2000 machine means that the problem is with Windows File and Printer Sharing and not with the printer sharing feature within OneCare that makes it easier to share printers with other computers in your "Circle" which are running OneCare and subscribed with the same LiveID.

    To confirm that the problem is due to the OneCare firewall, open OneCare, click on change settings, and then disable the Firewall temporarily.

    If the printer works with the firewall off, try the following:

    Open OneCare.

    Click Change Settings

    On the firewall tab, click configure firewall

    If the network is shown as Public, click Change Location to change it to "Home or Work."

    Click the Advanced Settings button

    Click Network connections tab.

    If there are multiple active connections shown, you may need to disable the extras in your Windows network connections settings. (Network and Sharing Center, manage connections, in Vista; Right click My Network Places and select Properties on the Start menu in XP)

    On the Ports and Protocols tab, add a check mark next to File and Printer Sharing - for subnet and Internet if the first setting alone (after all of the above are verified) does not allow Sharing to work.

    If all of the above fail, please contact support.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

     

    Wednesday, July 2, 2008 4:46 PM
    Moderator