locked
IP Address changing on home server- stops remote access RRS feed

  • Question

  •  

    Twice now WHS has changed it's IP address on me causing me to have to up date my router to allow remote accessing.

     

    First time it took me some time to understand why I could not remote access any more

    (WHS gave me a warning it had quit working)

     

    Then next time of course I new right away what to do.

     

    This all happed while I was at home so no harm no faul.

     

    But my consern is if I am off site and trying to access when this happens. I will be SOL.

     

    Is there a way to make this IP address from changing?

     

    I can't find this any where.

     

    Any body no what to do?

     

    Please let me know.

    Sunday, January 27, 2008 5:02 AM

Answers

  • You will need to either use the UPnP features in WHS to set up your router, or if your router doesn't properly support UPnP, you'll have to configure your server with a static IP address. To do the latter, you will need to use Remote Desktop to connect to your WHS:
    • On any other PC on your network, upen the Run box, type MSTSC, and press Enter.
    • Enter the name of your WHS PC in the window that appears and press Enter again.
    • A Remote Desktop window should appear, and you should be asked for user ID and password. Use the user ID Administrator, and the password you set for your WHS when you initially set it up.
    • As an alternative, if you have a keyboard, video, and mouse connected, you can log in that way. (It's easier to recover if you make a mistake, as a matter of fact.)
    • In your remote desktop session, open a command prompt, type "ipconfig /all" and press Enter. Make note of the IP address (which will probably be something like 192.168.1.101), the subnet mask (which will almost certainly be 255.255.255.0), the default gateway and the DNS servers for your active network connection.
    • In your Remote Desktop session, go to the Start Menu. Select Control Panel, then Network Connections, then your active network connection. Right click your local connection, and select Properties.
    • Find Internet Protocol (TCP/IP) in the list. Select it and click on the Properties button.
    • On the General tab, select "Use the following IP address:", then fill in an IP address which is in your local subnet and is not part of the pool of addresses your router serves up via DHCP. Fill in the subnet mask you noted above, and the gateway. Make a note of the values you choose; if you get something wrong you will need to manually configure another PC with the same subnet, gateway, and DNS information to get at your WHS PC to change the informaiton.
    • Fill in the DNS servers you noted above under "Use the following DNS server addresses:". Click OK, and OK again.
    • Reboot your server (not really required, but a good idea).
    Sunday, January 27, 2008 6:07 AM
    Moderator

All replies

  • You will need to either use the UPnP features in WHS to set up your router, or if your router doesn't properly support UPnP, you'll have to configure your server with a static IP address. To do the latter, you will need to use Remote Desktop to connect to your WHS:
    • On any other PC on your network, upen the Run box, type MSTSC, and press Enter.
    • Enter the name of your WHS PC in the window that appears and press Enter again.
    • A Remote Desktop window should appear, and you should be asked for user ID and password. Use the user ID Administrator, and the password you set for your WHS when you initially set it up.
    • As an alternative, if you have a keyboard, video, and mouse connected, you can log in that way. (It's easier to recover if you make a mistake, as a matter of fact.)
    • In your remote desktop session, open a command prompt, type "ipconfig /all" and press Enter. Make note of the IP address (which will probably be something like 192.168.1.101), the subnet mask (which will almost certainly be 255.255.255.0), the default gateway and the DNS servers for your active network connection.
    • In your Remote Desktop session, go to the Start Menu. Select Control Panel, then Network Connections, then your active network connection. Right click your local connection, and select Properties.
    • Find Internet Protocol (TCP/IP) in the list. Select it and click on the Properties button.
    • On the General tab, select "Use the following IP address:", then fill in an IP address which is in your local subnet and is not part of the pool of addresses your router serves up via DHCP. Fill in the subnet mask you noted above, and the gateway. Make a note of the values you choose; if you get something wrong you will need to manually configure another PC with the same subnet, gateway, and DNS information to get at your WHS PC to change the informaiton.
    • Fill in the DNS servers you noted above under "Use the following DNS server addresses:". Click OK, and OK again.
    • Reboot your server (not really required, but a good idea).
    Sunday, January 27, 2008 6:07 AM
    Moderator
  •  xbsims wrote:

     

    Twice now WHS has changed it's IP address on me causing me to have to up date my router to allow remote accessing.

     

    First time it took me some time to understand why I could not remote access any more

    (WHS gave me a warning it had quit working)

     

    Then next time of course I new right away what to do.

     

    This all happed while I was at home so no harm no faul.

     

    But my consern is if I am off site and trying to access when this happens. I will be SOL.

     

    Is there a way to make this IP address from changing?

     

    I can't find this any where.

     

    Any body no what to do?

     

    Please let me know.

     

    I believe you need to understand that it is not the WHS that is doing this but rather your DHCP server in the router that is reasigning the address. Now there are a number of reason why this might occour. One is you have power down the WHS for a period of time. Now Ken solution will work.

     

    I believe if your router supports DHCP reservations that reservations are a better solution. This will keep the WHS to the same IP address, but if you replace your router, or change the confrigation of it, like changing the IP addresses it uses it will not leave your WHS disconnected. On a headless unit like the MediaSmart Server this can create real problems, or if you forget the IP address you assign the unit, or if you happen to type the wrong address in when trying to change it. Many Linksys routers support DHCP reservations, look for a button on the Basic Setup (tab). 

    Monday, January 28, 2008 4:12 PM
  • I'd highly suggest setting a Static LAN IP on the server.  You can follow our tutorial over at http://www.MyHomeServer.com on how to set a Static LAN IP - this shows how to set one using a very popular Linksys router setup.

    Hope this helps!

    http://www.MyHomeServer.com

    Monday, January 28, 2008 6:06 PM