locked
off topic - foreign language RRS feed

  • General discussion

  • When I do a search, I see english US and then some other foreign language along with it.  I've went to my browser, tools options, the only thing is there is english.  I've went to the live id section where I select english and update, yet I'm getting pretty upset about seeing this foreign language on my screen.  I was even on a web page and everything was in english except when it asked my to secret question and that was in a foreign language.

    Please help me.

    Sunday, January 13, 2008 11:27 PM

All replies

  • Go to http://account.live.com and verify that your LiveID profile contains your correct country.

    Go to tools/options in Internet Explorer and delete all temporary internet files and cookies.

    Close your browser and open it once again. Sign in at a LiveID enabled site and see if the problem is resolved. Note that search results often include sites that are in foreign languages, so you may always see that still.

    -steve

     

    Monday, January 14, 2008 2:40 AM
    Moderator