locked
MS CRM 2011 ONLINE - how to change unit quantities to whole number RRS feed

  • Question

  • So in our system, quantities are allways whole numbers and there will not be any decimals.

    Now when I add a product using order product form, the quantity allways get 5 decimals. I know those decimals come from the unit entity's quantity field. And that field is set to use 5 decimals. Unfortunately I can not custom that field because it is not customable.

    Is there any way to get of those decimals?

    Wednesday, October 23, 2013 4:55 AM

Answers

  • Hi,

       You can change this in the solution. Select Settings -> Solutions -> Select the right solution. Select right entity and the decimal field and change the Precision to 0. This will take care of the issue.


    Hope this helps.
     
    -----------------------------------------------------------------------
     Minal Dahiya
    blog : http://minaldahiya.blogspot.com.au/

     
    If this post answers your question, please click "Mark As Answer" on the post and "Vote as Helpful"

    Nope, I cannot edit that field.

    But the ansewer is Price list item. In there I can set this individually for every product. There is a option called quantity selling option. And this must be set to whole.

    • Marked as answer by crm-user-crm Wednesday, October 23, 2013 5:42 AM
    Wednesday, October 23, 2013 5:41 AM

All replies

  • Hi,

       You can change this in the solution. Select Settings -> Solutions -> Select the right solution. Select right entity and the decimal field and change the Precision to 0. This will take care of the issue.


    Hope this helps.
     
    -----------------------------------------------------------------------
     Minal Dahiya
    blog : http://minaldahiya.blogspot.com.au/

     
    If this post answers your question, please click "Mark As Answer" on the post and "Vote as Helpful"

    • Proposed as answer by Minal Dahiya Wednesday, October 23, 2013 5:14 AM
    Wednesday, October 23, 2013 5:14 AM
  • Hello,

    Once field is created you can't change it's data type so you have to look the workaround suggested by Minal above.


    Our Website | Our Blog | Follow US | My Facebook Page | Microsoft Dynamics CRM 2011 Application Design
    Make sure to "Vote as Helpful" and "Mark As Answer",if you get answer of your question.

    Wednesday, October 23, 2013 5:41 AM
    Moderator
  • Hi,

       You can change this in the solution. Select Settings -> Solutions -> Select the right solution. Select right entity and the decimal field and change the Precision to 0. This will take care of the issue.


    Hope this helps.
     
    -----------------------------------------------------------------------
     Minal Dahiya
    blog : http://minaldahiya.blogspot.com.au/

     
    If this post answers your question, please click "Mark As Answer" on the post and "Vote as Helpful"

    Nope, I cannot edit that field.

    But the ansewer is Price list item. In there I can set this individually for every product. There is a option called quantity selling option. And this must be set to whole.

    • Marked as answer by crm-user-crm Wednesday, October 23, 2013 5:42 AM
    Wednesday, October 23, 2013 5:41 AM
  • Nope, does not work for me.

    I'm on CRM2011 RU16

    Friday, August 29, 2014 9:27 AM